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หนัมาใช ้Excel จดัการฐานขอ้มลู 

แทน Access กนัดกีวา่ 

เนือ่งจากความงา่ยในการบนัทกึขอ้มลูลงไปในตาราง โปรแกรม Microsoft Excel จงึไมไ่ดเ้ป็น

เพยีงโปรแกรมซึง่มตีารางสําหรับเอามาใชคํ้านวณเทา่นัน้ Excel กลายเป็นโปรแกรมทีนํ่ามาใช ้

กบังานไดห้ลากหลายประเภท ไมจํ่ากดัเฉพาะงานบญัชกีารเงนิ แตย่งันํา Excel ไปใชบ้นัทกึ

ขอ้มลูตา่งๆนานา ซึง่ความสะดวกในการบนัทกึนีเ่อง กลบัทําใหข้อ้มลูถกูบนัทกึไวอ้ยา่งตามใจ 

แลว้นํามาใชง้านไดไ้มเ่ต็มที ่บางกรณีถงึกบันํามาใชง้านไมไ่ด ้ใชไ้ปใชม้าสกัพักถงึกบั

จําเป็นตอ้งเสยีแรงเสยีเวลาเริม่ตน้บนัทกึขอ้มลูกนัใหม ่บทความนีจ้งึขอแนะนําวธิคีดิ วธิี

ออกแบบตารางเก็บขอ้มลูทีถ่กูตอ้งใหท้ราบกนั 

ตน้เหตขุองปัญหาเกดิจากผูใ้ช ้Excel รูจั้ก Excel เพยีงผวิเผนิ ไมรู่ว้า่มคํีาสัง่บนเมนูหรอืมสีตูร

คํานวณอะไรบา้งเพือ่นําใชใ้นการหายอดรวมคําตอบเรือ่งทีต่อ้งการ สตูรทีรู่จั้กกนัดมีเีพยีงสตูร

บวกลบคณูหารกนัธรรมดา ผูใ้ช ้Excel จงึมกัออกแบบตารางแยกเก็บตวัเลขแตล่ะเรือ่งที่

ตอ้งการไวใ้นตารางตามแนวนอนหรอืแนวตัง้โดยเฉพาะ แลว้เมือ่ใดทีต่อ้งการหาตวัเลขยอดรวม 

จะไดบ้วกเลขรวมกนัตามแนวนอนหรอืแนวตัง้นัน้ วธินีีแ้มจ้ะทําใหเ้ห็นขอ้มลูเรือ่งนัน้ๆไดช้ดัเจน 

แตก่ลบัทําใหต้ารางมขีนาดใหญข่ึน้เรือ่ยๆ ตอ้งคอยเพิม่ตารางตามแถวนอนหรอืแถวตัง้ขึน้ใหม่

อยูต่ลอดเวลา ถา้เพิม่แถวตอ่ทา้ยตารางก็ไมค่อ่ยยุง่ยากนัก แตถ่า้ตอ้งแทรกแถวเขา้ไปในตาราง

เดมิ จะทําใหก้ระทบกบัโครงสรา้งตารางเดมิทัง้หมด ถงึกบัตอ้งสรา้งสตูรกนัใหมท่ัง้ตาราง

ทเีดยีว 
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สมมตวิา่ คณุตอ้งการใช ้Excel เก็บบนัทกึขอ้มลูการฝากถอนเงนิฝากธนาคาร ซึง่ฝากเงนิไวก้บั

ธนาคาร 3 แหง่ จะออกแบบตารางเก็บขอ้มลูอยา่งไรด ี

 

หรอืแบบนี ้
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แนวทางการใช ้Excel เก็บขอ้มลู 

พงึคดิเผือ่อนาคตไวเ้สมอวา่ ตารางทีอ่อกแบบไวต้อ้งสามารถรองรับกบัการปรับเปลีย่นเพิม่เตมิ

ประเภทของขอ้มลูทีบ่นัทกึ เชน่ เดมิเคยฝากถอนเงนิกบัธนาคารเพยีง 3 แหง่ ถา้ตอ้งการบนัทกึ

ธรุกรรมกบัธนาคารเพิม่เตมิอกีหลายแหง่ ตอ้งสามารถใชต้ารางเดมิบนัทกึไดใ้นทันทโีดยไมต่อ้ง

เปลีย่นหรอืแกไ้ขโครงสรา้งตารางหรอืแกไ้ขสตูร 

1. แยกตารางเก็บขอ้มลูออกจากตารางคํานวณหรอืตารางรายงาน โดยในตารางเก็บขอ้มลูนี้

เป็นขอ้มลูทีเ่กดิจากการพมิพบ์นัทกึลงไปเทา่นัน้ ไมม่สีตูรคํานวณใดๆทัง้สิน้ หา้ม Merge 

เซลล ์และไมจํ่าเป็นตอ้งกําหนด Format หรอืเปลีย่น Format ใหต้า่งไปจากเดมิ 

2. ใชต้ารางบนัทกึขอ้มลูไวใ้นชทีเดยีวแฟ้มเดยีว โดยบนัทกึรายการเพิม่ตามแนวนอนหรอืเพิม่ 

row (หา้มเพิม่ column ขอ้มลูใหมต่ามแนวตัง้) เพือ่บนัทกึรายการใหมต่อ่ทา้ยรายการเดมิที่

มอียูแ่ลว้ไปเรือ่ยๆ  

 

3. แทนทีจ่ะเพิม่ column เพือ่ใชเ้ก็บขอ้มลูเรือ่งนัน้ๆโดยเฉพาะ ซึง่ยอ่มทําใหม้ ีcolumn 

จํานวนมาก ขอใหใ้ช ้column เพือ่ระบชุือ่รายการกํากบัรายการนัน้ๆแทน จะทําใหป้ระหยดั

จํานวน column ลงไปไดม้าก และไมม่เีซลลท์ีเ่วน้ชอ่งวา่งไวโ้ดยไมเ่กดิประโยชน ์
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4. ตารางเก็บขอ้มลูมจีดุประสงคห์นึง่เพือ่ใชอ้า้งองิขอ้มลูเกา่ๆหรอืบนัทกึตามลําดบัเหตกุารณ์ที่

เกดิขึน้กอ่นหลงั ดงันัน้จงึหา้มแทรกรายการใหมเ่ขา้ไประหวา่งรายการเกา่ หรอืเมือ่เวลาผา่น

ไปแลว้ หา้มยอ้นไปแกไ้ขขอ้มลูเกา่ หรอืลบรายการใดๆทีบ่นัทกึไวอ้นัอาจทําใหไ้มส่ามารถ

ใชอ้า้งองิเพือ่ทราบถงึประวตัขิองขอ้มลู (เฉพาะเมือ่พบวา่ขอ้มลูทีบ่นัทกึไวผ้ดิพลาด จงึเป็น

ความจําเป็นตอ้งแกไ้ขขอ้มลูเกา่ และกอ่นทีจ่ะแกไ้ข ตอ้งจัดเก็บขอ้มลูเกา่ไวเ้ป็นหลกัฐาน

ดว้ยเสมอโดยจัดเก็บแยกเป็นแฟ้มตา่งหากหรอืพมิพล์งกระดาษเพือ่ใชเ้ป็นหลกัฐานในการ

แกไ้ข) 

5. ขอ้มลูทีบ่นัทกึในตารางหนึง่ๆ ตอ้งเป็นขอ้มลูทีม่คีวามสมัพันธห์รอืเกีย่วขอ้งเป็นเรือ่ง

เดยีวกนั โดยแยกตารางขอ้มลูเรือ่งอืน่ใหเ้ป็นอกีตารางหนึง่ เชน่ ตารางการฝากถอนเงนิ

ธนาคารก็ตอ้งมขีอ้มลูทีเ่กีย่วขอ้งกบัการฝากถอนเทา่นัน้ ไมค่วรนําขอ้มลูเกีย่วขอ้งกบัการรับ

จา่ยเงนิกบัลกูคา้หรอืเจา้หนีม้าไวก้บัตารางฝากถอนเงนิธนาคาร เวน้แตก่ารฝากถอนนัน้ทํา

ไปเพือ่รับจา่ยเงนิกบัลกูคา้หรอืเจา้หนีใ้นกําหนดเวลาเดยีวกนั เป็นเหตเุป็นผลทําใหส้ามารถ

นําขอ้มลูมาบนัทกึไวใ้นตารางเดยีวกนั 

6. ในแตล่ะตารางทีแ่ยกกนั แมเ้ป็นตารางตา่งเรือ่งกนัทีแ่ยกไวใ้นชทีหรอืแฟ้มตา่งกนัก็ตาม 

เชน่ ตารางลกูคา้ ตารางสนิคา้ หรอืตารางการขายประจําวนั ควรกําหนดใหใ้ช ้column ที่

ตรงกนัเก็บขอ้มลูเรือ่งเดยีวกนั เชน่ กําหนดให ้column แรกซา้ยสดุหรอื column ในลําดับที่

ตรงกนัของแตล่ะตาราง บนัทกึขอ้มลูเกีย่วกบัวนัที ่เลขรหสั หรอืขอ้มลูเรือ่งเดยีวกนัให ้

ตรงกนัทกุตาราง 

7. ขอ้มลูทีจั่ดเก็บในตารางบนัทกึขอ้มลู ตอ้งแยกรายละเอยีดใหส้ามารถใชใ้นการคน้หาหรอื

คํานวณหายอดทีต่อ้งการไดท้นัท ีเชน่ ขอ้มลูเกีย่วกบัชือ่นามสกลุ ควรแยกขอ้มลูใหม้ ี

column เฉพาะสําหรับบนัทกึคํานําหนา้ชือ่ แยกออกจาก column บนัทกึชือ่และ column 

บนัทกึนามสกลุ เพือ่ทําใหย้ดืหยุน่ในการคน้หาขอ้มลูเฉพาะชือ่ หรอืเฉพาะนามสกลุไดท้นัที

ในอนาคต 

8. โครงสรา้งตารางฐานขอ้มลูทีด่ ีตอ้งออกแบบตามกฎ 3 ขอ้ ดงันี ้

8.1. หวัตาราง (Field Name) ซึง่เป็นบรรทัดบนสดุของตาราง ตอ้งใช ้row เดยีวเทา่นัน้ 

หากตอ้งการบนัทกึหลายบรรทดั ใหใ้ชว้ธิกีดปุ่ ม Alt+Enter เพือ่พมิพข์อ้ความใน

บรรทดัใหมใ่นเซลลเ์ดยีวกนั 

8.2. ตอ้งม ีcolumn ใด column หนึง่ซึง่บนัทกึขอ้มลูแตล่ะรายการตดิตอ่กนัไปตลอดทกุ

เซลล ์หา้มเวน้เซลลว์า่ง โดยเฉพาะอยา่งยิง่ column ทีใ่ชบ้ันทกึชือ่หรอืเลขรหสั เพือ่

ใชกํ้ากบัแตล่ะรายการวา่เป็นรายการอะไรและไมซ่ํ้ากบัรายการอืน่ 
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8.3. หา้มนําตารางฐานขอ้มลูไปตดิกบัขอ้มลูอืน่ในเซลลอ์ืน่รอบขา้ง ใหเ้วน้ระยะไวอ้ยา่งนอ้ย 

1 เซลลร์อบขา้ง เพือ่ทําให ้Excel สามารถรูข้อบเขตของตารางจากพืน้ทีข่อ้มลูที่

ตดิตอ่กนัไปไดเ้อง โดยเฉพาะชือ่ตารางทีพ่มิพไ์วด้า้นบนเหนอืหวัตาราง ควรเวน้

ระยะหา่งจากหวัตารางไว ้1 row เชน่กนั 

9. ขอ้มลูเกีย่วขอ้งกบัวนัที ่ใหบ้นัทกึไวใ้น column ใด column หนึง่เพือ่กํากบัขอ้มลูทกุ

รายการ โดยบนัทกึในโครงสรา้งของ วนัที/่เดอืน/ปีค.ศ.4 หลกั เชน่ 14/2/2011 เสมอ (ไม่

ควรบนัทกึแคเ่ลขวนัทีห่รอืชือ่เดอืน) เพือ่ชว่ยใหส้ามารถหายอดรวมแยกประเภทไดต้ามวนั 

เดอืน หรอืปีทีต่อ้งการไดด้ว้ยสตูรหรอืคําสัง่บนเมนูไดท้นัท ี

10. ขอ้มลูเรือ่งปรมิาณ จํานวน เลขรหสั ตอ้งบนัทกึแบบตวัเลขเทา่นัน้ เชน่ จํานวนสนิคา้ 20 กก 

ใหบ้นัทกึเฉพาะตวัเลข 20 ลงไปในเซลลเ์ทา่นัน้ ถา้รหสัเป็นตวัเลขและมเีลขศนูยนํ์าหนา้ 

เชน่ 00123 ใหบ้นัทกึเฉพาะเลข 123 แลว้กําหนดรปูแบบตวัเลขเป็น 00000 (อยา่พมิพ ์

‘00123 เพราะ Excel จะรับรูว้า่เป็นตวัอกัษรแทน) หรอืกําหนดใหใ้ชเ้ลขรหสัที ่Excel รับรูว้า่

เป็นตวัอกัษรโดยใชต้วัอกัษรนําหนา้เลขศนูย ์เชน่ a00123 

11. ในกรณีทีม่ขีอ้มลูซํ้ากนัหลายรายการซึง่โดยทัว่ไปสตูร VLookup ใน Excel จะสามารถ

คน้หาเฉพาะรายการแรกเทา่นัน้ ใหแ้กไ้ขโดยสรา้ง column ใหมเ่พือ่ปรับรหสัเดมิทีซ่ํ้ากนัให ้

เป็นรหสัใหมท่ีไ่มซ่ํ้าโดยนําเลขลําดบัทีข่องรายการไปตอ่ทา้ยรหสัเดมิ ซึง่แมว้า่จะทําให ้

แฟ้มมขีนาดใหญข่ึน้ แตจ่ะชว่ยใหส้ามารถใชส้ตูร VLookup ไดง้า่ยและใชเ้วลาคํานวณเร็ว

กวา่ทีจ่ะใชส้ตูรยากๆยาวๆเพือ่หาคา่ซํา้ 

 

12. แมเ้ซลลใ์ดทีย่งัไมท่ราบตวัเลขขอ้มลู ขอใหบ้นัทกึเลข 0 แทนไวก้อ่น หา้มปลอ่ยเซลล์

ตวัเลขใดๆเวน้ไวเ้ป็นเซลลว์า่ง เพราะถา้เป็นเซลลว์า่งจะทําให ้Pivot Table นําขอ้มลูเรือ่ง

นัน้ไปสรปุแบบ Count แทนทีจ่ะเป็น Sum 
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การแบง่ขอบเขตตารางแบบ I-C-O 

ในชทีหนึง่ๆของ Excel 2007 หรอื Excel 2010 มจํีานวน row มากกวา่ 1 ลา้น row และมี

จํานวน column มากกวา่ 1 หมืน่ column เปิดโอกาสใหใ้ช ้Excel เก็บขอ้มลูไดม้ากขึน้กวา่เดมิ

หลายเทา่ตวั แตโ่อกาสทีเ่ปิดกวา้งนีก้ลบัทําใหผู้ท้ีใ่ช ้Excel บนัทกึขอ้มลูอยา่งตามใจ สรา้ง

ปัญหารนุแรงมากขึน้ พอใชง้านไปไดส้กัพักก็จะพบวา่แฟ้มเริม่มขีนาดใหญข่ึน้เรือ่ยๆ แลว้ใช ้

เวลาในการคํานวณนานหลายชัว่โมง ครัน้จะแกไ้ขก็ถงึกบัตอ้งเริม่ตน้บนัทกึขอ้มลูกนัใหม ่สรา้ง

สตูรกนัใหมท่ัง้หมดทเีดยีว 

ผูใ้ช ้Excel สว่นใหญม่กัใช ้Excel แบบผดิเหมอืนๆกนั น่ันคอืสรา้งตาราง Excel เลยีนแบบตาม

หนา้ตารายงานทีต่อ้งการ มทีัง้ขอ้มลูทีก่รอกลงไปและมสีตูรคํานวณทีส่รา้งปะปนกนัไวใ้นตาราง 

ถา้รายงานทีต่อ้งการม ี100 หนา้ ก็จะสรา้งตาราง Excel ใหม้พีืน้ทีแ่สดงทัง้ 100 หนา้ลงไป สว่น

รายงานทีต่อ้งแสดงตามกําหนดเวลา ทกุวนั ทกุเดอืน ทกุปี ก็มกัสรา้งตารางแยกแสดงแตล่ะวนั 

แตล่ะเดอืน แตล่ะปี ออกจากกนั ในแฟ้มหนึง่จงึมชีทีหลายชที อยา่งนอ้ยก็ตอ้งม ี12 ชทีตาม

รายเดอืนทัง้ 12 เดอืน พอขึน้ปีใหมก่็เปิดแฟ้มใหมข่ึน้อกีและในแฟ้มนัน้ก็ม ี12 ชที นานไปจะมี

แฟ้มทีต่อ้งเก็บไวเ้ต็มไปหมด ครัน้จะหายอดตวัเลขคําตอบ ตอ้งวุน่วายคดัลอกตวัเลขจากแฟ้ม

นัน้ชทีนีม้าแปะตอ่ๆกนั หากตอ้งการปรับสตูรคํานวณก็ตอ้งไลแ่กส้ตูรทีส่รา้งไวใ้นทกุชทีทกุแฟ้ม

ใหเ้หมอืนกนัทัง้หมด ถา้พลัง้เผลอไมไ่ดแ้กไ้ขสตูรครบทกุเซลล ์ยอ่มทําใหผ้ลลพัธท์ีคํ่านวณได ้

ผดิบา้งถกูบา้ง พอทํางานแบบเครยีดไปวา้วุน่ใจไปไดส้กัพัก ลาออกก็กลายเป็นทางออกสดุทา้ย 

วธิกีารใช ้Excel ทีถ่กูตอ้ง มไิดต้า่งจากการใชโ้ปรแกรมคอมพวิเตอรอ์ืน่ๆทีส่รา้งขึน้มาใชก้นั น่ัน

คอื ตอ้งหาทางสรา้งสตูรขึน้มาใชง้านเพยีงสตูรเดยีวหรอืตารางเดยีว เมือ่ตอ้งการปรับปรงุแกไ้ข

สตูร จะไดแ้กไ้ขไดท้นัททีีจ่ดุเดยีว จากนัน้จงึสง่ผลคํานวณออกไปสรา้งเป็นตารางรายงาน ถา้

รายงานม ี100 หนา้ ใหส้รา้งตารางรายงานขึน้เพยีงตารางเดยีวหนา้เดยีว แตต่อ้งสามารถปรับ

สตูรคํานวณใหด้งึขอ้มลูมาคํานวณแลว้แสดงคําตอบไดต้ามเลขหนา้ทีต่อ้งการ 

สมมตวิา่ในแตล่ะหนา้ม ี30 บรรทดั พอพมิพเ์ลขหนา้ที ่1 ลงไป รายงานก็จะแสดงคําตอบของ

หนา้แรกตัง้แตบ่รรทดัที ่1 ถงึ 30 พอเปลีย่นเลขหนา้ไปเป็นหนา้ 2 ก็แสดงบรรทดัที ่31 ถงึ 60 

พอเปลีย่นเลขหนา้ไปเป็นหนา้ 3 ก็แสดงบรรทดัที ่61 ถงึ 90 แลว้ใหทํ้าเชน่นีเ้รือ่ยไปโดยผูใ้ชม้ี

หนา้ทีเ่พยีงอยา่งเดยีวคอืพมิพเ์ลขหนา้ทีต่อ้งการ 
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(สําหรับผูท้ีส่งสยัวา่จะหาเลขบรรทดัเริม่ตน้แตล่ะหนา้ไดอ้ยา่งไร ขอใหใ้ชส้ตูรคํานวณหาเลข

เริม่แตล่ะหนา้ = ((เลขหนา้ – 1)*จํานวนบรรทดัตอ่หนา้) + 1) 

ดาวนโ์หลดแฟ้มตวัอยา่งทีแ่สดงวธิใีชง้านตามทีอ่ธบิายนีไ้ดจ้าก 

http://www.excelexperttraining.com/extreme/files/timeplan/productsummary.xls 

องคป์ระกอบสําคญัในการออกแบบพืน้ทีก่ารใชต้าราง Excel ตอ้งเริม่จากรูจั้กแบง่พืน้ทีต่าราง

เป็น 3 สว่น เรยีกยอ่ๆวา่ I-C-O ดงันี ้

1. ตาราง Input หรอื ตารางฐานขอ้มลู ใชสํ้าหรับบนัทกึขอ้มลูทัง้ตวัเลขและตวัอกัษรลงไป 

หา้มสรา้งสตูรลงไปในในตารางนี ้และตอ้งออกแบบโครงสรา้งใหเ้ป็นฐานขอ้มลูทีด่ ีตามที่

ไดอ้ธบิายไวแ้ลว้ในตอนตน้ 

2. ตาราง Calculate หรอื ตารางคาํนวณ ใชสํ้าหรับสรา้งสตูรคํานวณ ตอ้งหาทางสรา้งสตูร

ลงไปไปในเซลลห์วัมมุตารางเพยีงเซลลเ์ดยีวแลว้เมือ่คดัลอกสตูรนี ้ตอ้งสามารถนําไปใช ้

คํานวณไดก้บัทกุเซลลใ์นตาราง ซึง่โดยทัว่ไปผูท้ีจ่ะสรา้งสตูรแบบนีไ้ดต้อ้งรูจั้กเลอืกใส่

เครือ่งหมาย $ กํากบัตําแหน่งอา้งองิหรอืใชร้ว่มกบัสตูร IF หรอืสตูรคํานวณตามเงือ่นไขอืน่ๆ 

เพือ่ทําใหส้ตูรปรับการคํานวณตามเงือ่นไขทีอ่าจแตกตา่งกนัในแตล่ะสว่นของพืน้ทีต่าราง 

3. ตาราง Output หรอื ตารางรายงาน ใชสํ้าหรับแสดงผลลพัธใ์นแบบรายงานทีต่อ้งการให ้

ปรากฏบนหนา้จอหรอืสัง่พมิพ ์

ในงานหนึง่ๆควรมตีารางคํานวณกบัตารางรายงานแตล่ะประเภทเพยีงหนา้เดยีวชทีเดยีวเทา่นัน้ 

สว่นตารางฐานขอ้มลูอาจแบง่เป็นหลายตารางเพือ่ใหเ้ลอืกดงึขอ้มลูจากฐานขอ้มลูทีเ่กีย่วขอ้ง

ไดเ้มือ่ตอ้งการ โดยแบง่เก็บไวเ้ป็นหลายชทีหรอืหลายแฟ้มก็ได ้

ในระยะแรกชว่งทีข่อ้มลูยงัมปีรมิาณไมม่าก อาจใชช้ทีเดยีวสําหรับ I-C-O ทัง้หมด โดยแบง่ให ้

ใชพ้ืน้ที ่column ดา้นซา้ยสําหรับเก็บขอ้มลู แลว้ใช ้column สว่นกลางๆสําหรับคํานวณ แลว้สง่

ผลลพัธอ์อกไปสรา้งรายงานจัดหนา้ตาตามทีต่อ้งการไวใ้น column ดา้นขวาสดุ ตอ่มาเมือ่

ปรมิาณขอ้มลูเริม่มากขึน้ก็ใหย้า้ยแยกแตล่ะสว่นของ I-C-O ไวใ้นชทีของแตล่ะสว่นเอง จน

สดุทา้ยเมือ่แฟ้มมขีนาดใหญข่ึน้สง่ผลทําใหคํ้านวณชา้ลง จงึยา้ยชทีออกไปเป็นแฟ้มทีล่งิคก์นั

ระหวา่งแฟ้ม Input แฟ้ม Calculate และแฟ้ม Output 
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วธิจีดัเตรยีมพืน้ที ่I-C-O 

แทนทีจ่ะปลอ่ยใหผู้ใ้ชง้านซึง่อาจเป็นผูส้รา้งงานเองหรอืไมก่็ตาม มาเปิดใชแ้ฟ้มแลว้แกไ้ปแก ้

มาจนสตูรทีส่รา้งไวถ้กูบนัทกึขอ้มลูทบัเสยีไป ผูส้รา้งงานควรจัดเตรยีมพืน้ที ่I-C-O แตล่ะสว่น

ใหพ้รอ้มตอ่การใชง้าน ดังนี ้

1. ตาราง Input หรอืตารางฐานขอ้มลู ใหเ้ลอืกเฉพาะพืน้ทีซ่ ึง่จะเปิดยอมใหบ้นัทกึคา่ใหม่

ทบัลงไปได ้แลว้คลกิขวาสัง่ Format Cells > Protection > ตดักาชอ่ง Locked ทิง้

ไป จากนัน้สัง่ Review > Protect Sheet แลว้จะพบวา่เมือ่กดปุ่ ม Tab จะเลือ่น cursor 

ไปตามเซลลท์ีไ่มไ่ด ้lock ใหเ้องทลีะเซลล ์

2. ตาราง Calculate และตาราง Output ควรกําหนดใหพ้ืน้ทีใ่นตารางเหลา่นีถ้กูป้องกนั

ไมใ่หบ้นัทกึคา่ใหมท่บัลงไปและป้องกนัไมใ่หส้ตูรในเซลลป์รากฏใหเ้ห็นในชอ่ง Formula 

Bar โดยเริม่จากเลอืกพืน้ทีต่ารางแลว้คลกิขวาสัง่ Format Cells > Protection > กา

ชอ่ง Locked ไวต้ามเดมิแลว้กาชอ่ง Hidden เพิม่ลงไป จากนัน้สัง่ Review > 

Protect Sheet 

นอกจากนัน้ควรกําหนดสใีนพืน้ทีแ่ตล่ะสว่นใหต้า่งกนั เชน่ เซลล ์Input กําหนดใหใ้ช ้font สี

ชมพ ูสว่นเซลลส์ตูรทีล่งิคข์า้มชทีใหใ้ชส้น้ํีาเงนิ เซลลส์ตูรทีล่งิคข์า้มแฟ้มมาใหใ้ชส้เีขยีวเป็นตน้ 

อกีทัง้อาจซอ่นชทีทีเ่ป็นตาราง Calculate แลว้สัง่ Review > Protect Workbook ก็จะไมม่ี

ใครสามารถเปิดดชูทีทีถ่กูซอ่นไวเ้วน้แตจ่ะกรอกรหสัผา่นไดถ้กูตอ้งกอ่น 

หากตอ้งการคน้หาตําแหน่งของเซลลท์ีบ่นัทกึคา่ไวเ้ป็น

ตวัเลข หรอืตวัอกัษร หรอืเซลลท์ีม่สีตูร ใหใ้ชว้ธิกีดปุ่ ม 

F5 > Special แลว้เลอืกกาชอ่งตามประเภทขอ้มลูที่

ตอ้งการคน้หา โดยถา้เลอืกเซลลเ์ดยีวไว ้เมือ่ใชคํ้าสัง่

นีจ้ะทําการคน้หาใหท้กุเซลลใ์นชทีนัน้ หรอืถา้ตอ้งการ

ใหค้น้หาเฉพาะในพืน้ทีท่ีต่อ้งการ ตอ้งเลอืกพืน้ที่

ตารางสว่นทีต่อ้งการไวก้อ่น 
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วธิเีพิม่ลดสาระสาํคญัของขอ้มลูทีบ่นัทกึไว ้

ผูใ้ช ้Excel อาจบนัทกึขอ้มลูขาดบา้งเกนิไปบา้ง เนือ่งจากขาดความรูเ้รือ่งสตูรหรอืนกึไปเองวา่ 

Excel สามารถหาคําตอบไดท้กุเรือ่ง ทําใหล้ะเลยไมบ่นัทกึขอ้มลูทีค่วรจะบนัทกึซํ้า หรอืบนัทกึ

ซํ้าจนเลยเถดิเกนิไป โปรดพจิารณาตารางฐานขอ้มลูในรปูตอ่ไปนี ้

 

จากตารางนี ้จะพบวา่ผูบ้นัทกึขอ้มลูละเลยไมไ่ดบ้นัทกึเซลลว์ันที ่9/5/2011 และ 11/5/2011 

ใหค้รบทกุรายการและไมไ่ดบ้นัทกึชือ่ธนาคาร BBL ในรายการถอน เพราะอาจเห็นวา่เป็นรายการ

ทีเ่กดิขึน้ในวันทีเ่ดยีวกนัหรอืเป็นรายการของธนาคารเดยีวกนักบัรายการทีบ่นัทกึไวแ้ลว้ตดิๆกนั

ขา้งบน ซึง่แมจ้ะไมผ่ดิหลกัการออกแบบฐานขอ้มลูทีด่แีละผูใ้ชต้ารางนีย้งัเขา้ใจชดัเจนวา่เป็น

รายการของวนัทีใ่ดและของธนาคารใดก็ตาม แตเ่ซลลช์อ่งทีเ่วน้วา่งไว ้กลับทําใหส้ตูรหรอืคําสัง่

ของ Excel ทีม่อียู ่ไมส่ามารถนํามาใชง้านไดแ้มแ้ตน่อ้ย 

สตูรและคําสัง่ของ Excel จะนํามาหาคําตอบไดต้อ่เมือ่แตล่ะรายการมขีอ้มลูบนัทกึไวค้รบถว้น 

โดยเฉพาะขอ้มลูทีเ่ป็นสาระสําคญั ตอ้งมไีวก้าํกบัรายการเพือ่แสดงถงึความแตกตา่งของ

รายการแตล่ะรายการ เชน่ ขอ้มลูซึง่เกีย่วขอ้งกบัรหสั ชือ่ วนัที ่หรอืขอ้มลูทีจ่ะนํามาใชเ้ป็น

เงือ่นไขในการคํานวณ ตอ้งบนัทกึกํากบัแตล่ะรายการไวเ้สมอ หา้มละเลยเวน้เป็นเซลลว์า่งไว ้

เป็นอนัขาด 

หากตารางใดมเีซลลว์า่งและตอ้งการนําขอ้มลูมาเตมิลงไปใหเ้ต็ม โดยนําขอ้มลูจากรายการ

ดา้นบนทีต่ดิกนัมาเตมิบนัทกึลงไปในเซลลว์า่งดา้นลา่ง ใหแ้กไ้ขพรอ้มกนัทัง้ตาราง ดงันี ้
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1. เลอืกพืน้ทีต่ารางใหค้รอบคลมุถงึเซลลว์า่งทีต่อ้งการแกไ้ข เชน่ในตวัอยา่งนีค้อืพืน้ทีจ่าก

เซลล ์B3:C9 

2. กดปุ่ ม F5 > Special แลว้กาชอ่ง Blanks เมือ่กดปุ่ ม OK จะพบวา่ Excel เลอืกเฉพาะเซลล์

ทีว่า่งใหท้ัง้หมด 

3. ใหพ้มิพเ์ครือ่งหมาย = แลว้คลกิเซลลด์า้นบนทีต่ดิกนั น่ันคอืเซลล ์B3 

4. กดปุ่ ม Ctrl พรอ้มกบั Enter จะพบวา่ Excel สรา้งสตูรลงิคนํ์าขอ้มลูเซลลด์า้นบนทีต่ดิกนัมา

ใสล่งไปในเซลลว์า่งจนครบทกุเซลล ์

5. สัง่ Copy พืน้ทีต่ารางทัง้หมดแลว้ Paste Special ทบัทีเ่ดมิแบบ Value เพือ่ทําลายสตูรให ้

กลายเป็นขอ้มลู 

คราวนีม้าดตูารางขอ้มลูทีบ่นัทกึซํ้าเกนิไปกนับา้ง 

 

ตารางนีเ้ป็นตารางบนัทกึการซือ้สนิคา้จาก supplier เชน่ รายการแรกเป็นรายการซือ้สนิคา้ทีม่ี

รหสั a001 ชือ่สนิคา้คอื aaa ซือ้เขา้มาจํานวน 100 ชิน้ โดยซือ้มาจาก supplier ทีม่รีหสั s001 

ซึง่มชีือ่ supplier วา่ sfk  

สาเหตทุีต่ารางนีถ้กูเรยีกวา่ Flat Database เนือ่งจากเป็นตารางซึง่เก็บทกุเรือ่งไวใ้นรายการ

เดยีวกนั ทําใหใ้นการบนัทกึการซือ้สนิคา้รายการหนึง่ๆตอ้งใชเ้ซลล ์5 เซลลเ์รือ่ยไป 

ทัง้นีข้อ้มลูสว่นทีเ่ป็นรหสักบัชือ่ ไมว่า่จะเป็นรหสัสนิคา้กบัชือ่สนิคา้ หรอืรหสั supplier กบัชือ่ 

supplier คอืสิง่ทีต่อ้งเป็นไปดว้ยกนัเสมอ รหสัหนึง่ก็ตอ้งใชกํ้ากบัชือ่หนึง่อยูแ่ลว้ ดงันัน้การ

บนัทกึรหสักบัชือ่ไวใ้นรายการเดยีวกนัเรือ่ยไป จะทําใหแ้ฟ้มมขีนาดใหญข่ึน้โดยไมจํ่าเป็น 

แทนทีจ่ะบนัทกึขอ้มลูการซือ้สนิคา้ไวใ้นตารางเดยีว ใหแ้ยกออกเป็น 3 ตาราง ดงัรปูตอ่ไปนี ้
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ตารางขอ้มลูสนิคา้และตารางขอ้มลูผูข้าย เป็นตารางเก็บขอ้มลูซึง่คอ่นขา้งจะคงที ่ไมค่อ่ยมกีาร

เปลีย่นแปลง ไมว่า่จะมกีารแกไ้ขหรอืเพิม่ลดก็แทบจะไมเ่กดิขึน้หรอืหากจะมกี็นานๆครัง้เทา่นัน้ 

สว่นตารางขอ้มลูสนิคา้ทีซ่ ือ้ตา่งหากเป็นตารางทีจ่ะมกีารบนัทกึตอ่ทา้ยรายการสดุทา้ยไปเรือ่ยๆ

ทกุครัง้ทีม่กีารซือ้สนิคา้เขา้มา (หากปรับใหส้มบรูณ์ควรมวีนัทีกํ่ากบัแตล่ะรายการดว้ย แต่

ตวัอยา่งนีม้เีพือ่ทําใหเ้ขา้ใจหลกัการพจิารณาไดง้า่ยขึน้ในขัน้แรกเทา่นัน้) 

แมจ้ะมจํีานวนตารางเพิม่ขึน้ แตจ่ะพบวา่ในการบนัทกึการซือ้สนิคา้รายการหนึง่ๆ คราวนีใ้ชเ้พยีง 

3 เซลลเ์ทา่นัน้ ในระยะยาวยอ่มทําใหแ้ฟ้มมขีนาดทีเ่พิม่ขึน้ในอตัราทีน่อ้ยกวา่การบนัทกึลงไป

ในตารางเดยีวแบบ Flat 

จดุออ่นของการออกแบบตารางแบบนี ้คอื ทําใหค้น้หาขอ้มลูทัง้หมดทีต่อ้งการไดย้ากขึน้เพราะ

ไมส่ามารถดขูอ้มลูไดพ้รอ้มกนัในตารางเดยีว ตอ้งอาศยัสตูรดงึขอ้มลูจากหลายตารางมาแสดง

รว่มกนัในภายหลงั โดยผา่นขอ้มลูทีม่คีวามสมัพันธก์นัระหวา่งตาราง จงึเรยีกฐานขอ้มลูแบบนีว้า่ 

Relational Database ซึง่ในตวัอยา่งนีใ้ช ้ID และ SId เป็นรหสัเชือ่มโยงทีใ่ชด้งึขอ้มลูระหวา่ง

ตารางดว้ยสตูร 

หากสนใจวธิกีารออกแบบตารางแบบ Relational Database โปรดศกึษาเพิม่เตมิจากหนังสอื

การจัดการฐานขอ้มลู หรอืเรือ่ง Database Normalization 
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เมือ่ใดจะใช ้Flat หรอืเมือ่ใดจะใช ้Relational Database 

ถา้มองในแงก่ารจัดการฐานขอ้มลูทีด่ ีการออกแบบฐานขอ้มลูแบบ Relational Database ยอ่ม

สอดคลอ้งตรงตามหลกัการ แตจ่ะทําใหก้ารใช ้Excel ขาดความยดืหยุน่ โดยเฉพาะผูท้ีข่าด

พืน้ฐานเรือ่งสตูรและคําสัง่ที ่Excel มอียู ่มองไมอ่อกวา่จะนําขอ้มลูมาใชป้ระโยชนใ์หเ้ต็มทีไ่ด ้

ดว้ยวธิใีด 

สว่นตารางฐานขอ้มลูแบบ Flat Database แมว้า่มขีอ้มลูซํ้าซอ้นและทําใหแ้ฟ้มมขีนาดใหญ ่แต่

จะทําใหผู้ใ้ชง้านทีใ่ช ้Excel ไมเ่กง่นัก เชน่ ผูบ้รหิาร หรอืพนักงานทัว่ไปสามารถนําขอ้มลูมาใช ้

ประโยชนไ์ดท้นัท ี 

Flat Database เหมาะสําหรับธรุกจิทีม่ปีระเภทสนิคา้ไมม่ากนักและราคาแพง เชน่ บา้น 

ทีด่นิ รถยนต ์เครือ่งประดบั โดยบนัทกึเพิม่รายการสนิคา้ตามวนัทีรั่บเขา้สนิคา้ตอ่กนัไป

เรือ่ยๆและใชว้ธิเีพิม่ column สําหรับบนัทกึเหตกุารณ์ตา่งๆทีเ่กดิขึน้กบัสนิคา้แตล่ะตวั 

ขอใหพ้งึระลกึถงึขอ้ดขีอ้เสยีและผลกระทบตอ่กลุม่ผูใ้ชง้านไวเ้สมอ ถา้วนัหนึง่พบวา่แฟ้มมี

ขนาดใหญจ่นทําให ้Excel ทํางานชา้ลง แทนทีจ่ะเสยีเวลามาปรับแตง่แฟ้มขอ้มลูเพือ่หวงัให ้

แฟ้มมขีนาดเล็กลงและคอมพวิเตอรทํ์างานเร็วขึน้ ทางออกหนึง่คอืใหซ้ือ้คอมพวิเตอรเ์ครือ่ง

ใหมซ่ึง่ทํางานเร็วขึน้กวา่เดมิ เพราะราคาคา่เครือ่งคอมพวิเตอรส์มยันีม้รีาคาไมแ่พงนัก ถกูกวา่

คา่แรงของพนักงานทีต่อ้งเสยีเวลามาปรับปรงุแฟ้มเสยีอกี 

แตถ่า้พบวา่ตารางขอ้มลูแบบ Flat ทีม่ขีอ้มลูซํ้ากนัจากการพมิพ ์กลบัทําใหม้ขีอ้มลูผดิพลาด

เนือ่งจากพมิพต์วัสะกดตา่งกนับอ่ยครัง้ (มวีรรคบา้ง ไมม่วีรรคบา้ง เตมิ s ตอ่ทา้ยบา้ง มจีดุ

ตอ่ทา้ยบา้ง) ก็ควรเลอืกนํา Relational Database  มาประยกุตใ์ชใ้นสว่นทีจํ่าเป็น 
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เมือ่ใดจะใช ้Excel เมือ่ใดจะใช ้Access หรอืโปรแกรมฐานขอ้มลูอืน่ 

คนทัว่ไปมกัมองวา่โปรแกรม Microsoft Excel เหมาะสําหรับงานคํานวณ งานทีเ่กีย่วขอ้งกบั

ตวัเลข หรอืบางคนทีรู่จั้กแบบผวิเผนิอาจระบไุปเลยวา่เหมาะสําหรับงานบญัช ีแตเ่นือ่งจาก 

Excel มโีครงสรา้งตารางทีเ่ปิดใหบ้นัทกึคา่ไดท้ัง้ตวัเลข ตวัอกัษร หรอืแมแ้ตร่ปูภาพ และเมือ่

ตอ้งการโยกยา้ยแกไ้ขเปลีย่นแปลงก็ทําไดง้า่ย ซึง่ความสามารถแบบนีเ้รยีกวา่ วสิ ซ ิวกิ หรอื 

wysiwyg ยอ่มาจาก What you see is what you get จงึทําใหค้นสว่นมากนํา Excel มาใชก้บั

งานแทบทกุประเภทหรอือยา่งนอ้ยตอ้งเคยพยายามคดิหาทางนํา Excel มาใชก้บังานนัน้งานนี้

ของตน  

แทนทีจ่ะโอนเอยีงเขา้ขา้ง Excel วา่ใหใ้ช ้Excel ไปตลอดโดยไมต่อ้งหนัไปใชโ้ปรแกรม 

Access หรอืโปรแกรมประเภทจัดการฐานขอ้มลูอืน่ๆ ขอเสนอแนวทางการใช ้Excel จัดการ

ฐานขอ้มลูใหเ้หมาะสมกบัสถานการณ์ ดงันี ้

1. ชว่งทีง่านทีย่งัขาดมาตรฐาน น่ันคอืยังไมแ่น่นอนวา่ตอ้งออกแบบฐานขอ้มลูกีต่ารางและใน

ตารางนัน้ๆตอ้งเก็บอะไรบา้ง ตอ้งแบง่เป็นกีแ่ถวตามแนวตัง้หรอืแนวนอน แตล่ะแถวตอ้งเป็น

ขอ้มลูเรือ่งอะไร ในชว่งนีค้วรใช ้Excel ไปกอ่นจนกวา่งานจะมมีาตรฐานตายตวัแลว้จงึคอ่ย

หนัไปใช ้Access หรอืโปรแกรมฐานขอ้มลูอืน่ 

2. ถงึแมง้านจะมมีาตรฐานแลว้ แตป่รมิาณขอ้มลูยงัมไีมม่าก ควรใช ้Excel ไปกอ่น จนกวา่จะ

พบวา่ขอ้มลูมคีวามซบัซอ้นมากขึน้จน Excel รับไมไ่หว จงึหนัไปใช ้Access หรอืหาซือ้

โปรแกรมสําเร็จรปูเฉพาะงานเรือ่งนัน้ๆมาใชแ้ทน Excel เพราะปัจจบุนัโปรแกรมสําเร็จรปูที่

ใชใ้นงานขาย การออกใบสัง่ซือ้ หรอืโปรแกรมบญัช ีมรีาคาไมแ่พงและสะดวกตอ่การใชง้าน

มากกวา่ทีจ่ะหาทางสรา้งขึน้มาใชเ้องดว้ย Excel 

3. ตราบใดทีม่พีนักงานเพยีงคนเดยีวทําหนา้ทีด่รูะบบขอ้มลู พงึหลกีเลีย่งการใช ้Access หรอื

โปรแกรมอืน่ทีพั่ฒนาขึน้เอง เพราะหากพนักงานคนนีล้าออกไป ระบบงานของบรษัิทจะเริม่

ตดิขดัขึน้มาเมือ่ใดก็ได ้ดงันัน้หากมพีนักงานดแูลระบบขอ้มลูเพยีงคนเดยีว ควรใช ้Excel 

ไปกอ่นหรอืหาซือ้โปรแกรมสําเร็จรปูในงานนัน้ๆมาใชโ้ดยตรง 

4. บรษัิทใหญ่ๆ  ซึง่มโีปรแกรมสําเร็จรปูราคาแพงใชง้านอยูแ่ลว้ ควรใชโ้ปรแกรมเหลา่นัน้ใน
การเก็บขอ้มลูการดําเนนิธรุกจิของตน แลว้เปิดใหพ้นักงานสามารถใชฐ้านขอ้มลูรว่มกนัผา่น
ระบบเครอืขา่ยแบบ Online หรอืสรา้งฐานขอ้มลู SQL ไวบ้นเว็บ แลว้ใช ้Excel ซึง่มคีวาม
ยดืหยุน่กวา่ ชว่ยนําขอ้มลูที ่export ออกมา นํามาวเิคราะหห์รอืจัดทําเป็นรายงานใน
โครงสรา้งทีเ่หมาะสม โดยเฉพาะรายงานตามความตอ้งการของผูบ้รหิาร  
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วธิบีนัทกึขอ้มลูลงไปในตาราง Excel 

Excel จะไรค้า่หากปราศจากขอ้มลูทีบ่นัทกึไว ้แตข่อ้มลูทีบ่นัทกึไวไ้มถ่กูตอ้งก็ทําให ้Excel ไร ้

คา่ไดเ้ชน่กนั การเริม่ตน้บนัทกึขอ้มลูอยา่งถกูวธิแีละถกูตอ้งจงึเป็นเรือ่งสําคัญอยา่งยิง่ เนือ้หาใน

สว่นนีจ้งึขอแนะนําประเด็นตา่งๆซึง่เกีย่วขอ้งกบัการบนัทกึขอ้มลูลงไปในตาราง 

จะใชเ้ซลลใ์ดเป็นเซลลแ์รก 

แทนทีจ่ะใชเ้ซลล ์A1 เป็นเซลลแ์รก ขอแนะนําใหเ้วน้ Row 1 และ Column A ใหว้า่งไว ้โดยให ้

ใชเ้ซลล ์B2 เป็นเซลลแ์รก ลองดภูาพตารางตอ่ไปนี ้

 

ตามภาพตารางดา้นขวา ประโยชนข์องการใชเ้ซลล ์B2 เป็นเซลลแ์รก จะชว่ยทําใหเ้ห็นได ้

ชดัเจนวา่ขอบดา้นบนและขอบดา้นซา้ยของตารางถกูตเีสน้กรอบไวแ้ลว้ และยงัดไูมอ่ดึอดั 

สามารถปรับความสงูความกวา้งของ Row 1 และ Column A ใหม้รีะยะหา่งจากขอบตารางได ้

ตามใจชอบ ทัง้นีพ้ืน้ทีส่ว่นทีเ่วน้วา่งไวม้ไิดทํ้าใหแ้ฟ้มมขีนาดใหญข่ึน้แตอ่ยา่งใด  

นอกจากนีใ้นกรณีทีม่ตีารางอืน่วางไวด้า้นลา่ง ใหใ้ช ้Column A เพือ่

เลือ่นหนา้จอไปแสดงตารางถดัไปดา้นลา่งไดอ้ยา่งรวดเร็ว โดยเริม่

จากขยบัหนา้จอไปแสดงตารางดา้นลา่งใหเ้ห็นไดช้ดัไวก้อ่น แลว้

พมิพข์อ้ความใดๆไวท้ีเ่ซลลท์ีอ่ยูด่า้นลา่งสดุของจอ ซึง่ในภาพนีค้อื

เซลล ์A36 จากนัน้เมือ่ตอ้งการเลือ่นจอไปแสดงตารางดา้นลา่ง ให ้

คลกิไปทีเ่ซลล ์A1 หรอืเซลลใ์ดใน Column A แลว้กดปุ่ ม End ตาม

ดว้ยลกูศรชีล้ง จะพบวา่ Cursor วิง่ไปเลอืกเซลล ์A36 ทําใหเ้ลือ่น

ตารางถดัไปดา้นลา่งมาแสดงใหเ้ห็นดา้นบนของจอ 
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ตวัเลขชดิขวา ตวัอกัษรชดิซา้ย 

หากตอ้งการใชข้อ้มลูทีเ่ก็บไวใ้นแฟ้ม Excel ไดง้า่ย ไมต่อ้งเสยีเวลาตรวจสอบแกไ้ขหรอืใชส้ตูร

ยุง่ยากซบัซอ้นเพือ่คน้หาขอ้มลู พงึระลกึไวว้า่ ขอ้มลูทีพ่มิพล์งไปตอ้งมสีถานะเป็นตวัเลข

หรอืตวัอกัษร ตามลกัษณะของคา่ทีเ่ห็นดว้ยสายตาดว้ย เชน่ ตวัเลขทีเ่ห็นในเซลลว์า่เป็น

เลข 001 ก็ตอ้งมสีถานะเป็นเลขดว้ย กลา่วคอืมคีา่เป็นเลข 1 ไมใ่ช ่‘001 ทีม่เีครือ่งหมาย

ฝนทองนําหนา้ ซึง่ทําใหม้สีถานะเป็นตวัอกัษร 

พืน้ทีต่ารางทีใ่ชใ้นการบนัทกึพมิพค์า่ใดๆลงไป อยา่กําหนด Format ใหข้อ้มลูชดิซา้ยหรอืชดิ

ขวา โดยปลอ่ยใหข้อ้มลูทีพ่มิพล์งไปแสดงสถานะของตวัเองใหเ้ห็นทนัทเีมือ่กดปุ่ ม Enter 

เพราะ Excel จะเลือ่นขอ้มลูทีพ่มิพล์งไปใหช้ดิซา้ยหรอืขวาตามสถานะของคา่ทีแ่ทจ้รงิใหเ้อง 

น่ันคอืตวัเลขชดิขวา ตวัอกัษรชดิซา้ย 

สตูรประเภทฐานขอ้มลู เชน่ VLookup และ Match จะใชส้ถานะของขอ้มลูในการคน้หาคา่ที่

ตอ้งการ โดยจะคน้หาขอ้มลูพบตอ่เมือ่ใชข้อ้มลูทีม่สีถานะเป็นเลขคน้หาพบจากตารางทีเ่ก็บ

ตวัเลข และจะใชข้อ้มลูทีม่สีถานะเป็นตวัอกัษรคน้หาพบจากตารางทีเ่ก็บตวัอกัษร ดงันัน้ ถา้ใช ้

‘001 คน้หาจากตารางทีเ่ก็บตวัเลข 001 ยอ่มไมม่ทีางคนืคา่ไดถ้กูตอ้ง 

ในกรณีทีต่อ้งการแสดงเลข 1 ทีพ่มิพล์งไปใหม้เีลข 0 นําหนา้กลายเป็น 001 วธิทีีถ่กูตอ้ง ให ้

กําหนด Format เป็น 000 แตผู่ท้ีใ่ช ้Excel อยา่งไมร่ะวงัอาจพมิพ ์‘001 ลงไปอกีก็ได ้ดงันัน้

แทนทีจ่ะกําหนดรหสัใดๆใหม้เีลข 0 นําหนา้ ขอแนะนําใหพ้มิพต์วัอกัษรตวัใดๆก็ไดนํ้าหนา้

ตวัเลขแทน เชน่ a001 จะทําใหห้มดปัญหาเพราะ a001 ยอ่มมสีถานะเป็นตวัอกัษรชดัเจน 

ปรบัระบบ Excel ใหเ้หมาะกบัการบนัทกึขอ้มลู 

ตามระบบที ่Excel เตรยีมไวใ้หเ้มือ่พมิพค์า่ใดๆลงไปในเซลลแ์ลว้กดปุ่ ม Enter จะพบวา่ Excel 

จะเลือ่น Cursor ลงไปยังเซลลถ์ดัไปดา้นลา่งทีต่ดิกนั เป็นระบบทีเ่หมาะกบัการบนัทกึขอ้มลู

จากตารางตามแนวตัง้ แตร่ะบบนีไ้มเ่หมาะกบัการบนัทกึขอ้มลูรายการประจําวนั ซึง่ควรเลือ่นไป

ยงัเซลลถ์ดัไปดา้นขวาตา่งหาก เพราะรายการทีเ่กดิขึน้พรอ้มกนัยอ่มอยูใ่นบรรทดัเดยีวกนั (เชน่

บนัทกึวนัทีข่ายสนิคา้ ชือ่ลกูคา้ และยอดเงนิ ตอ้งอยูใ่นรายการเดยีวกนั) และระบบนีย้งัไม่

เหมาะกบัการสรา้งสตูร เพราะเมือ่พมิพส์ตูรลงไปแลว้กดปุ่ ม Enter ตอ้งเสยีเวลาคลกิยอ้นกลบั

มาทีเ่ซลลส์ตูรอกีเสมอหากตอ้งการยอ้นกลบัมาแกไ้ขเพิม่เตมิสตูรใหถ้กูตอ้ง 
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ดงันัน้เพือ่ควบคมุใหเ้มือ่กดปุ่ ม Enter แลว้ Cursor ยงัคงอยูท่ีตํ่าแหน่งเซลลเ์ดมิ หรอืถา้

ตอ้งการบนัทกึคา่แลว้ตอ้งการใหเ้ลือ่นไปยงัเซลลด์า้นใด เพยีงแคก่ดปุ่ มลกูศรชีไ้ปตามทศินัน้ๆ  

ขอแนะนําใหป้รับระบบ Excel ใหมโ่ดยสัง่ File > Options > Advanced > ตดักาชอ่ง 

After pressing Enter, move selection 

นอกจากนีค้วรตดักาชอ่ง Allow editing directly in cells ทิง้ไปดว้ยเพือ่ทําใหใ้ช ้Formula 

Bar ในการแกไ้ขขอ้มลูหรอืสตูรในเซลลแ์ทนการแกไ้ขในเซลลโ์ดยตรง เนือ่งจาก Formula 

Bar จะแสดงขนาดตวัหนังสอืใหเ้ห็นชดัเจนกวา่การแกไ้ขในเซลลโ์ดยตรง 

วธิบีนัทกึขอ้มลูตามตาํแหนง่เซลลท์ีต่อ้งการ 

ผูใ้ช ้Excel ทีช่อบการเลือ่น Cursor ลงเมือ่กดปุ่ ม Enter มกัรูส้กึอดึอดัเมือ่เปลีย่นระบบให ้

Cursor ยงัคงอยูท่ีตํ่าแหน่งเดมิ บางคนถงึกบัยกเหตผุลตา่งๆนานามาโตก้ลบัมาวา่ระบบเดมิที ่

Excel เตรยีมมาใหนั้น้ดอียูแ่ลว้ ซึง่ไมใ่ชเ่รือ่งงา่ยทีจ่ะเปลีย่นพฤตกิรรมการใช ้Excel ทีทํ่ากนัจน

ชนิตดิเป็นนสิยั แตถ่า้ทราบเพิม่วา่ แมจ้ะเปลีย่นระบบใหก้ดปุ่ ม Enter แลว้ Cursor อยูท่ีเ่ซลล์

เดมิไปแลว้ก็ตาม เมือ่กดปุ่ ม Enter ก็ยงัมวีธิทํีาให ้Cursor เลือ่นไปยงัเซลลตํ์าแหน่งตา่งๆได ้

เองอกี และเมือ่ทราบวธินีีแ้ลว้จะพบวา่ สาเหตขุองความอดึอดั ไมไ่ดเ้กดิจากระบบของ Excel 

หรอก แตเ่กดิจากตวัผูใ้ชเ้องตา่งหากทีข่าดความรูค้วามเขา้ใจเกีย่วกบัวธิบีนัทกึขอ้มลู 

ใหเ้ริม่จากเลอืกพืน้ทีต่ารางทัง้หมดกอ่น พอพมิพข์อ้มลูแลว้กดปุ่ ม Enter จะพบวา่ Cursor 

เลือ่นลงมาตามแนวตัง้ทลีะเซลลจ์นถงึเซลลส์ดุทา้ยในแนว Column นัน้แลว้กระโดดไปเริม่ตน้

บนัทกึในบรรทดัแรกของ Column ถดัไป หรอือกีนัยหนึง่จะบนัทกึตามแนวตัง้กอ่นแนวนอน เพือ่

แสดงใหเ้ห็นชดัโปรดดจูากทศิทางของลกูศรในภาพตอ่ไปนี ้

 

ถา้ตอ้งการบนัทกึตามแนวนอนกอ่นแนวตัง้ พอพมิพข์อ้มลูเสร็จใหก้ดปุ่ ม Tab แทนปุ่ ม Enter จะ

เลือ่น Cursor ไปยงัเซลลด์า้นขวาทลีะเซลลจ์นสดุตารางแลว้กระโดดลงมาบนัทกึตอ่ใน Row 
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ถดัไป ดงัรปูตอ่ไปนี ้ซึง่เป็นวธิเีหมาะกบัการบนัทกึขอ้มลูประจําวนัเพราะในรายการหนึง่ๆยอ่ม

ตอ้งอยูใ่น Row เดยีวกนั 

 

ถา้เลอืกพืน้ทีต่ารางไวต้ามแนวนอนหรอืแนวตัง้โดดๆแบบ Single Row หรอื Single Column 

ไมว่า่จะกดปุ่ ม Enter หรอืปุ่ ม Tab จะทําให ้Cursor เลือ่นไปยงัเซลลถ์ดัไปทีต่ดิกนั 

หากตอ้งการบนัทกึขอ้มลูลงไปในเซลลท์ีก่ระจายกนัซึง่ไมไ่ดอ้ยูใ่นพืน้ทีต่ารางตดิกนั ใหเ้ริม่จาก

เลอืกเซลลท์ีส่องซึง่ตอ้งการบนัทกึขอ้มลูลงไปไวก้อ่นแลว้กดปุ่ ม Ctrl คา้งไวแ้ลว้คลกิเลอืก

เซลลตํ์าแหน่งถดัไปทีต่อ้งการไปจนครบแลว้จงึยอ้นกลบัมาคลกิเลอืกเซลลแ์รกเป็นตําแหน่ง

เซลลส์ดุทา้ย จากนัน้เริม่พมิพข์อ้มลูแลว้กดปุ่ ม Enter จะพบวา่ Excel ไลพ่มิพข์อ้มลูลงไปใน

เซลลต์ามตําแหน่งและลําดบัทีใ่หต้ามตอ้งการ ดงัรปูตอ่ไปนี ้

 

หากตอ้งการบนัทกึขอ้มลูลงไปในเซลลต์ามลําดบัตวัเลขทีเ่ห็น ใหเ้ริม่จากคลกิเลอืกเซลล ์B7 

จากนัน้กดปุ่ ม Ctrl แลว้คลกิเลอืกเซลล ์D2, D7, B2 แลว้เริม่บนัทกึขอ้มลูโดยกดปุ่ ม Enter ไป

เรือ่ยๆ Excel จะบนัทกึขอ้มลูลงไปในเซลล ์B2 > B7 > D2 > D7 

สว่นวธิเีลอืกพืน้ทีต่ารางขอ้มลูทีต่อ้งการบนัทกึ ก็ไมจํ่าเป็นตอ้งเสยีเวลาใชเ้มาสค์ลกิเลอืก โดย

ใหเ้ริม่จากตัง้ชือ่ Range Name ใหก้บัพืน้ทีต่ารางขอ้มลูไวก้อ่น เมือ่ตอ้งการเลอืกพืน้ทีนั่น้ๆให ้

คลกิเลอืกชือ่ Range Name ทีต่อ้งการจากชอ่ง Name Box หรอืกดปุ่ ม F5 เพือ่เปิดหนา้จอ

แสดงชือ่ทัง้หมดทีต่ัง้ไวใ้หเ้ลอืก 
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แป้นพมิพล์ดัทีค่วรรู ้

F2 ใชแ้กไ้ขขอ้มลูหรอืสตูรในเซลล ์

F3 ใชใ้สช่ือ่ตําแหน่งเซลลห์รอืชือ่สตูรทีต่ัง้ไวใ้นแฟ้มนัน้ๆลงไปในสตูร  
หรอืสัง่ Paste List ตอ่ จะสรปุชือ่ทีต่ัง้ไวท้ัง้หมดลงไปในตาราง 

F4 ใชใ้สเ่ครือ่งหมาย $ กํากบัตําแหน่งอา้งองิ  
หรอืสัง่ทวนคําสัง่สดุทา้ยซํ้า 

F5 ใชห้าเซลล ์ตามตําแหน่งหรอืชือ่ตําแหน่งเซลลท์ีท่ราบ 
หรอืสัง่ Special ตอ่ จะคน้หาตําแหน่งเซลลไ์ดอ้กีหลายแบบ 

F8 ใชค้วบคมุตําแหน่งเซลลแ์รกไวไ้มใ่หข้ยบัเพือ่ขยายตาราง (Extend) 

F9 ใชส้ัง่คํานวณทกุชทีทกุแฟ้มทีเ่ปิดขึน้ 

Shift + F9 ใชส้ัง่คํานวณเฉพาะชทีทีเ่ลอืกอยูช่ทีเดยีวเทา่นัน้ 

F2 ตามดว้ย F9 ใชแ้กะสตูรในเซลลเ์พือ่ดวูา่มคีา่ทีแ่ทจ้รงิเป็นอยา่งไร แลว้กด Esc 

Ctrl + * หรอื Ctrl+a ใชเ้ลอืกพืน้ทีต่ารางซึง่มขีอ้มลูตดิตอ่กนัไป (Current Region) 

Ctrl + . ใชย้า้ย Active Cell ไปตามเซลลห์วัมมุของตารางทีเ่ลอืกไว ้

Ctrl + Shift +  

Shift + End  

ใชเ้ลอืกพืน้ทีต่ารางจากเซลลท์ีเ่ลอืกไวไ้ปจนสดุทางดา้นขวา  
หรอืตามทศิทางของลกูศรทีก่ด 

Ctrl + PgUp ใชเ้ลอืกชทีถดัไป 

Ctrl + PgDn ใชเ้ลอืกชทีกอ่นหนา้ 

Ctrl + Tab ใชเ้ลอืกแฟ้มถดัไปทีเ่ปิดอยู ่

Ctrl + Shift + Tab ใชเ้ลอืกแฟ้มกอ่นหนา้ทีเ่ปิดอยู ่

Ctrl + Shift + Enter ใชส้รา้งสตูร Array ซึง่จะมเีครือ่งหมาย { } ปิดหวัทา้ยสตูร 
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วธิตีรวจสอบความถกูตอ้งของขอ้มลู 

ถา้เทยีบ Excel กบัคนทีป่ระพฤตปิฏบิตัตินตามศลีหา้ กลา่วไดว้า่ Excel เป็นคนทีซ่ือ่สตัยไ์มเ่คย

พดูปดแมแ้ตน่อ้ย ขอ้มลูทีบ่นัทกึไวอ้ยา่งไร Excel ก็จะนําขอ้มลูตามทีบ่นัทกึไวม้าใชต้อ่ดว้ย

ความซือ่สตัยส์จุรติ หากสตูร VLookup ทีส่รา้งไวอ้ยา่งถกูตอ้งแตห่าคา่ทีต่อ้งการไมพ่บ กลบั

แสดงคําตอบเป็น Error แบบ Not Available (NA) มไิดห้มายถงึวา่สตูรทีส่รา้งไวผ้ดิ แตน่ั่น

แสดงวา่ไมม่คีา่นัน้บนัทกึไวห้รอืบนัทกึไวไ้มถ่กูตอ้ง 

ขัน้แรกของการตรวจสอบความถกูตอ้งของขอ้มลู ใหเ้ริม่จากทําลายรปูแบบ Format ทีกํ่าหนด

ไวใ้นพืน้ทีต่ารางขอ้มลู โดยสัง่ Home > Clear > Clear Formats เพือ่ทําให ้Excel แสดงคา่ที่

แทจ้รงิ สิง่แรกทีต่อ้งสงัเกตคอื คา่ทีเ่ห็นเป็นตวัเลข ตอ้งชดิขวาของเซลล ์สว่นคา่ทีเ่ห็นเป็น

ตวัอกัษร ตอ้งชดิซา้ยของเซลล ์ซึง่ถา้เซลลใ์ดเห็นวา่ชดิซา้ย แตด่แูลว้เป็นตวัเลข 001 น่ันยอ่ม

แสดงวา่ตวัเลข 001 ทีเ่ห็นไมใ่ชค่า่ทีม่สีถานะเป็นตวัเลข 

แมก้ารลบ Format ทิง้จะทําใหเ้ห็นคา่ทีแ่ทจ้รงิไดก้็ตาม แตย่งัไมส่ามารถตรวจสอบความ

ถกูตอ้งของขอ้มลูไดร้อ้ยเปอรเ์ซน็ต ์และเป็นวธิทีีผู่ใ้ช ้Excel ตอ้งคอยสงัเกตทลีะเซลลทํ์าให ้

ตอ้งเสยีเวลาอยา่งมาก อกีทัง้ทําใหเ้สยีรปูแบบทีกํ่าหนดไว ้ผูใ้ช ้Excel จงึจําเป็นตอ้งเรยีนรูส้ตูร

ตอ่ไปนีเ้พือ่ชว่ยในการตรวจสอบความถกูตอ้งของขอ้มลู 

1. สตูร IsNumber(cell) คนืคา่เป็น True ถา้คา่ในเซลลม์สีถานะของคา่เป็นตัวเลข 

2. สตูร IsText(cell) คนืคา่เป็น True ถา้คา่ในเซลลม์สีถานะของคา่เป็นตวัอกัษร 

3. สตูร IsBlank(cell) คนืคา่เป็น True ถา้เซลลไ์มม่คีา่ใดๆบนัทกึไว ้

4. สตูร CountBlank(range) นับจํานวนเซลลท์ีเ่ป็นเซลลว์า่ง 

5. สตูร Len(cell) คนืคา่เป็นจํานวนอกัขระหรอืความยาวของคา่ทีอ่ยูใ่นเซลล ์

6. สตูร Exact(cell1,cell2) คนืคา่เป็น True ถา้ในเซลลท์ัง้สองมคีา่ทีบ่นัทกึตรงกนั โดย

สตูรนีจ้ะตรวจสอบลกัษณะตวัเล็กตวัใหญข๋องคา่ทีบ่นัทกึไวด้ว้ย 

ถา้พบวา่ขอ้มลูในเซลลใ์ดบนัทกึไวผ้ดิพลาด แทนทีจ่ะเสยีเวลาบนัทกึคา่ใหมท่ลีะเซลล ์ใหใ้ช ้

คําสัง่ Home > Find and Select > Replace แกไ้ขขอ้มลูพรอ้มกนัทัง้ตาราง หรอืจะใชส้ตูร

ตอ่ไปนีเ้พือ่แกไ้ขใหเ้ป็นขอ้มลูใหมท่ีถ่กูตอ้งหรอืนําผลไป copy ทบัขอ้มลูทีบ่นัทกึผดิไว ้

1. สตูร Trim(cell) จะตดัชอ่งวา่งดา้นหนา้และดา้นหลงัขอ้มลูทิง้ไป และตดัชอ่งวา่งตรง

กลางระวา่งขอ้มลูใหเ้หลอืแคช่อ่งเดยีว เชน่ ‘ aa   bb   ’  จะแกเป็น ‘aa bb’ 
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2. สตูร Substitute(cell,”ขอ้ความเดมิ”,”ขอ้ความใหม”่) ใชแ้กข้อ้ความบางสว่นในเซลลใ์ห ้

เปลีย่นเป็นขอ้ความใหม ่เชน่ ถา้ A1 มคีา่เป็น 12345 แลว้ตอ้งการเปลีย่นเป็น 17895 

ใหใ้ชส้ตูร =Substitute(A1,234,789) แตข่อใหส้งัเกตวา่เลข 17895 ทีไ่ดก้ลบัชดิซา้ย

ของเซลล ์ดงันัน้ถา้จะนําคา่นีไ้ปใชแ้บบตวัเลขทีช่ดิขวาของเซลล ์ตอ้งแกส้ตูรเป็น 

=Substitute(A1,234,789)*1 หรอื =--Substitute(A1,234,789) 

3. สตูร Clean(cell) จะตดัอกัขระทีไ่มแ่สดงในการพมิพท์ิง้ไป เพราะบางครัง้ขอ้มลูทีไ่ดม้า

จากแหลง่อืน่ทีไ่มไ่ดใ้ช ้Excel อาจตดิอกัขระพเิศษทีม่องไมเ่ห็นตดิมาดว้ย ทําใหข้อ้มลู

ทีเ่ห็นนัน้ไมใ่ชข่อ้มลูจรงิทัง้หมด 

4. สตูร Upper(cell) ปรับตวัอกัษรเป็นตวัใหญท่ัง้หมด 

5. สตูร Lower(cell) ปรับตวัอกัษรเป็นตวัเล็กทัง้หมด 

6. สตูร Proper(cell) ปรับตวัอกัษรเฉพาะตวัแรกเป็นตวัใหญ ่

7. สตูรทีใ่ชแ้ยกตวัอกัษรออกมาจากคํา โดยใชส้ตูร Left Right Mid เชน่ 

=Mid(12345,2,3) จะได ้234 เพราะเลข 2 เป็นตําแหน่งที ่2 และ 234 เป็น 3 ตวัที่

ตอ้งการ 

8. สตูรหาตําแหน่งของตวัอกัษรหรอือกัขระนัน้ๆในขอ้ความ โดยใชส้ตูร Find เชน่ 

=Find("\","C:\EXCEL\XLSTART\",10) คนืคา่เป็นเลข 17 โดยจะหาตําแหน่งของ

เครือ่งหมาย \ วา่ถดัจากตําแหน่งที ่10 แลว้ยงัมเีครือ่งหมาย \ อกีอยูท่ีตํ่าแหน่งตวัที ่17 
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เครือ่งมอืพเิศษสาํหรบัใชบ้นัทกึขอ้มลู 

แทนทีจ่ะตอ้งเสยีเวลายอ้นกลบัมาตรวจสอบขอ้มลูทีบ่นัทกึไว ้Excel ไดจั้ดเตรยีมเครือ่งมอื

พเิศษไวห้ลายอยา่งสําหรับชว่ยในการบนัทกึขอ้มลูใหถ้กูตอ้งตามตอ้งการและป้องกนัการเกดิ

ขอ้ผดิพลาดจากการบนัทกึขอ้มลูใหน้อ้ยทีส่ดุ เชน่ Data Validation, AutoComplete, Pick 

from List, Custom List, และ Form 

Data Validation 

Data Validation เป็นเครือ่งมอืชว่ยตรวจสอบขอ้มลูในระหวา่งการกดปุ่ ม Enter หรอืระหวา่งการ

คลกิเลอืกขอ้มลูทีต่อ้งการวา่เป็นขอ้มลูถกูตอ้งตามเงือ่นไขทีกํ่าหนดไวห้รอืไม ่(แตไ่มไ่ดช้ว่ย

ตรวจสอบขอ้มลูเกา่ทีบ่ันทกึไวอ้ยูแ่ลว้) เชน่ เมือ่คลกิเซลล ์D3 ในภาพตอ่ไปนีจ้ะมรีายการของ

ชือ่เดอืนแสดงขึน้มาขา้งใตใ้หค้ลกิเลอืกไดส้ะดวกโดยไมต่อ้งพมิพเ์อง 

 

เริม่จากเลอืกเซลลห์รอืตารางขอ้มลูทีต่อ้งการบนัทกึขอ้มลูแลว้สัง่ Data > Data Validation 

แลว้เลอืก Allow แบบ List แลว้คลกิลงไปในชอ่ง Source แลว้กดปุ่ ม F3 เพือ่นําชือ่ Range 

Name ชือ่ MonthList นําขอ้มลูมาแสดงเป็นรายการใหค้ลกิเลอืก (ซึง่การใช ้Range Name 

ลงิคข์อ้มลูมาแสดงในชอ่ง Source จะชว่ยลงิคข์อ้มลูขา้มชทีหรอืขา้มแฟ้มมาใชไ้ด)้ 
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ในชอ่ง Allow นอกจากการใชง้านแบบ List ยงัมตีวัเลอืกอืน่ๆเพือ่ใชต้รวจสอบขอ้มลูทีจ่ะบนัทกึ

ลงไปไดอ้กีหลายอยา่ง เชน่ 

 Whole Number ใชค้วบคมุคา่ทีบ่นัทกึเฉพาะเลขจํานวนเต็ม 

 Decimal ใชค้วบคมุคา่ทีบ่นัทกึเฉพาะเลขจํานวนทศนยิม 

 Date ใชค้วบคมุคา่ทีบ่นัทกึเฉพาะวนัที ่ในโครงสรา้ง วนั/เดอืน/ปีค.ศ. 

 Time ใชค้วบคมุคา่ทีบ่นัทกึเฉพาะเวลา ในโครงสรา้ง ชัว่โมง:นาท:ีวนิาท ี

 Text length ใชค้วบคมุคา่ทีบ่นัทกึเมือ่มจํีานวนตวัอกัษรยาวตามทีกํ่าหนด 

 Custom ใชรั้บสตูรเพือ่ควบคมุการบนัทกึขอ้มลู ถา้สตูรนัน้คนืคา่เป็น True จะทําให ้

สามารถบนัทกึคา่ลงไปได ้เชน่  

o =And(IsNumber(cell),Int(cell)=cell,Len(cell)=4) จะรับคา่เฉพาะตวัเลขที่

เป็นเลขจํานวนเต็ม 4 หลกัเทา่นัน้ 

o =CountIF(DataRange,cell)=1 จะรับคา่ทีไ่มซ่ํ้าเทา่นัน้ 

AutoComplete 

หากผูใ้ชพ้มิพต์วัอกัษรตวัแรกแลว้ตอ้งการให ้Excel พมิพต์วัอกัษรทีเ่หลอืใหเ้อง ใหเ้ริม่จาก

พมิพช์ือ่รายการทัง้หมดใหถ้กูตอ้งลงไปในตารางตามแนวตัง้เซลลล์ะชือ่ไวก้อ่น 

จากภาพนีเ้มือ่พมิพแ์คต่วั a ลงไปในเซลล ์B8 จะ

พบวา่ Excel เตมิ pr ตอ่ทา้ยใหเ้ป็น apr ใหท้นัท ีพอ

กดปุ่ ม Enter จะไดคํ้าวา่ Apr 

ถา้ตอ้งการพมิพต์วัอกัษรอืน่ เมือ่พมิพต์วัอกัษร a แลว้

ใหก้ดปุ่ ม Backspace เพือ่ลบ pr ทิง้ไปแลว้พมิพ์

ตวัอกัษรอืน่ตอ่ไปเอง 

ถา้ตอ้งการยกเลกิไมใ่ห ้Excel ชว่ยเตมิขอ้ความอยา่งถาวร ใหส้ัง่ File > Options > Advanced 

> ตดักาชอ่ง Enable AutoComplete for cell values ทิง้ไป 

นอกจากนี ้แทนทีจ่ะตอ้งพมิพต์วัอกัษรตวัแรกเองลงไปกอ่น ใหเ้ลอืกเซลลท์ีต่อ้งการในแนวตัง้

เดมินัน้ แลว้กดปุ่ ม Alt พรอ้มกบัปุ่ มลกูศรลง หรอืจะใชว้ธิคีลกิขวาเลอืกคําสัง่ Pick from Drop-

down List จะพบรายการของขอ้มลูเปิดหอ้ยลงมาใหค้ลกิเลอืกโดยไมต่อ้งพมิพแ์มแ้ตน่อ้ย 
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Custom List 

เคยสงัเกตไหมวา่ เมือ่พมิพคํ์าวา่ Jan เอาไวใ้นเซลลแ์ลว้ใชเ้มาสล์าก copy ไปยงัเซลลท์ีต่ดิกนั

ตอ่ไปจะเกดิชือ่เดอืน Jan, Feb, Mar เรือ่ยไปจนถงึ Dec ใหเ้อง แทนทีจ่ะใชเ้ฉพาะชือ่เดอืน

ตามที ่Excel จัดเตรยีมไวใ้หต้ัง้แตแ่รก Custom List เป็นรายการขอ้มลูทีส่ามารถเพิม่เขา้ไปให ้

Excel แตล่ะเครือ่งมคีวามสามารถไลเ่รยีงรายการถดัไปใหเ้องเมือ่มกีารใชเ้มาสล์ากเพือ่ copy 

เริม่จากใหพ้มิพช์ือ่รายการทีต่อ้งการเอาไวก้อ่นตามแนวนอนหรอืแนวตัง้ก็ได ้จากนัน้สัง่ File > 

Options > Advanced > General > กดปุ่ ม Edit Custom List 

 

ใหกํ้าหนดตําแหน่งอา้งองิของขอ้มลูทีต่อ้งการสรา้งเป็น Custom List ลงไปในชอ่ง Import list 

from cells แลว้กดปุ่ ม Import จะทําให ้Excel เฉพาะเครือ่งนัน้ม ีCustom List ตามตอ้งการ 

จากนัน้เมือ่ตอ้งการพมิพข์อ้มลูตามทีกํ่าหนดไว ้ใหเ้ลอืกพมิพแ์คร่ายการเดยีวแลว้ใชเ้มาสล์าก

เพือ่ copy จะพบขอ้มลูรายการถดัไปเรยีงลําดบัใหเ้องตามทีจั่ดเรยีงไวใ้น Custom List ตัง้แต่

แรก อยา่งไรก็ตาม Custom List จะรับรายการไดส้งูสดุเพยีง 254 รายการเทา่นัน้และจํากดั

เฉพาะขอ้มลูทีเ่ป็นตวัอกัษร 

Custom List ยงัชว่ยทําใหเ้มือ่สัง่ Sort แบบ Custom หรอืใช ้Pivot Table จะไดข้อ้มลูที่

เรยีงลําดบัไวอ้กีดว้ย 
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Form Controls 

Form Controls มหีนา้ตาเป็นปุ่ มใหค้ลกิเลอืก พอคลกิเลอืกแลว้จะสง่ผลลัพธไ์ปยงัเซลลท์ี่

กําหนดไว ้โดยผลทีไ่ดรั้บจะแสดงคา่ออกมาแตกตา่งกนัตามแตว่า่จะใชปุ้่ มแบบใด 

 

กอ่นอืน่ตอ้งเปิดแถบคําสัง่เมนู Developer ขึน้มากอ่น โดยสัง่ File > Options > Customize 

Ribbon แลว้ในกรอบจอดา้นขวาซึง่แสดงรายชือ่ของ Main Tabs ใหก้าชอ่ง Developer 

จากนัน้เมือ่ตอ้งการสรา้งปุ่ ม ใหส้ัง่ Developer > Insert > Form Controls จะแสดงรปูปุ่ ม

ตา่งๆตามภาพขา้งบนนี ้

วธิกีารสรา้งปุ่ มมหีลกัการเดยีวกนั เริม่จากคลกิเลอืกปุ่ มทีต่อ้งการกอ่นแลว้คลกิลงไปในตาราง

ตรงตําแหน่งเซลลท์ีต่อ้งการใหม้ปีุ่ มโดยอาจตอ้งคลกิแลว้ลากใหม้ขีนาดปุ่ มตามตอ้งการ 

จากนัน้ใหค้ลกิขวาที่

ตวัปุ่ มแลว้เลอืกคําสัง่ 

Format Control เพือ่

กําหนดตําแหน่ง

อา้งองิ Cell link ใช ้

เป็นเซลลสํ์าหรับ
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แสดงผลทีไ่ดจ้ากการคลกิเลอืกปุ่ ม สว่นปุ่ มประเภท Combo Box ใหกํ้าหนดตําแหน่งตารางที่

ตอ้งการนําขอ้มลูมาแสดงลงไปในชอ่ง Input Range 

ปุ่ มจาก Form Controls มจีดุประสงคใ์นการใชง้านแตกตา่งกนั ดงันี ้

1. ปุ่ ม Check Box เป็นปุ่ มรปูรา่งสีเ่หลีย่ม การคลกิกาหรอืไมก่าปุ่ มนีจ้ะคนืคา่ออกมาเป็น 

True หรอื False ซึง่นําไปใชคํ้านวณกบัสตูร IF  

2. ปุ่ ม Option Button เป็นปุ่ มรปูรา่งวงกลมเล็กๆ เนือ่งจากปุ่ มประเภทนีจ้ะกาไดเ้พยีง

ปุ่ มเดยีวเทา่นัน้ ไมส่ามารถกาซํ้าไดอ้กี ดงันัน้กอ่นทีจ่ะสรา้งปุ่ ม Option Button ตอ้ง

สรา้ง Group Box เป็นกรอบรปูสีเ่หลีย่มใหเ้ป็นพืน้ทีร่องรับปุ่ มไวก้อ่น เมือ่คลกิกาปุ่ มที่

อยูใ่น Group Box ก็จะคนืคา่ออกมาเป็นเลขลําดับทีข่องปุ่ ม ใหนํ้าตวัเลขนีไ้ปใชก้บัสตูร 

Choose หรอื Index 

3. ปุ่ ม Combo Box เป็นปุ่ มทีแ่สดงรายการใหเ้ลือ่นดหูรอืคลกิเลอืกรายการนัน้ๆไดแ้ลว้จะ

คนืคา่ออกมาเป็นเลขลําดบัของรายการ ใหนํ้าตวัเลขนีไ้ปใชก้บัสตูร Choose หรอื 

Index 

4. ปุ่ ม Scroll Bar หรอื Spinner เป็นปุ่ มทีม่ลีกูศรใหค้ลกิเลอืกเพือ่คนืคา่ออกมาเป็นเลข

ในชว่งตัง้แต ่0 – 30,000 ใหนํ้าตวัเลขนีไ้ปใชคํ้านวณเทยีบกบัอตัราทีกํ่าหนด 

Form Controls ทกุปุ่ มจะทํางานแบบ Interactive กลา่วคอื เมือ่คลกิลงไปทีปุ่่ มก็จะคนืคา่

ออกไปทีเ่ซลลซ์ึง่กําหนดใหเ้ป็น Cell link และเมือ่เปลีย่นคา่ในเซลลท์ีเ่ป็น Cell link ก็จะทําให ้

ปุ่ มเปลีย่นการแสดงผลตามไดเ้ชน่กนั 

หมายเหต ุนอกจากปุ่ มทีส่รา้งจาก Form Controls แลว้ยงัมปีุ่ มทีส่รา้งจาก ActiveX Controls 

เพือ่ใชง้านรว่มกบั VBA 
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เคล็ดอืน่ๆในการบนัทกึขอ้มลู 

 Filter เป็นเครือ่งมอืชว่ยเลอืกใหแ้สดงเฉพาะรายการทีต่อ้งการขึน้มาบนัทกึขอ้มลู 

 ถา้ตอ้งการพมิพข์อ้ความหลายบรรทดัในเซลลเ์ดมิ ใหก้ดปุ่ ม Alt+Enter เพือ่ขึน้บรรทดั

ใหมใ่นเซลลเ์ดยีวกนั 

 ถา้ตอ้งการบนัทกึแกไ้ขชทีหลายๆชทีพรอ้มกนั กอ่นจะทําการแกไ้ขใดๆในชที ใหก้ดปุ่ ม 

Ctrl หรอื Shift คา้งไวก้อ่นแลว้คลกิทีช่ทีซึง่ตอ้งการใหเ้กดิผลพรอ้มๆกนั ซึง่จะเห็นคํา

วา่ Group ปรากฏตอ่ทา้ยชือ่แฟ้มบนจอดา้นซา้ยบน (ปุ่ ม Ctrl จะเลอืกชทีซึง่ไมต่ดิกนั

ได ้สว่นปุ่ ม Shift จะชว่ยใหเ้ลอืกชทีทีต่ดิกนัทัง้หมด) เมือ่บนัทกึแกไ้ขเสร็จแลว้ ใหค้ลกิ

เลอืกชทีอืน่จะพบคําวา่ Group หายไป 

 ถา้ตอ้งการบนัทกึหลายๆเซลลพ์รอ้มกนั ใหก้ดปุ่ ม Ctrl คา้งไวแ้ลว้คลกิเลอืกเซลลท์ี่

ตอ้งการไปเรือ่ยๆ จากนัน้เมือ่พมิพข์อ้มลูในเซลลเ์สร็จแลว้ ใหก้ดปุ่ ม Ctrl+Enter จะ

พบวา่ขอ้มลูนัน้ถกูบนัทกึลงไปในเซลลท์ีเ่ลอืกไวใ้หท้ัง้หมดพรอ้มกนั 

 แทนทีจ่ะเสยีเวลาพมิพข์อ้ความยาวๆลงไปในเซลล ์ใหกํ้าหนด Formula Name ชือ่สัน้ๆ

ใหก้บัขอ้ความนัน้ เชน่ตัง้ชือ่วา่ MyVar ซึง่ Refers to =”Excel Expert Training” 

จากนัน้เมือ่ตอ้งการใชง้าน ใหพ้มิพ ์=MyVar ลงไปในเซลลก์็จะไดคํ้าวา่ Excel Expert 

Training แสดงขึน้มาแทน 

 แทนทีจ่ะเสยีเวลาพมิพข์อ้ความยาวๆลงไปในเซลล ์ใหกํ้าหนด Format โดยม ีCustom 

Type เป็น [=1]”Excel Expert Training” จากนัน้เมือ่ตอ้งการใชง้านใหพ้มิพเ์ลข 1 ลง

ไปในเซลลท์ีใ่ช ้Format นี ้จะไดคํ้าวา่ Excel Expert Training แสดงขึน้มาแทน 
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วธิคีน้หาขอ้มลูใน Excel 

ในขัน้ตอนตา่งๆของการจัดการฐานขอ้มลูซึง่ประกอบดว้ยขัน้ตอนของการจัดเก็บ การคน้หา การ

แกไ้ข และการจัดทํารายงานนัน้ ขัน้ตอนของการคน้หาขอ้มลูทีเ่ก็บไวใ้นตาราง Excel ถอืเป็น

เรือ่งสําคญัทีส่ดุ เพราะหากเก็บขอ้มลูไวแ้ลว้ไมส่ามารถนําขอ้มลูเหลา่นัน้มาใชย้อ่มทําใหเ้สยี

เปลา่ไมเ่กดิประโยชน ์โดยการจะคน้หาขอ้มลูพบหรอืไมนั่น้ตอ้งเริม่ตน้จากการเก็บขอ้มลูใหเ้ป็น

ทีเ่ป็นทางไวก้อ่นตามหลกัการ ดงันี ้

1. ตอ้งบนัทกึในพืน้ทีต่ารางซึง่มโีครงสรา้งตามหลกัฐานขอ้มลูทีด่ตีามทีไ่ดก้ลา่วไวแ้ลว้ใน

บทกอ่นๆ 

2. ขอ้มลูใดๆทีบ่นัทกึไว ้หากไมจํ่าเป็นหรอืไมใ่ชข่อ้มลูเกีย่วขอ้งกบัเหตกุารณ์ทีเ่กดิขึน้ใหม ่

ตอ้งไมบ่นัทกึซํ้าอกีเป็นอนัขาด เชน่ ขอ้มลูรหสัสนิคา้ ชือ่สนิคา้ หรอืรายละเอยีดอืน่ๆที่

เกีย่วขอ้งกบัสนิคา้รหสันัน้ๆ เมือ่บนัทกึไวแ้ลว้ ใหบ้นัทกึไวเ้พยีงครัง้เดยีว จากนัน้เมือ่

ตอ้งการคน้หาขอ้มลูของสนิคา้ ใหใ้ชร้หสัหรอืชือ่สนิคา้เป็นคําคน้หารายละเอยีดอืน่ๆมา

แสดงเมือ่ตอ้งการ 

3. ในแฟ้มหนึง่ๆ ควรบนัทกึขอ้มลูเรือ่งเดยีวกนัไวใ้นชทีเดยีวกนัในตารางเดยีวกนัซึง่มพีืน้ที่

ทีต่ดิตอ่กนัโดยบนัทกึรายการทีเ่กดิขึน้ใหมต่อ่ทา้ยบรรทดัหรอื row ของรายการเดมิ

ตอ่ไปเรือ่ยๆตามกําหนดเวลาทีเ่กดิรายการขึน้ ไมค่วรทําการลบรายการเกา่ทิง้ หรอืนํา

รายการใหมไ่ปแทรก insert ระหวา่งรายการเกา่ 

4. ตารางฐานขอ้มลูควรเป็นขอ้มลูทีเ่กดิจากการพมิพล์งไปเทา่นัน้หรอืมคีา่เป็น value ซึง่

ไมใ่ชข่อ้มลูทีไ่ดม้าจากสตูรลงิคห์รอืสตูรคํานวณ และไมจํ่าเป็นตอ้งกําหนดรปูแบบการ

แสดงผลใหแ้ตกตา่งไปจากเดมิ เพือ่ทําใหเ้ห็นขอ้มลูทีแ่ทจ้รงิตามแบบทีบ่นัทกึตัง้แต่

แรกไวต้ลอดเวลา 

5. ในกรณีทีข่อ้มลูเกดิจากการคํานวณ ควรเก็บเซลลส์ตูรคํานวณทีส่มัพันธเ์กีย่วขอ้งกนัไว ้

ในแฟ้มเดยีวกนัเสมอ เพราะการแยกแฟ้มจะทําใหต้อ้งเสยีเวลาเปิดแฟ้มทัง้หมดที่

เกีย่วขอ้งกนัขึน้มากอ่นจงึจะคํานวณครบถว้นทกุเซลล ์สว่นสตูรคํานวณทีไ่มจํ่าเป็นตอ้ง

คํานวณพรอ้มกนั ควรแยกเป็นแฟ้มคํานวณเรือ่งนัน้ๆโดยเฉพาะ แลว้ตอ่เมือ่ตอ้งการ

ขอ้มลูมาใช ้จงึสรา้งสตูรลงิคข์า้มแฟ้มนําเฉพาะผลคําตอบมาใชต้อ่ในอกีแฟ้มหนึง่ 

6. ขอ้มลูทีม่องเห็นวา่เป็นตัวเลข ตอ้งมสีถานะเป็นตวัเลข และขอ้มลูทีม่องเห็นวา่เป็น

ตวัอกัษร ตอ้งมสีถานะเป็นตวัอกัษร เพราะสตูรจะใชส้ถานะของคา่ในการคน้หา 
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ประเภทของการคน้หาขอ้มลู 

ผูใ้ช ้Excel ทัว่ไปมกัตัง้ชือ่ชทีหรอืชือ่แฟ้มตามประเภทของขอ้มลูทีเ่ก็บไวเ้พือ่สะดวกในการ

คน้หา เชน่ ตัง้ชือ่ชทีเรยีงตามเดอืนไปเรือ่ยๆ พอขึน้ปีใหมจ่งึขึน้แฟ้มใหม ่และในแฟ้มนัน้ก็แบง่

ชทีตามชือ่เดอืนไปอกี ครัน้จะคน้หาขอ้มลูของวนันัน้เดอืนนีปี้โนน้ ตอ้งไลเ่ปิดแฟ้มเกา่คน้หา

ขอ้มลูเพือ่ copy มาแปะตอ่กนัวุน่วาย พฤตกิรรมแบบนีแ้สดงวา่ผูใ้ช ้Excel ขาดพืน้ฐานความรู ้

ของการใชคํ้าสัง่บนเมนู และไมท่ราบวธิใีชส้ตูรดงึขอ้มลูทีต่อ้งการออกมาทํารายงาน 

ผูม้คีวามรูเ้ชีย่วชาญการใช ้Excel จะพยายามบนัทกึขอ้มลูเรือ่งหนึง่ๆลงไปในชทีเดยีว

แฟ้มเดยีวเทา่นัน้ ไมว่า่จะเป็นขอ้มลูของปีไหนเดอืนไหนวนัใดก็จะบนัทกึอยูใ่นชทีเดยีว 

จากนัน้เมือ่ตอ้งการคน้หาขอ้มลูก็จะเปิดชทีนัน้ขึน้มาเพือ่ใชคํ้าสัง่บนเมนูหรอืสตูรเพือ่

คน้หาขอ้มลูทีต่อ้งการตอ่ไป ตอ่มาถา้แฟ้มเริม่มขีนาดใหญอ่าจสง่ผลให ้Excel ทํางาน

ชา้ลง ก็จะเปิดแฟ้มใหมแ่ละในแฟ้มใหมนั่น้ก็จะมเีพยีงชทีเดยีวสําหรับขอ้มลูเรือ่งนัน้ๆ 

วธิกีารคน้หาขอ้มลู สามารถจัดแบง่ออกเป็นหลายวธิตีามลกัษณะของการใช ้Excel ดงันี ้

1. ใชคํ้าสัง่บนเมนู 

2. ใชส้ตูร 

3. ใช ้VBA (ขอยกวธินีีไ้ปอธบิายในหลกัสตูร Excel VBA) 

หากจัดแบง่วธิคีน้หาขอ้มลูตามลกัษณะโครงสรา้งของขอ้มลู แบง่ไดห้ลายกรณีดงันี ้

1. กรณีขอ้มลูจากเซลลท์ีอ่ยูก่ระจายกนั 

2. กรณีขอ้มลูจากเซลลท์ีอ่ยูต่ดิกนัเป็นตารางเดยีว 

3. กรณีขอ้มลูจากเซลลท์ีอ่ยูต่ดิกนัเป็นตารางหลายตาราง (ซึง่อาจจะไมไ่ดอ้ยูใ่นชที

เดยีวกนั) 

นอกจากนีก้ารจัดแบง่ตามลกัษณะโครงสรา้งของขอ้มลู ยงัขึน้กบัการวางแนวของขอ้มลูที่

จัดเก็บไวด้ว้ยวา่ ขอ้มลูทีต่อ้งการคน้หาอยูใ่นแนว row เดยีวกนักบัคา่ทีใ่ชห้าหรอืไม ่และมี

ขอ้มลูทีต่อ้งการคน้หาอยูร่ายการเดยีวหรอืหลายรายการ อกีทัง้มโีครงสรา้งตารางทีเ่ป็น

มาตรฐานเหมอืนกนัทกุตารางหรอืไม ่ดงันัน้จงึไมใ่ชเ่รือ่งงา่ยทีจ่ะใชส้ตูรงา่ยๆสัน้ๆเพือ่คน้หา

ขอ้มลูไดท้นัททีีต่อ้งการ 
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วธิคีน้หาขอ้มลูจากเซลลท์ ีอ่ยูก่ระจายกนั 

ขอ้มลูกระจาย หมายถงึ ขอ้มลูซึง่ไมไ่ดเ้ก็บไวใ้นเซลลต์ดิๆกนั โดยอาจเก็บขอ้มลูลงไปในเซลล์

กระจายกนั แยกไวใ้นชทีเดยีวกนัหรอืตา่งชทีตา่งแฟ้มกนัก็ได ้

คําสัง่บนเมนูซึง่สามารถนํามาคน้หาขอ้มลูทีก่ระจายกนั ไดแ้ก ่การใชคํ้าสัง่ Find (Ctrl+f) เพือ่

หาขอ้มลูทีท่ราบวา่สะกดอยา่งไร ถา้ทราบแตเ่พยีงลกัษณะของขอ้มลูวา่เป็นตวัเลขหรอืตวัอกัษร 

ใหใ้ชคํ้าสัง่ Goto Special (F5 > Special) จากคําสัง่ Home > Find & Select 

สตูรทีใ่ชค้น้หาขอ้มลูทีก่ระจายกนัในเซลลท์ีท่ราบตําแหน่งชดัเจน ไดแ้ก ่IF และ Choose 

 

สตูร IF  

เป็นสตูรทีย่ดืหยุน่ทีส่ดุ แตส่ามารถนํามาใชก้บักรณีทีม่เีงือ่นไขไมม่ากนัก โดยเงือ่นไขทีใ่ชใ้น

สตูร IF สามารถใชเ้งือ่นไขไดท้กุประเภทในการเปรยีบเทยีบตัง้แต ่=, >, <, >=, <= หรอื <> 

และไมจํ่ากดัวา่ตอ้งเปรยีบเทยีบกบัคา่ทีเ่ป็นตวัเลขหรอืตวัอกัษร และไมจํ่ากดัวา่ตวัเลขตวัอกัษร

นัน้มคีา่เป็นเทา่ใด เชน่ 

=IF(   YourChoice="A",   L6,   L17   ) 

ถา้เซลลช์ือ่ YourChoice มคีา่เทา่กบัตวัอกัษร A ใหนํ้าคา่มาจากเซลล ์L6 มาแสดง แตถ่า้ 

YourChoice มคีา่ไมเ่ทา่กบัตวัอกัษร A ใหนํ้าคา่จากเซลล ์L17 มาแสดงแทน 

 

=IF(   YourChoice>=123,   L6,   L17   ) 

ถา้เซลลช์ือ่ YourChoice มคีา่มากกวา่หรอืเทา่กบัตวัเลข 123 ใหนํ้าคา่มาจากเซลล ์L6 มา

แสดง แตถ่า้ YourChoice มคีา่ไมม่ากกวา่หรอืเทา่กบัตวัเลข 123 ใหนํ้าคา่จากเซลล ์L17 มา

แสดงแทน 
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สตูร Choose  

ใชก้บัเงือ่นไขทีเ่ป็นเลขจํานวนเต็มตัง้แตเ่ลข 1 – 254 โดยตอ้งกําหนดตําแหน่งของคา่ที่

กระจายไวใ้นวงเล็บของสตูรนีต้อ่ๆกนัไปใหถ้กูตอ้งตามตอ้งการ เชน่ 

=CHOOSE(  YourChoice,   L6,   L17,   M17,   K17,   O77   ) 

ถา้เซลลช์ือ่ YourChoice มคีา่เทา่กบัเลข 1 ใหนํ้าคา่จากเซลล ์L6 มาแสดง 

ถา้เซลลช์ือ่ YourChoice มคีา่เทา่กบัเลข 2 ใหนํ้าคา่จากเซลล ์L17 มาแสดง 

ถา้เซลลช์ือ่ YourChoice มคีา่เทา่กบัเลข 3 ใหนํ้าคา่จากเซลล ์M17 มาแสดง 

ถา้เซลลช์ือ่ YourChoice มคีา่เทา่กบัเลข 4 ใหนํ้าคา่จากเซลล ์K17 มาแสดง 

ถา้เซลลช์ือ่ YourChoice มคีา่เทา่กบัเลข 5 ใหนํ้าคา่จากเซลล ์O77 มาแสดง 

=CHOOSE(  TypeInput,  Price1,   Price2,   Price3,    Price4) 

ถา้เซลลช์ือ่ TypeInput มคีา่เทา่กบัเลข 1 ใหนํ้าคา่จากเซลลท์ีม่ชี ือ่วา่ Price1 มาแสดง 

ถา้เซลลช์ือ่ TypeInput มคีา่เทา่กบัเลข 1 ใหนํ้าคา่จากเซลลท์ีม่ชี ือ่วา่ Price2 มาแสดง 

ถา้เซลลช์ือ่ TypeInput มคีา่เทา่กบัเลข 1 ใหนํ้าคา่จากเซลลท์ีม่ชี ือ่วา่ Price3 มาแสดง 

ถา้เซลลช์ือ่ TypeInput มคีา่เทา่กบัเลข 1 ใหนํ้าคา่จากเซลลท์ีม่ชี ือ่วา่ Price4 มาแสดง 

เมือ่เปรยีบเทยีบระหวา่งสตูร IF กบัสตูร Choose จะเห็นไดว้า่สตูร Choose มโีครงสรา้งสตูรที่

งา่ยกวา่ เพยีงแตต่อ้งปรับเปลีย่นเงือ่นไขใหเ้ป็นเลขจํานวนเต็มแทน 

 

หมายเหต ุ

ใน Excel 2003 ในวงเล็บของสตูรใดๆจะนําสตูรมาใสซ่อ้นเขา้ไปไดเ้พยีง 7 สตูร ดงันัน้สตูร IF 

จงึซอ้นกนัไดอ้กี 7 IF ภายในวงเล็บของสตูร และ Choose จํากดัเงือ่นไขทีเ่ป็นตวัเลขตัง้แตเ่ลข 

1 – 29 เทา่นัน้ 

สว่น Excel 2007 เป็นตน้มา ในวงเล็บจะซอ้นสตูรไดถ้งึ 64 สตูร และสตูร Choose สามารถรับ

เงือ่นไขเป็นตวัเลขตัง้แต ่1 – 254 ซึง่แมจ้ะทําใหส้ามารถใชส้ตูร IF และ Choose ในการคน้หา

ขอ้มลูทีก่ระจายตวักนัไดส้ะดวกกวา่เดมิก็ตาม แตย่อ่มทําใหส้ตูรซบัซอ้นตอ่การแกะและทํา

ความเขา้ใจไดย้ากขึน้เชน่กนั  
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วธิคีน้หาขอ้มลูจากเซลลท์ ีอ่ยูต่ดิกนัเป็นตารางเดยีว 

คนทีใ่ช ้Excel แบบผดิๆ มกัจัดเก็บขอ้มลูกระจายกนัไวห้ลายๆทีเ่พือ่หวงัวา่จะไดม้ขีอ้มลูไว ้

ใชไ้ดท้ันทโีดยไมต่อ้งคน้หาขอ้มลู ทําใหใ้นแฟ้มหนึง่ๆมขีอ้มลูทีจั่ดเก็บไวซ้ํ้าซอ้นกนัเต็มไป

หมด อาจมชีทีหลายชทีหรอืแฟ้มหลายแฟ้มทีม่ขีอ้มลูจัดเก็บไวซ้ํ้ากนั พอถงึคราวตอ้งยอ้นกลบั

มาแกไ้ขขอ้มลู ก็จําเป็นตอ้งไลเ่ปิดแฟ้มแกไ้ขขอ้มลูทีบ่นัทกึไวใ้หค้รบทกุที ่ถา้พลัง้เผลอไมไ่ด ้

แกไ้ขใหค้รบ ยอ่มทําใหม้ขีอ้มลูทัง้ผดิและถกูคละกนัไป 

วธิกีารทีถ่กูตอ้ง เมือ่นําเซลลข์อ้มลูทีเ่ก็บไวม้าวางตดิกนัในโครงสรา้งของตาราง จะชว่ยทําให ้

ใช ้Excel คน้หาขอ้มลูไดส้ะดวกขึน้มาก ตอ่เมือ่ตอ้งการนําขอ้มลูไปใชก้็สามารถใชคํ้าสัง่บนเมนู

หรอืใชส้ตูรดงึคา่ในรายการทีต่อ้งการไปใชต้อ่อกีทหีนึง่ หากตอ้งการแกไ้ขขอ้มลูก็สามารถทํา

ไดง้า่ยเพยีงยอ้นกลบัมาแกไ้ขทีต่ารางเดมิตารางเดยีว 

ตารางทีจั่ดเก็บขอ้มลูไวต้อ้งมโีครงสรา้งตามแบบฐานขอ้มลูทีด่ ีกลา่วคอื 

1. หวัตาราง (Field Name) ซึง่เป็นบรรทัดบนสดุของตาราง ตอ้งใช ้row เดยีวเทา่นัน้ หาก

ตอ้งการบนัทกึหลายบรรทดั ใหใ้ชว้ธิกีดปุ่ ม Alt+Enter เพือ่พมิพข์อ้ความในบรรทดัใหม่

ในเซลลเ์ดยีวกนั 

2. ตอ้งม ีcolumn ใด column หนึง่ซึง่บนัทกึขอ้มลูแตล่ะรายการตดิตอ่กนัไปตลอดทกุ

เซลล ์หา้มเวน้เซลลว์า่ง โดยเฉพาะอยา่งยิง่ column ทีใ่ชบ้ันทกึชือ่หรอืเลขรหสั เพือ่

ใชกํ้ากบัแตล่ะรายการวา่เป็นรายการอะไรและไมซ่ํ้ากบัรายการอืน่ 

3. หา้มนําตารางฐานขอ้มลูไปตดิกบัขอ้มลูอืน่ในเซลลอ์ืน่รอบขา้ง ใหเ้วน้ระยะไวอ้ยา่งนอ้ย 

1 เซลลร์อบขา้ง เพือ่ทําให ้Excel สามารถรูข้อบเขตของตารางจากพืน้ทีข่อ้มลูที่

ตดิตอ่กนัไปไดเ้อง โดยเฉพาะชือ่ตารางทีพ่มิพไ์วด้า้นบนเหนอืหวัตาราง ควรเวน้

ระยะหา่งจากหวัตารางไว ้1 row เชน่กนั 
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คําสัง่บนเมนูสําหรับคน้หาขอ้มลูจากตารางฐานขอ้มลู ไดแ้ก ่

คาํส ัง่ Data > Sort  

ตารางขอ้มลูทีจ่ะนํามาจัดเรยีงนัน้ไมค่วรเป็นสตูรทีล่งิคม์าจากตารางอืน่ และหากจําเป็นตอ้ง

จัดเรยีงขอ้มลูทีเ่ป็นสตูรทีล่งิคก์นั ควรเป็นสตูรทีล่งิคข์อ้มลูตามแนวบรรทดัหรอื row เดยีวกนั

และสัง่ใหจั้ดเรยีงทกุตารางทีม่สีตูรลงิคก์นัไปพรอ้มกนั เพือ่ทําใหเ้มือ่จัดเรยีงขอ้มลูแลว้สตูร

ยงัคงดงึขอ้มลูในแนวเดยีวกนัอยู ่ 

นอกจากนีถ้า้เลอืก Sort Order แบบ Custom List จะเรยีงลําดบัขอ้มลูตามลําดบัทีเ่รากําหนด

ไวเ้องไดอ้กีดว้ย (กําหนด Custom List ไดจ้าก File > Excel Options > Advanced > 

General > Edit Custom Lists) โดยกําหนดใหเ้รยีงลําดบัตามชือ่ทีไ่มไ่ดเ้รยีงตวัอกัษรจากนอ้ย

ไปมากหรอืจากมากไปนอ้ย แตใ่หเ้รยีงลําดบัตามแบบทีกํ่าหนดไว ้เชน่ เรยีงตามชือ่เดอืน Jan, 

Feb, Mar, Apr, … เป็นตน้ 

 

การสัง่ Sort จะสง่ผลใหโ้ครงสรา้งตารางเรยีงลําดับตา่งไปจากเดมิ ดงันัน้กอ่นทีจ่ะสัง่ Sort ควร

เพิม่ column ทีใ่สเ่ลขลําดบัรายการจากนอ้ยไปมากไวก้อ่นเสมอ เพือ่ชว่ยใหเ้มือ่ตอ้งการ

รายการใหเ้รยีงลําดบักลับมาตามเดมิใหส้ัง่เรยีงลําดบักลบัมาตามเลขลําดบันี ้
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คาํส ัง่ Data > Filter 

 

Filter เป็นการกรองขอ้มลูใหแ้สดงเฉพาะขอ้มลูทีต่อ้งการเทา่นัน้โดย Excel จะจัดการซอ่น

บรรทดัของรายการอืน่ใหเ้อง วธินีีด้กีวา่การสัง่ Sort เพราะไมทํ่าใหโ้ครงสรา้งตารางเปลีย่นไป

จากเดมิ แตต่อ้งเสยีเวลามาคลกิเลอืกขอ้มลูทีต่อ้งการกรองใหมเ่ป็นครัง้ๆไป 

แทนทีจ่ะตอ้งเสยีเวลาคลกิเขา้ไปเลอืกขอ้มลูรายการทีต่อ้งการกรองใหม ่แนะนําใหเ้พิม่ 

column ใหมเ่พือ่ใชส้ตูร And หรอื OR ตรวจสอบรายการแตล่ะบรรทดัวา่เป็นขอ้มลูรายการที่

ตอ้งการหรอืไม ่จากนัน้ใหเ้ลอืกกรอง column ใหมน่ีเ้พยีง column เดยีวตามขอ้มลูทีค่นืคา่

ออกมาเป็น True จะสะดวกตอ่การใชง้านยิง่ขึน้ 
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หากตอ้งการคํานวณจากยอดทีเ่หลอืจากการกรอง แนะนําใหใ้ชส้ตูร 

=SubTotal(109,NumberRange) คูก่บัการกรอง เพราะสตูรนีจ้ะแสดงยอดรวมของตวัเลข

เฉพาะทีเ่ห็น (Visible Cells Only) เทา่ทีเ่หลอืจากการกรองใหอ้กีดว้ย และแทนทีจ่ะใชเ้ลข 

109 ยงัมเีลขอืน่ตัง้แตเ่ลข 101 - 111ซึง่ทําใหส้ตูร SubTotal นีห้ายอดประเภทอืน่ๆไดอ้กี เชน่ 

 เลข 101 จะทําหนา้ทีเ่ป็นสตูร Average 

 เลข 102 จะทําหนา้ทีเ่ป็นสตูร Count 

 เลข 103 จะทําหนา้ทีเ่ป็นสตูร CountA 

นอกจากนีห้ากสัง่ Copy ตารางขอ้มลูทีเ่หลอืจากการกรอง จะไดเ้ฉพาะพืน้ทีเ่ทา่ทีเ่ห็นออกไป 

Paste เทา่นัน้ โดยไมต่ดิพืน้ที ่row ทีถ่กูซอ่นตามไปดว้ย 

แมก้ารใชคํ้าสัง่ Data > Sort และ Data > Filter สามารถชว่ยคน้หาขอ้มลูทีต่อ้งการมาแสดง

ไดง้า่ย ถา้ใชคํ้าสัง่ Sort ยอ่มสง่ผลทําใหลํ้าดบัรายการของขอ้มลูเดมิเปลีย่นไป ตา่งจากการสัง่ 

Filter ซึง่ไมก่ระทบกบัลําดบัขอ้มลูทีเ่ก็บไวแ้ตอ่ยา่งใด ดงันัน้การใช ้Filter จงึเหมาะกวา่การสัง่ 

Sort แตโ่ปรดสงัเกตวา่ผลจากการใชคํ้าสัง่ดงักลา่วจะแสดงขอ้มลูทีต่อ้งการคน้หาใหเ้ห็นใน

บรเิวณพืน้ทีข่องตารางเดมิเทา่นัน้ หากตอ้งการนําขอ้มลูทีต่อ้งการคน้หาไปแสดงทีอ่ืน่ 

จําเป็นตอ้งอาศยัสตูร VLookup หรอืใชคํ้าสัง่ Advanced Filter 

ขอ้ควรระวงัในการใช ้Filter 

ควร Remove Filter ทีทํ่าไวแ้ลว้ทําใหมท่กุครัง้ เพือ่ทําใหไ้ดร้ายการทีต่อ้งการอยา่งชดัเจน 
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สตูร VLookup 

สตูร VLookup เป็นสตูรยอดนยิมในการใชค้น้หาคา่ทีต่อ้งการจากตารางขอ้มลูทีบ่นัทกึไวเ้ป็น

เซลลต์ดิตอ่กนั ตวัอกัษร V นําหนา้ยอ่มาจากคําวา่ Vertical ซึง่แปลวา่ แนวตัง้ สตูรนีจ้งึมี

ลกัษณะการทํางานตามชือ่สตูร น่ันคอื ใชค้น้หาคา่จากตารางทีเ่ก็บขอ้มลูแตล่ะเรือ่งไวต้าม

แนวตัง้หรอืตามแนว column โดยมขีอ้แมว้า่ตอ้งใชข้อ้มลูแนวตัง้หรอื column ดา้นซา้ยสดุ

เทา่นัน้เป็นคา่ทีใ่ชค้น้หา 

 

ตาราง B2:D7 เป็นตารางฐานขอ้มลูทีเ่ก็บขอ้มลูไวเ้ป็นเซลลต์ดิตอ่กนั โดยตัง้ชือ่ Range Name 

วา่ MyData ใหก้บัเซลล ์B3:D7 ซึง่เป็นพืน้ทีร่ายการขอ้มลูทีเ่ก็บไว ้ไมร่วมถงึพืน้ทีห่วัตาราง 

B2:D2 ซึง่ถกูตัง้ชือ่วา่ Header 

เมือ่ตอ้งการคน้หาวา่รหสั Id a003 ในเซลล ์F3 มชีือ่และยอดสนิคา้เทา่กบัเทา่ใด โดยใหแ้สดง

คําตอบในเซลล ์G3 และ H3 ตามลําดบั ใหเ้ริม่พจิารณากอ่นวา่ขอ้มลูรหสั Id ถกูจัดเก็บไวเ้ป็น 

column ซา้ยสดุของตาราง MyData ดงันัน้จงึสามารถนําสตูร VLookup มาใชค้น้หาชือ่และยอด

สนิคา้ไดต้ามตอ้งการดงันี ้

 เซลล ์G3 ใชส้ตูร =VLOOKUP( $F$3, MyData, 2 ) ไดคํ้าตอบเป็นชือ่ C 

 เซลล ์H3 ใชส้ตูร =VLOOKUP( $F$3, MyData, 3 ) ไดคํ้าตอบเป็นยอดสนิคา้ 30 

เลข 2 และเลข 3 ซึง่ใสไ่วใ้นวงเล็บดา้นหลงัสดุ หมายถงึ การกําหนดใหส้ตูร VLookup นํา

คําตอบจากตาราง MyData ใน column ที ่2 และ 3 มาแสดง 
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เมือ่สตูร VLookup สามารถคน้หาคา่ทีต่อ้งการไดเ้ชน่นี ้มไิดแ้สดงวา่สตูรทีส่รา้งขึน้นีถ้กูตอ้ง

เสมอไป ขอใหท้ดลองเปลีย่นรหสัในเซลล ์F3 เป็น a003x จะพบวา่สตูร VLookup ยงัคงหา

คําตอบไดอ้ยูท่ัง้ๆทีร่หสั a003x ไมม่อียูจ่รงิก็ตาม 

 

สาเหตทุีเ่ป็นเชน่นีเ้พราะสตูร VLookup ทีใ่ชอ้ยูนั่น้เป็นสตูรแบบ Approaching Match โดยสตูร

แบบนีจ้ะทํางานไดถ้กูตอ้งตอ่เมือ่ column ซา้ยสดุเรยีงคา่ไวจ้ากนอ้ยไปมากเทา่นัน้ หากคา่ที่

ตอ้งการหาคอื a003x ไมม่ ีก็จะใชร้หสัอืน่ทีน่อ้ยกวา่หรอืเทา่กบั a003x มาใชแ้ทนซึง่ก็คอืใช ้

รหสั a003 แทนน่ันเอง ทําใหย้งัใชค้น้หาไดต้ามปกตแิตไ่ดผ้ลลพัธไ์มถ่กูตอ้ง 

สตูรแบบ Approaching Match เหมาะกบัการใชต้วัเลขซึง่มคีา่ตอ่เนือ่งกนัไปใชใ้นการคน้หา แต่

ตวัอยา่งนีค้า่ทีใ่ชค้น้หาเป็นรหสั ขอแนะนําใหป้รับสตูรไปใชแ้บบ Exact Match แทนโดยเพิม่

เลข 0 ตอ่ทา้ยเขา้ไปดา้นหลงัสดุในสตูรดงันี ้

 เซลล ์G3 ใชส้ตูร =VLOOKUP( $F$3, MyData, 2, 0 )  

 เซลล ์H3 ใชส้ตูร =VLOOKUP( $F$3, MyData, 3, 0 )  

แมส้ตูรในเซลล ์G3 และ H3 จะคนืคา่วา่ #N/A กต็าม แตเ่ป็นคําตอบทีถ่กูตอ้งเพราะในเมือ่รหสั 

a003x ไมม่อียูจ่รงิ ก็ตอ้งหาคําตอบไมไ่ด ้
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ในสตูร VLookup แบบ Exact Match ขอใหส้งัเกตวา่ใน column ของรหสั Id ไมจํ่าเป็นตอ้ง

เรยีงจากนอ้ยไปมาก ซึง่เลข 0 ทีเ่พิม่ตอ่ทา้ยลงไปนัน้มคีวามหมายวา่ ไม ่หรอื False (หมายถงึ

กําหนดใหส้ตูรหาคา่แบบไมจํ่าเป็นตอ้งเรยีงลําดับ) หากเปลีย่นรหสัในเซลล ์F3 เป็นรหสัอืน่ทีม่ี

อยูจ่รงิ ก็ยอ่มหาคําตอบไดถ้กูตอ้งตามตอ้งการ 

ขอ้สงัเกตสาํคญัของการใชส้ตูร VLookup 

1. ถา้ขอ้มลูใน column ซา้ยสดุเรยีงลําดบัจากนอ้ยไปมากอยูแ่ลว้ จะชว่ยทําใหเ้กดิการไล่

เทยีบคา่ทีต่อ้งการไดง้า่ยขึน้ ดงันัน้สตูร VLookup แบบ Approaching Match จงึให ้

คําตอบไดร้วดเร็วกวา่สตูร VLookup แบบ Exact Match อยา่งมาก 

2. แทนทีจ่ะใสเ่ลข column ซึง่เป็นคา่คงทีไ่วใ้นสตูร VLookup ใหนํ้าสตูร Match เพือ่

คํานวณหาเลข column แทน เชน่ จากเดมิใชส้ตูร =VLOOKUP($F$3,MyData,2,0) 

ใหเ้ปลีย่นเป็นสตูร =VLOOKUP($F$3,MyData, MATCH(G2,Header,0), 0) ซึง่จะชว่ย

ป้องกนัทําใหส้ตูรยงัคงทํางานไดต้ามเดมิแมจ้ะมกีารแทรก column ลงไปในตาราง

ฐานขอ้มลู เพราะสตูร MATCH(G2,Header,0) จะคนืคา่เป็นเลขที ่column ทีถ่กูตอ้งให ้

เสมอ 

 

3. สตูร VLookup และสตูร Match จะใชล้กัษณะของขอ้มลูเป็นสว่นประกอบในการคน้หา

คา่ กลา่วคอื หากคา่ทีนํ่าไปใชค้น้หามลีกัษณะเป็น Text หรอื Number ก็ตอ้งนําไป
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คน้หาจากตารางฐานขอ้มลูซึง่บนัทกึไวแ้บบ Text หรอื Number ตาม เชน่ หากใชค้า่ 

‘123 ไปใชค้น้หา ก็จะคน้หาคา่ไดต้อ่เมือ่ในตารางฐานขอ้มลูบนัทกึคา่ไวเ้ป็น ‘123 ดว้ย 

แตจ่ะคน้หาขอ้มลูของ 123 ไมพ่บเพราะ ‘123 มลีกัษณะเป็น Text แต ่123 มลีกัษณะ

เป็น Number 

4. ในกรณีทีม่คีา่บนัทกึไวซ้ํ้าหลายรายการ สตูร VLookup และสตูร Match จะคน้หาขอ้มลู

ของรายการแรกทีบ่นัทกึซํ้าไวเ้ทา่นัน้ 

5. เมือ่หาคา่ไมพ่บ แทนทีจ่ะปลอ่ยใหส้ตูร VLookup คนืคา่เป็น #N/A ควรเปลีย่นคา่ 

#N/A เป็นเลข 0 หรอืคําเตอืนอืน่แทน โดยนําสตูร IsError หรอื IsNA มาปรับสตูรเป็น  

=IF(IsError(สตูร VLookup), 0, สตูร VLookup) 

หรอื 

=IF(IsError(สตูร VLookup), “ไมพ่บคา่ทีต่อ้งการ”, สตูร VLookup) 

6. สตูร VLookup แบบ Approaching Match =VLOOKUP($F$3,MyData,2) นีเ้ป็น

โครงสรา้งสตูรแบบสัน้ซึง่ละเลข 1 ตอ่ทา้ยไว ้ยงัมอีกีรปูแบบหนึง่คอื 

=VLOOKUP($F$3,MyData,2,1) โดยเลข 1 ทีต่อ้ทา้ยสดุในวงเล็บมคีวามหมายวา่ ใช ่

หรอื True หมายถงึ ใหใ้ชก้บัตารางทีข่อ้มลูใน column ซา้ยสดุเรยีงจากนอ้ยไปมาก 

7. ถา้เลอืกใชส้ตูร VLookup แบบ Approaching Match แตข่อ้มลูใน column ซา้ยสดุ

ไมไ่ดเ้รยีงลําดบัจากนอ้ยไปมากครบทกุรายการ สตูรนีจ้ะทํางานเพีย้นถกูบา้งผดิบา้ง  

8. นอกจากสตูร VLookup แลว้ยงัมสีตูร HLookup ไวใ้ชก้บัตารางทีเ่ก็บขอ้มลูตาม

แนวนอน แตม่โีอกาสใชง้านนอ้ยมากเนือ่งจากตารางฐานขอ้มลูทีด่ตีอ้งเก็บขอ้มลูไวต้าม

แนวตัง้ซึง่เหมาะสําหรับใชส้ตูร VLookup เทา่นัน้ 

9. หากในแฟ้มมกีารใชส้ตูร VLookup หลายเซลลแ์ละใชอ้า้งองิกบัพืน้ทีต่ารางขนาดใหญ ่

จะทําใหแ้ฟ้มทํางานชา้ลงตามจํานวนสตูรและขนาดพืน้ทีท่ีเ่พิม่ขึน้ อกีทัง้หากไมไ่ดใ้ช ้

สตูร Match ชว่ยในการหาเลขที ่column จะเสีย่งไดข้อ้มลูผดิทนัททีีผู่ใ้ชแ้กไ้ข

โครงสรา้งตารางโดยการ insert แทรก column ดงันัน้จงึแนะนําใหใ้ชส้ตูร VLookup กบั

ตารางทีเ่ก็บขอ้มลูขนาดไมใ่หญนั่กและไมค่อ่ยมกีารเปลีย่นแปลง เชน่ ตารางเก็บรายชือ่

สนิคา้ รายชือ่ลกูคา้ แลว้หนัไปใชส้ตูร Match กบั Index กบัตารางทัว่ไปแทน 
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คาํส ัง่ Data > Advanced 

 

คําสัง่ Data > Advanced เป็นการสัง่ให ้Excel ดงึขอ้มลูจาก List range ตามเงือ่นไขทีกํ่าหนด

ไวใ้น Criteria range ออกไปแสดงยงัเซลลท์ีกํ่าหนด ซึง่สามารถดงึขอ้มลูซํ้าออกไปไดด้ว้ย 

 List Range ตอ้งกําหนดพืน้ทีท่ัง้ตารางฐานขอ้มลูซึง่รวมหวัตารางไวด้ว้ย 

 Criteria range ตอ้งมหีวัตารางสะกดตรงกบัหวัตารางของฐานขอ้มลู และอาจมหีลาย

บรรทดัแลว้แตว่า่ตอ้งการเงือ่นไขหลายอยา่งหรอืไม ่จากภาพนีใ้นเซลล ์F3 ใสร่หสั Id 

a003 ลงไปเพือ่กําหนดใหก้รองหาขอ้มลูทกุรายการทีม่รีหสั a003  

 ถา้ตอ้งการรหสั a003 เฉพาะรายการทีม่จํีานวนมากกวา่ 40 และตอ้งการรหสั a002 ดว้ย

ใหข้ยายพืน้ที ่Criteria Range ออกไปเป็น F2:H4 ตามภาพ 

 

 Advanced Filter สามารถสง่คําตอบขา้มชทีได ้โดยตอ้งเริม่สัง่จากชทีทีต่อ้งการคําตอบ

ไปแสดง 
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วธิคีน้หาขอ้มลูจากตารางซึง่ไมไ่ดอ้ยูต่ดิกนัเป็นตารางเดยีว 

คําสัง่บนเมนูของ Excel สามารถนํามาใชค้น้หาขอ้มลูจากเซลลซ์ึง่บนัทกึไวต้ดิกนัเป็นตาราง

เดยีวกนัไดเ้ทา่นัน้ หากขอ้มลูถกูจัดเก็บแยกตารางจะไมม่ทีางใชคํ้าสัง่บนเมนูหาคําตอบที่

ตอ้งการไดเ้ลย ทางออกหนึง่คอืใหใ้ชส้ตูร Match เพือ่หาตวัเลขตําแหน่งรายการวา่ขอ้มลูที่

ตอ้งการคน้หานัน้เป็นรายการทีเ่ทา่ใด ตอ่ไปจงึนําตวัเลขตําแหน่งรายการไปคน้หาขอ้มลูอืน่ๆ

ของรายการโดยใชส้ตูร Index 

สตูร Match และสตูร Index เป็นสตูรทีต่อ้งใชร้ว่มกนัเสมอ ทําใหส้ามารถใช ้Excel แบบ 

Relational database และยงัใชเ้วลาคํานวณรวดเร็วกวา่สตูร VLookup อยา่งมาก 

 

จากภาพนีม้ตีารางเก็บขอ้มลูของรหสัแยกกนั 2 ตาราง ตารางหนึง่ B2:C7 เก็บขอ้มลูชือ่ของ

รหสั และอกีตารางหนึง่ B10:C15 เก็บยอดจํานวนของรหสั เราตอ้งการคน้หาวา่รหสั a003 ที่

กรอกไวใ้นเซลล ์E3 มชีือ่และยอดจํานวนเทา่กบัเทา่ใด โดยใหแ้สดงคําตอบไวใ้นเซลล ์G3 

และ H3 ตามลําดบั 

กอ่นอืน่ตอ้งวเิคราะหโ์ครงสรา้งตารางกอ่นวา่ลําดับรหสัในตารางทัง้สองนัน้จัดไวใ้นตําแหน่ง

รายการเดยีวกนั เชน่ รหสั a003 อยูใ่นรายการลําดบัที ่2 ตรงกนัทัง้สองตาราง โดยขอ้มลูรหสั

ไมจํ่าเป็นตอ้งเรยีงลําดบัจากนอ้ยไปมากก็ได ้
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เซลล ์F3 ถอืเป็นหวัใจของการคน้หาขอ้มลู มสีตูร =MATCH(E3,Id,0) คนืคา่ออกมาเป็นเลข 2 

ซึง่หมายความวา่รหสั a003 ถกูจัดเก็บไวเ้ป็นรายการที ่2 ใน range ทีต่ัง้ชือ่วา่ Id ซึง่เลข 0 ใน

วงเล็บเป็นการกําหนดวา่ใน Id ไมต่อ้งเรยีงลําดบั (ถา้เปลีย่นเลข 0 เป็นเลข 1 ตอ้งเรยีงลําดบั

ใน Id จากนอ้ยไปมาก หรอืใชเ้ลข -1 แทน ตอ้งเรยีงลําดบัใน Id จากมากไปนอ้ย) 

พอไดเ้ลข 2 แลว้จากนัน้ในเซลล ์G3 และ H3 ใหใ้ชส้ตูร =INDEX(Name,F3) และ 

=INDEX(Amount,F3) ก็จะไดช้ือ่และยอดจํานวนของรหสัตามตอ้งการ 

หากภายหลงัมกีารโยกยา้ย

ตําแหน่งขอ้มลูใหไ้มต่ดิกนั

เป็นตารางเดยีวกนั ตาม

ภาพตอ่ไปนี ้(หรอืแมจ้ะ

โยกยา้ยตารางไปวางไว ้

ตา่งชทีหรอืตา่งแฟ้ม) กจ็ะ

พบวา่สตูร Match และ 

Index ทีส่รา้งไว ้ยงัคงหา

คําตอบไดต้ามเดมิ 

ถา้ปรับสตูรในเซลล ์G3 และ H3 เป็น =INDEX(Name,MATCH(E3,Id,0)) และ 

=INDEX(Amount,MATCH(E3,Id,0)) เพือ่ลดัหาคําตอบโดยไมจํ่าเป็นตอ้งพึง่พาสตูร Match 

จากเซลล ์F3 ก็ได ้แตว่ธินีี ้

Excel เสยีเวลาคดิสตูร 

Match ซํ้าหลายครัง้ ทําให ้

สตูรยาวขึน้ยากตอ่การแกะ 

แฟ้มมขีนาดใหญข่ึน้ และ

ใชเ้วลาคํานวณนานขึน้ ไม่

ควรซอ้นสตูรแบบนีห้ากไม่

มคีวามจําเป็น 
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เมือ่ใดจะใชส้ตูร VLookup เมือ่ใดจะใชส้ตูร Match และ Index 

จากทีอ่ธบิายมาแลว้วา่สตูร Match และ Index เหมาะกบัการคน้หาขอ้มลูจากตารางซึง่ไมไ่ดอ้ยู่

ตดิกนัเป็นตารางเดยีวก็ตาม แตใ่นการใชง้านจรงิมไิดเ้ป็นไปตามหลกัดงักลา่วนีเ้สมอไป 

เนือ่งจากยังมปัีจจัยอืน่ซึง่สําคญักวา่ลกัษณะโครงสรา้งของขอ้มลูในการเลอืกใชส้ตูร VLookup 

หรอืใชส้ตูร Match และ Index ดงันี ้

 หากผูส้รา้งแฟ้มเป็นเพยีงคนเดยีวทีจ่ะใชแ้ฟ้มนัน้ จะเลอืกใชส้ตูรใดก็ไดต้ามใจชอบ 

 ถา้ใชง้านไปแลว้พบวา่แฟ้มทํางานชา้ลง ใหเ้ปลีย่นจากสตูร VLookup แบบ Exact 

Match มาเป็นสตูร VLookup แบบ Approaching Match โดยสัง่จัดเรยีงขอ้มลูจากนอ้ย

ไปมากดว้ย แตถ่า้แฟ้มยงัทํางานชา้อยูอ่กี จงึปรับสตูรเป็น Match และ Index 

 ถา้คดิวา่ตารางขอ้มลูทีใ่ชใ้นการคน้หานัน้ จะไมม่กีารเปลีย่นแปลงลกัษณะโครงสรา้งอกี

ตอ่ไปแลว้หรอืเป็นตารางเล็กมขีนาดไมใ่หญ ่การใชส้ตูร VLookup จะสะดวกกวา่ แตถ่า้

ไมแ่น่ใจวา่จะมกีารเปลีย่นแปลงลกัษณะโครงสรา้งตารางอกีหรอืไมห่รอืเป็นตารางขอ้มลู

ขนาดใหญ ่ควรเลอืกใชส้ตูร Match และ Index เพือ่ป้องกนัไวก้อ่นเพราะสตูรนีจ้ะยงัคง

ทํางานไดแ้มว้า่โครงสรา้งตารางมกีารเปลีย่นแปลง 

 ถา้มผีูใ้ชแ้ฟ้มรว่มกนัหลายคน ควรเลอืกใชส้ตูร Match และ Index เพือ่ป้องกนักรณีที่

ผูใ้ชง้านอาจเผลอเขา้ไปแกไ้ขโครงสรา้งตาราง 

 หากเลอืกใชส้ตูร Match และ Index ขา้มชทีหรอืขา้มแฟ้มหรอืขา้มตารางทีไ่มต่ดิกนั 

ตอ้งคอยตรวจสอบวา่ขอ้มลูรายการเดยีวกนัถกูจัดเก็บไวใ้นลําดบัเดยีวกนัในทกุตาราง 

หากไมแ่น่ใจขอใหใ้ชส้ตูร Match หาตําแหน่งรายการในแตล่ะตารางจะปลอดภยัยิง่ขึน้ 

 ถา้ไมม่เีวลาแกไ้ขสตูร ใหจั้ดซือ้คอมพวิเตอรเ์ครือ่งใหมท่ีทํ่างานเร็วขึน้มาใชง้านแทน 

เพราะคา่เครือ่งคอมพวิเตอรใ์หมม่รีาคาไมแ่พงเหมอืนแตก่อ่น และยงัประหยดักวา่การ

เสยีแรงเสยีเวลามาแกไ้ขสตูรเอง (อยา่ลมืคดิคา่ตวัคนสรา้งสตูรมาเทยีบกบัคา่เครือ่ง

คอมพวิเตอร)์ 

 

คําแนะนําเหลา่นีเ้ป็นเพยีงขอ้เสนอแนะตามความชอบและเหตผุลสว่นตวัดังทีก่ลา่วมา

ขา้งตน้เทา่นัน้ 
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วธิคีน้หาขอ้มลูจากเซลลท์ีอ่ยูเ่ย ือ้งกนั 

ขอ้มลูทีล่อกมาจากระบบอืน่ทีไ่มใ่ช ่Excel มกัมโีครงสรา้งขอ้มลูซึง่ไมไ่ดเ้ป็นฐานขอ้มลูทีด่ ี

โดยเฉพาะขอ้มลูที ่export ออกมาจากรายงานทางบญัชหีรอืการผลติ อาจมตํีาแหน่งขอ้มลูที่

ตอ้งการคําตอบวางไวใ้นแนวเยือ้งกบัคา่ทีใ่ชห้า 

สตูร VLookup สามารถใชค้น้หาคา่คําตอบทีอ่ยูใ่นแนวเดยีวกนักบัคา่ทีใ่ชห้าเทา่นัน้ หาก

คําตอบทีต่อ้งการอยูใ่นเซลลท์ีอ่ยูเ่ยือ้งกนักบัคา่ทีใ่ชห้า จะไมส่ามารถใชส้ตูร VLookup แลว้ถา้

หากคดิจะนําสตูร Match และ Index มาใชก้็ตอ้งใชร้ว่มกบัสตูรอืน่ 

 

ในภาพนีม้ขีอ้มลูถกูจัดเก็บไวเ้ป็นชดุๆ โดยแตล่ะชดุมขีนาดความสงูความกวา้งเทา่กนั ชดุแรก a 

มพีืน้ทีต่ัง้แตเ่ซลล ์B2:D5 ชดุทีส่อง b มพีืน้ทีต่ัง้แตเ่ซลล ์B6:D9 ชดุทีส่าม c มพีืน้ทีต่ัง้แต่

เซลล ์B10:D13 ชดุทีส่ี ่d มพีืน้ทีต่ัง้แตเ่ซลล ์B14:D17 ซึง่ในอนาคตอาจเพิม่ขอ้มลูชดุตอ่ไป

ดา้นลา่งลงไปเรือ่ยๆ 

สิง่ทีต่อ้งการก็คอื เมือ่ใสค่า่ c ลงไปในเซลล ์H2 ใหห้าวา่ในชดุ c มตีวัเลขบนัทกึไวใ้นเซลล์

ดา้นลา่งขวามอืสดุของชดุ c เป็นเทา่ใด ซึง่คําตอบทีต่อ้งการคอืตวัเลข 333 จากเซลล ์D13 

และหากเปลีย่นคา่ในเซลล ์H2 เป็น a, b, c, หรอื d ก็ตอ้งหาตัวเลขคําตอบออกมาใหเ้ป็น 111, 

222, 333, 444 ตามลําดบัดว้ย 
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วธิที ี ่1  

 

เริม่จากการใชส้ตูรในเซลล ์H5 =MATCH(H2,B:B,0) หาใหไ้ดก้อ่นวา่คา่ c ในเซลล ์H2 นัน้เมือ่

ดจูาก column B แลว้อยูใ่น row 10 

เนือ่งจากเรามขีอ้สมมตฐิานทีสํ่าคญัวา่แตล่ะชดุมขีนาดความสงูความกวา้งเทา่กนั ในขัน้ตอ่ไป

ใหว้ดัความสงูหรอืจํานวน row ของชดุแรกดว้ยสตูรในเซลล ์H6 =ROWS(B2:B5) ไดค้วามสงู 

4 row 

จากนัน้ใหห้าเลขที ่row ของ row สดุทา้ยของชดุ c โดยการนําเลขที ่row แรกบวกเพิม่ดว้ย

ความสงูแลว้ลบ 1 ดว้ยสตูรในเซลล ์H7 =H5+H6-1 ไดตํ้าแหน่งของเลข 333 แลว้วา่อยูใ่น 

row 13 

แลว้ใหใ้ชส้ตูรในเซลล ์H8 =INDEX(D:D,H7) เพือ่หาวา่จาก column D มขีอ้มลูในลําดบัที ่13 

จากเซลล ์H7 คอืตวัเลขคําตอบ 333 

แทนทีจ่ะตอ้งเสยีเวลาสรา้งสตูรหลายขัน้ อาจใชส้ตูรตอ่ไปนีห้าคําตอบ 333 เลยก็ได ้

=INDEX( D:D, MATCH(H2,B:B,0) + ROWS(B2:B5) – 1 ) 
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วธิที ี ่2 

 

ใชส้ตูรตอ่ไปนีใ้นเซลล ์H11 ลดัหาตวัเลขคําตอบ 333 

=OFFSET( INDEX(B:B,MATCH(H2,B:B,0)), ROWS(B2:B5)-1, COLUMNS(B2:D2)-1) 

อกีนัยหนึง่คอืสตูร =OFFSET( B10, 3, 2) เพือ่หาคา่ทีอ่ยูใ่นตําแหน่งถดัไปจากเซลล ์B10 ถดั

ลงไป 3 row และถดัไปทางดา้นขวา 2 column น่ันเอง 

สงัเกตวา่ใชส้ตูร MATCH(H2,B:B,0) เชน่เดยีวกนักบัวธิแีรก โดยเมือ่นําไปซอ้นในสตูร Index 

เป็นสตูร INDEX(B:B,MATCH(H2,B:B,0)) จะกลายเป็นสตูรทีบ่อกตําแหน่ง B10 ของขอ้มลูใน

ลําดบัที ่10 ใน column  B  

สตูร INDEX(B:B,MATCH(H2,B:B,0)) นี ้ถา้สรา้งลงในเซลลจ์ะคอืคา่ออกมาเป็นคา่ในเซลล ์

B10 คอืใหคํ้าตอบเป็น c แตเ่มือ่นําสตูร INDEX(B:B,MATCH(H2,B:B,0)) ไปสรา้งซอ้นลงใน

สตูร Offset จะเลกิหาคา่ตวั c แตจ่ะคนืคา่คําตอบออกมาเป็นตําแหน่งเซลล ์B10 แทน 

โปรดจาํไวว้า่ สตูรใดทีส่ามารถใชห้าคา่ไดโ้ดยตรง สตูรน ัน้ยอ่มกลายเป็นสตูรที่

บอกตาํแหนง่ของคา่ทีใ่ชห้าได ้ตอ่เมือ่นําสตูรไปสรา้งซอ้นลงไปในสตูรอืน่ 

ROWS(B2:B5)-1 ใชห้าวา่คา่ 333 ทีต่อ้งการหานัน้ อยูถ่ดัจากเซลล ์B10 ลงไป 3 เซลล ์โดย

หาจากขนาดความสงูทีห่าจาก ROWS(B2:B5) ลบทิง้เสยี 1 row 

COLUMNS(B2:D2)-1 ใชห้าวา่คา่ 333 ทีต่อ้งการหานัน้ อยูถ่ดัจากเซลล ์B10 ไปทางดา้นขวา 

2 เซลล ์โดยหาจากขนาดความสงูทีห่าจาก COLUMNS(B2:D2) ลบทิง้เสยี 1 column 
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วธิที ี ่3 

 

วธินีีม้ทีีม่าจากสตูร =Indirect( “ตําแหน่งเซลลท์ีต่อ้งการหาคา่”) ซึง่จะคนืคา่ออกมาเป็นคา่ใน

เซลลท์ีท่ราบตําแหน่ง ดังนัน้หากตอ้งการหาคา่ 333 จากเซลล ์D13 ก็ตอ้งหาทางสรา้งสตูร 

=Indirect(“D13”) ออกมาใหไ้ด ้

ขัน้แรกหาเลขที ่row 13 ไดจ้ากสตูรในเซลล ์H15 =MATCH(H2,B:B,0)+ROWS(B2:B5)-1 

ซึง่ไดจ้ากการนําเลขที ่row 10 ทีไ่ดจ้ากสตูร MATCH(H2,B:B,0) ไปบวกเพิม่ดว้ยความสงู 4 

row แลว้ลบทิง้เสยี 1 row 

ตอ่ไปหาเลขที ่column 4 จากสตูรในเซลล ์H16 =COLUMN(D2) 

เมือ่นําคา่จากเซลล ์H15 และ H16 สง่ตอ่ไปยงัสตูร ADDRESS(H15,H16) ยอ่มเทยีบเทา่กบั

สตูร =INDIRECT(ADDRESS(13,4)) หรอื =INDIRECT("$D$13") 

แทนทีต่อ้งใชห้ลายสตูรหลายขัน้ตอน จะใชส้ตูรลดันีแ้ทนก็ได ้

=INDIRECT( ADDRESS( MATCH(H2,B:B,0) + ROWS(B2:B5) - 1, COLUMN(D2) ) ) 
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การจดัการคา่ซํา้ 

ในหลกัการบันทกึขอ้มลูทีด่ตีอ้งควบคมุการบนัทกึคา่ซํ้าใหเ้กดิขึน้ไดเ้ทา่ทีจํ่าเป็นเทา่นัน้ เชน่ใน

งานบนัทกึขอ้มลูสนิคา้ทีข่าย จะมตีารางบนัทกึรายละเอยีดของสนิคา้เอาไว ้จากนัน้เมือ่ตอ้งการ

รายละเอยีดของสนิคา้ไปใชท้ีเ่ซลลอ์ืน่ ไมจํ่าเป็นตอ้งพมิพร์ายละเอยีดของสนิคา้นัน้ๆซํ้าอกี 

คา่ทีจํ่าเป็นตอ้งพมิพซ์ํ้ามเีพยีงรหสั พอพมิพร์หสัลงไปแลว้ใหใ้ชส้ตูรดงึขอ้มลูของรหสัสนิคา้นัน้

มาแสดง โดยใชส้ตูร VLookup, Match, Index, หรอืสตูรอืน่ๆดงึรายละเอยีดของรหสัมาแสดง 

อยา่งไรก็ตามมบีางงานทีผู่ใ้ช ้Excel อาจเผลอพมิพค์า่ซํ้า โดยเฉพาะงานทีต่อ้งกระจายให ้

พนักงานหลายๆคนชว่ยกนับนัทกึขอ้มลู เครือ่งมอืทีใ่ชช้ว่ยเตอืนทนัททีีม่กีารบนัทกึคา่ซํ้าไดแ้ก ่

คําสัง่ Data Validation เพือ่ป้องกนัหรอืเตอืนการบนัทกึซํ้าและ Conditional Formatting เพือ่

เปลีย่นสเีซลลท์ีม่คีา่ซํ้าโดยใชง้านรว่มกบัสตูร CountIF (ไมค่วรใชคํ้าสัง่ Remove Duplicates) 

 

หากตอ้งการสัง่ให ้Excel เตอืนเมือ่มกีารพมิพค์า่ซํา้ ใหเ้ริม่จากเลอืกพืน้ทีต่ารางตัง้แต ่B3:B15 

ซึง่เตรยีมไวสํ้าหรับบนัทกึขอ้มลู จากนัน้สัง่ Data > Data Validation > Data Validation 

เลอืก Allow แบบ Custom แลว้พมิพส์ตูร =COUNTIF($B$3:$B$15,B3)=1 ลงไปในชอ่ง 

Formula โดยไมต่อ้งใสเ่ครือ่งหมาย $ ในสว่นของ B3 ทีอ่ยูด่า้นทา้ยในวงเล็บของสตูร เพือ่ทํา

ให ้Excel ใชตํ้าแหน่งถดัไปในการตรวจสอบใหเ้อง 
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ถา้ตอ้งการเปลีย่นสเีซลลท์ีม่กีารบนัทกึคา่ซํ้า ใหเ้ริม่จากเลอืกพืน้ทีต่ารางตัง้แต ่B3:B15 แลว้สัง่ 

Home > Conditional Formatting > New Rule โดยเลอืกใชเ้งือ่นไขแบบ Use a formula to 

determine which cells to format แลว้ใชส้ตูร =COUNTIF($B$3:$B$15,B3)>1 ซึง่ถา้สตูรนี้

คนืคา่เป็น True ยอ่มแสดงวา่สตูร CountIF นับขอ้มลูแลว้พบวา่มคีา่ซํ้าจรงิ 

 

โปรดสงัเกตวา่ถา้ใช ้Data Validation จะใชส้ตูร =COUNTIF($B$3:$B$15,B3)=1 แตเ่มือ่ใช ้

กบั Conditional Formatting ตอ้งเปลีย่นสมการจากเทา่กบั 1 เป็นมากกวา่ 1 แทน ดว้ยสตูร 

=COUNTIF($B$3:$B$15,B3)>1 เพราะ Data Validation จะยอมใหบ้นัทกึคา่ตอ่เมือ่นับแลว้มี

เพยีงคา่เดยีวคอืนับแลว้เทา่กบั 1 คา่เทา่นัน้ สว่นการใช ้Conditional Formatting จะเปลีย่นสี

เพือ่เตอืนเมือ่มคีา่ซํ้าคอืเมือ่นับแลว้ทีค่า่มากกวา่ 1 

Data Validation เป็นเครือ่งมอืทีค่วรนํามาใชร้ว่มกบั Conditional Formatting เสมอ เนือ่งจาก 

Data Validation จะชว่ยตรวจสอบคา่ซํ้าใหต้อ่เมือ่เกดิคา่ซํ้าขึน้จากการพมิพล์งไปในตาราง

เทา่นัน้ แตจ่ะไมต่รวจสอบหากมกีาร copy คา่ซํ้าวางลงไปแตอ่ยา่งใด ดงันัน้เมือ่เกดิคา่ซํ้าขึน้

เมือ่ใดก็จะเห็นสใีนเซลลเ์ปลีย่นแปลงตา่งไปจากเดมิจากคําสัง่ Conditional Formatting เป็น

ปราการดา่นสดุทา้ยของการตรวจสอบอกีชัน้หนึง่ 



หนา้ 52 / 97 
 

 

 

© www.ExcelExpertTraining.com 

ในภาพตอ่ไปหากตอ้งการเปลีย่นสเีซลลเ์พือ่ชว่ยแสดงตําแหน่งขอ้มลูรายการทีต่อ้งการใหเ้ห็น

ชดัเจนขึน้  

 

ตารางดา้นซา้ยมอืเป็นตารางฐานขอ้มลู ใหเ้ลอืกพืน้ทีต่ารางเฉพาะสว่นของรายการทัง้หมด

ตัง้แต ่B3:E20 แลว้สัง่ Home > Conditional Formatting > New Rule โดยเลอืกใชเ้งือ่นไข

แบบ Use a formula to determine which cells to format แลว้ใชส้ตูร =$C3=$G$3 

 

เซลล ์G3 เป็นเซลลท์ีใ่ชก้รอกรหสัทีต่อ้งการใชส้บีอกตําแหน่ง ดงันัน้ในสตูร =$C3=$G$3 ที่
ใชน้ีจ้งึกําหนดตําแหน่งแบบคงที ่$G$3 เอาไว ้สว่นเซลล ์C3 เป็นเซลลแ์รกของรายการหสั ID 
ซึง่ในสตูรนีกํ้าหนดใหเ้ลือ่นตําแหน่งไปเรือ่ยๆใน column C จงึตอ้งใช ้$C3   
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การหาเลขตาํแหนง่รายการขอ้มลูทีซํ่า้ดว้ยสตูร Multiple Match  

สตูร VLookup และสตูร Match มจีดุออ่นตรงทีส่ตูรเหลา่นีจ้ะทํางานกบัขอ้มลูทีไ่มซ่ํ้าเทา่นัน้ 

หากนําไปใชก้บัตารางทีม่ขีอ้มลูซํ้าจะใหคํ้าตอบของขอ้มลูรายการแรกทีซ่ํ้ากนั สว่นคําสัง่ Data 

> Advanced หรอื Filter จะทํางานตอ่เมือ่ถกูสัง่ใหมเ่ป็นครัง้ๆไป ดงันัน้หากตอ้งการแสดง

รายละเอยีดของขอ้มลูทีซ่ํ้ากนัในทนัททีีม่กีารเปลีย่นแปลง ตอ้งหนัมารูจั้กกบัสตูรทีเ่รยีกกนัวา่

สตูร Multiple Match 

สตูร Multiple Match ถอืเป็นสตูรทีถ่กูถามกนับอ่ยครัง้มาก ถงึแมไ้ดเ้คยเขยีนอธบิายไวอ้ยา่ง

ละเอยีดหลายครัง้หลายโอกาสแลว้ก็ตาม มกัไมเ่ขา้ใจวา่สตูรนีส้รา้งกนัไดอ้ยา่งไรหากไมไ่ดเ้ห็น

ขัน้ตอนการสรา้งทลีะขัน้กบัตาตวัเอง 

 

ตารางดา้นซา้ยมอืของภาพนีเ้ป็นตารางฐานขอ้มลูซึง่มคีา่ซํ้ากนับนัทกึไว ้เชน่ ขอ้มลูของรหสั 

a001 ถกูบนัทกึไวใ้นรายการที ่1, 6, 9, 11, และ 15 โดยตวัเลขตําแหน่งรายการของรหสั a001 

เหลา่นีส้ามารถหาไดด้ว้ยสตูร Multiple Match {=SMALL(IF(ID=G3,Num),Num)} ซึง่สรา้ง

ไวใ้นเซลล ์L3:L12 แบบ Array 

ตวัอยา่งนีใ้ชก้ารตัง้ชือ่ Range Name วา่ Num, ID, Name, และ Amount ใหก้บัพืน้ทีข่อ้มลู 

B3:B20, C3:C20, D3:D20, และ E3:E20 ตามลําดบั สว่นเซลล ์G3 เป็นเซลลรั์บคา่รหสัที่

ตอ้งการคน้หาตําแหน่งรายการ 
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เพือ่แสดงใหเ้ห็นทีไ่ปทีม่าของสตูร {=SMALL(IF(ID=G3,Num),Num)} วา่เกดิจากการ

คํานวณหลายขัน้ตอนและแตล่ะขัน้ทําหนา้ทีห่าคา่อะไรบา้ง ขออธบิายสตูรทีส่รา้งไวใ้น Step1 - 

Step3 ดงันี ้(เวลาใชง้านจรงิไมจํ่าเป็นตอ้งสรา้งสตูรเหลา่นีแ้ตอ่ยา่งใด) 

Step1 : เริม่จากเลอืกเซลล ์I3:I20 พรอ้มกนัแลว้สรา้งสตูร =ID=G3 แลว้กดปุ่ ม 

Ctrl+Shift+Enter จะมวีงเล็บปีกกาปิดหวัทา้ยสตูรกลายเป็น {=ID=G3} คนืคา่ออกมาเป็น 

True คูข่นานตรงกบัตําแหน่งรายการทีม่รีหสั a001 

Step2 : ปรับตําแหน่งทีเ่ป็น True จาก Step1 ใหเ้ป็นเลขทีร่ายการ Num โดยเลอืกเซลล ์

J3:J20 พรอ้มกนัแลว้สรา้งสตูร =IF(I3:I20,Num) แลว้กดปุ่ ม Ctrl+Shift+Enter จะมวีงเล็บ

ปีกกาปิดหวัทา้ยสตูรกลายเป็น {=IF(I3:I20,Num)} จะพบวา่ตําแหน่งทีเ่คยเป็นคา่ True 

กลายเป็นเลขตําแหน่งรายการ 1, 6, 9, 11, 15 ขึน้มาใหเ้ห็นแทน 

Step3 : นําตวัเลขตําแหน่งรายการจาก Step2 มาเรยีงจากนอ้ยไปมากโดยนําไปซอ้นในสตูร 

Small โดยเลอืกเซลล ์K3:K20 พรอ้มกนัแลว้สรา้งสตูร =SMALL(J3:J20,Num) แลว้กดปุ่ ม 

Ctrl+Shift+Enter จะมวีงเล็บปีกกาปิดหวัทา้ยสตูรกลายเป็น {=SMALL(J3:J20,Num)} 

เมือ่นําสตูรจาก Step1 – Step3 มาซอ้นกนัจะกลายเป็นสตูร Multiple Match ในเซลล ์L3:L12 

{=SMALL(IF(ID=G3,Num),Num)} ทัง้นีโ้ปรดสงัเกตวา่ไมจํ่าเป็นตอ้งสรา้งสตูรลงไปในเซลล ์

L3:L20 ทีย่าวลงมาถงึ row 20 เชน่ทีใ่ชก้บัสตูรใน Step1 – Step3 แตอ่ยา่งใด แตใ่หเ้ลอืก

จํานวน row จากเซลล ์L3:L12 หรอื 10 row เทา่ทีค่ดิวา่รหสัจะมโีอกาสซํา้กนัสงูสดุกีค่รัง้ก็พอ 

จากนัน้ใหใ้ชส้ตูร Index ดงึขอ้มลูตามลําดบัรายการทีห่าไดม้าแสดงตอ่ไป 
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การหาเลขตาํแหนง่รายการขอ้มลูทีเ่ป็น Unique Item 

Unique Item คอื ขอ้มลูทีไ่มซ่ํ้ากบัขอ้มลูอืน่ ซึง่ในกรณีทีม่กีารบนัทกึรายการซํ้ากนัไวห้ลาย

รายการ รายการแรกของแตล่ะชดุทีซ่ํ้ากนัก็คอื Unique Item โดยใชส้ตูรคลา้ยกบัสตูร Multiple 

Match เพยีงมขีัน้ตอนเพิม่ขึน้อกีหนึง่ขัน้ตอน 

 

ในภาพนีต้ารางรหสั ID จาก C3:C20 มรีหสับนัทกึไวซ้ํ้ากนั รหสั ID ทีเ่ป็น Unique Item คอื

รหสัรายการที ่1, 2, 3, 4, 5, 7, 10, และ 16 ซึง่หาตวัเลขตําแหน่งรายการเหลา่นีไ้ดจ้ากสตูร 

Array ในเซลล ์I3:I12 { =SMALL( IF(MATCH(ID&"",ID&"",0) = Num, Num), Num)} 

โดยสตูรนีต้อ้งสรา้งพรอ้มกนัลงทเีดยีวไปในเซลล ์I3:I12 แลว้กดปุ่ ม Ctrl+Shift+Enter เพือ่

ทําใหม้เีครือ่งหมายวงเล็บปีกกาปิดหวัทา้ยสตูรใหเ้อง (ทัง้นีใ้หเ้ลอืกจํานวนเซลล ์I3:I12 มาก

หรอืนอ้ยกวา่นีก้็ไดแ้ลว้แตว่า่จะมจํีานวน Unique Item ทัง้หมดมากนอ้ยเทา่ใด) 

Step1 : สตูร MATCH(ID&"",ID&"",0) ทําหนา้ทีห่าเลขตําแหน่งรายการของ ID แตล่ะตวั 

สาเหตทุีต่อ้งปรับใหใ้ช ้ID&"" เพือ่ทําใหส้ตูรนีย้งัใชง้านไดห้ากมเีซลลว์า่ง เชน่ เซลล ์C20 

Step2 : นําคา่จาก Step1 ไปเทยีบกบัเลขลําดบั Num จะพบวา่ตําแหน่งรายการทีต่รงกนั หรอื

แสดงคา่เทา่กบั True คอืตําแหน่งทีเ่ป็น Unique Item 
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Step3 : เปลีย่นคา่ True จาก Step2 ใหเ้ป็นเลขทีร่ายการดว้ยสตูร 

IF(MATCH(ID&"",ID&"",0) = Num, Num) 

Step4 : เรยีงเลขตําแหน่งรายการทีไ่ดจ้าก Step3 ใหเ้รยีงจากนอ้ยไปมากดว้ยสตูร Small 

เมือ่ไดต้วัเลขตําแหน่งรายการทีเ่ป็น Unique แลว้ใหใ้ชส้ตูร Index แสดงชือ่รหสั ID ตอ่ไป 

นอกจากสตูรขา้งตน้แลว้ ยงัมสีตูรลดัหาชือ่รายการทีเ่ป็น Unique หรอืจะใชคํ้าสัง่ Data > 

Advanced แบบ Unique records only 

 

เซลล ์D3 สรา้งสตูร =B3 เพือ่นํารหสัรายการแรกยกมาเป็น Unique Item ไวก้อ่น จากนัน้ใน

เซลล ์D4 ใหส้รา้งสตูร Array {=INDEX(ID,MATCH(0,COUNTIF($D$3:D3,ID),0))} แลว้ 

copy สตูรไปตอ่ลงไปในเซลลถ์ดัไปดา้นลา่ง โปรดดรูายละเอยีดของสตูรนีไ้ดจ้าก 

http://www.get-digital-help.com/2009/03/30/how-to-extract-a-unique-list-and-the-

duplicates-in-excel-from-one-column/ 
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การใชค้าํส ัง่ Data > Advanced เพือ่หา Unique List 

 

เริม่จากสัง่ Data > Advanced แลว้กาชอ่ง Copy to another location กําหนด List range 

เป็นตารางฐานขอ้มลู B2:B19 ซึง่อยูใ่นแนว column เดยีว (ไมส่ามารถใชห้ลาย column พรอ้ม

กนั) แลว้เลอืก Copy to ไปยงัเซลล ์D2 ทีต่อ้งการคําตอบ โดยอยา่ลมืกาชอ่ง Unique records 

only ดา้นลา่งสดุ ก็จะไดร้ายการ Unique List แสดงออกมาใหเ้ห็นในเซลล ์D2:D10 

ตามปกตกิารหา Unique List เป็นงานทีน่านๆทจีะทําสกัครัง้หนึง่ พอไดร้ายการ Unique List 

แลว้ก็จะใชง้านไปอกีนานจนกวา่จะมรีายการแปลกใหมเ่พิม่เขา้มา ดงันัน้การใชคํ้าสัง่ 

Advanced Filter แบบ Unique จงึเป็นวธิทีีง่า่ยและสะดวกกวา่การสรา้งสตูรขึน้มาใชเ้องอยา่ง

มาก แตอ่ยา่ลมืวา่การใชคํ้าสัง่บนเมนูจะไมห่าคําตอบใหมใ่หห้ากมกีารเปลีย่นแปลงขอ้มลู 
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การปรบัคา่ซํา้ใหก้ลายเป็น Unique Item 

แมส้ตูร Multiple Match จะชว่ยลดัหาตวัเลขตําแหน่งรายการทีซ่ํ้ากนัใหท้นัททีีม่กีาร

เปลีย่นแปลงแกไ้ขขอ้มลูก็ตาม แตส่ตูรนีต้อ้งสรา้งแบบ Array ลงไปในตารางพรอ้มกนั จงึ

คอ่นขา้งยากและเสีย่งสําหรับมอืใหมซ่ึง่ไมคุ่น้เคยกบัสตูร Array มากอ่นทีจ่ะปรับแตง่สตูรใหเ้ขา้

กบังานของตนหากขาดพืน้ฐานทีไ่ปทีม่าวา่สตูรนีคํ้านวณเลขตําแหน่งรายการทีซ่ํ้ามาไดอ้ยา่งไร 

แทนทีจ่ะใชส้ตูร Multiple Match กบัตารางทีม่รีายการซํ้ากนั ใหห้าทางปรับคา่ซํ้าในตาราง

ฐานขอ้มลูใหเ้กดิคา่ใหมท่ีไ่มซ่ํ้าหรอือกีนัยหนึง่คอืปรับคา่ซํ้าใหก้ลายเป็น Unique Item ซึง่

สามารถใชส้ตูร VLookup หรอื Match และ Index ในการคน้หาขอ้มลูทีต่อ้งการไดง้า่ยและ

รวดเร็วกวา่สตูร Multiple Match ทีใ่ชเ้วลาในการคํานวณแบบ Array ชา้กวา่ 

 

สงัเกตวา่เดมิรหสั ID ในเซลล ์B3:B7 มรีหสับนัทกึไวซ้ํ้า สว่นรหสัใหม ่NewID ในเซลล ์D3:D7 

ไมม่รีหสัใดซํ้ากนัอยูเ่ลยเป็น Unique Item 

ใหเ้ริม่จากเพิม่ column C และ D แลว้สรา้งสตูร =COUNTIF($B$3:B3,B3) ลงไปในเซลล ์C3 

แลว้ copy ลงไปในเซลล ์C3:C7 คูข่นานกบัรหสั ID เดมิใหค้รบทกุตวั เลขผลลพัธ ์1, 1, 2, 1, 

และ 2 ทีไ่ด ้เป็นเลขแสดงตวัทีซ่ํา้ของรหสัแตล่ะตวัน่ันเอง เชน่ เลข 1 ทีไ่ดใ้นเซลล ์C3 

หมายความวา่ a001 ในเซลล ์B3 เป็น a001 ตวัที ่1 สว่นเลข 2 ในเซลล ์C5 หมายความวา่ 

a001 ในเซลล ์B5 เป็น a001 ตวัที ่2 

จากนัน้ใหส้รา้งรหสั NewID ในเซลล ์D3 สรา้งสตูร =B3&"-"&C3  แลว้ copy ลงไปใหค้รบ

เซลล ์D3:D7 จะเกดิรหสัใหมท่ีไ่มซ่ํ้า เชน่ a001-2 แสดงวา่เป็นรหสั a001 ตวัที ่2 แลว้ใชร้หสั

ใหมน่ีใ้นการคน้หาขอ้มลูของรหสัทีก่รอกลงไปในเซลล ์H3 ดว้ยสตูร VLookup ในเซลล ์I3 

และ J3 ตอ่ไป แมว้ธินีีทํ้าใหม้จํีานวนเซลลส์ตูรเพิม่ขึน้ ซึง่ยอ่มทําใหแ้ฟ้มมขีนาดใหญข่ึน้ แต่

เวลาทีใ่ชคํ้านวณอาจรวดเร็วกวา่การใชส้ตูร Multiple Match ในแฟ้มทีม่ขีนาดเล็กกวา่ก็เป็นได ้
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การคาํนวณยอดรวมเพือ่จดัทาํรายงาน 

การจัดเก็บขอ้มลูไวใ้นโครงสรา้งฐานขอ้มลูทีถ่กูตอ้ง เป็นองคป์ระกอบสําคญัชว่ยทําใหเ้กดิ

ความสะดวกและงา่ยในการหาคําตอบทีต่อ้งการ แตผู่ใ้ช ้Excel แบบมกังา่ยอาจหาทางทีง่า่ย

กวา่นัน้โดยปรับแตง่โครงสรา้งฐานขอ้มลูใหก้ลายเป็นหนา้รายงาน ทําใหไ้มส่ามารถใช ้

ฐานขอ้มลูไดเ้ต็มทีอ่กีตอ่ไป ยิง่กวา่นัน้หากรายงานทีต่อ้งจัดพมิพม์รีอ้ยหนา้ ก็มกัออกแบบ

ตารางรายงานเลยีนแบบหนา้รายงานทัง้รอ้ยหนา้ ทําใหแ้ฟ้มมขีนาดใหญข่ึน้อยา่งมากเนือ่งจาก

ตอ้งเตรยีมพืน้ทีใ่นชทีเดยีวกนั ตา่งชที หรอืตา่งแฟ้ม รอไวสํ้าหรับแสดงขอ้มลูทกุหนา้ 

พงึระลกึไวเ้สมอวา่ฐานขอ้มลูทีด่ตีอ้งคงสภาพโครงสรา้งเชน่เดมิไวต้ลอด การเปลีย่นแปลงที่

เกดิขึน้กบัตารางฐานขอ้มลูจะมเีพยีงการเพิม่รายการใหมต่อ่ทา้ยรายการเดมิลงไปเรือ่ยๆ หากไม่

จําเป็นจะไมม่กีาร insert row แทรก หรอื delete row ลบรายการทีบ่นัทกึไวท้ิง้ และหนา้

รายงานตอ้งหาทางสรา้งขึน้เพยีงหนา้เดยีวหรอืสตูรเดยีว แลว้หาทางเปลีย่นหนา้เดยีวหรอืสตูร

เดยีวนัน้ใหแ้สดงคําตอบหนา้อืน่ๆหรอืเรือ่งอืน่ๆไดโ้ดยไมต่อ้งสรา้งหนา้ใหมห่รอืสตูรใหมข่ึน้อกี 

หลงัจากฐานขอ้มลูมโีครงสรา้งทีแ่น่นอนชดัเจนแลว้ เมือ่ตอ้งการหาคําตอบเกีย่วขอ้งกบัตวัเลข

ยอดรวม มทีางเลอืกใหใ้ชคํ้าสัง่หรอืสตูรได ้ดงันี ้

 ใชส้ตูร SubTotal รว่มกบัคําสัง่ Filter และ Custom Views 

 ใชคํ้าสัง่ Data > SubTotal เพือ่สรา้งยอดรวมรายการแตล่ะประเภทขึน้ภายในตาราง

ฐานขอ้มลูนัน้ 

 ใชคํ้าสัง่ Data > Consolidate เพือ่รวมตวัเลขของหลายตารางตามตําแหน่งเรือ่ง

เดยีวกนัเขา้ดว้ยกนั 

 ใชส้ตูร Array SumIF หรอื DSum เพือ่หายอดรวมแยกประเภท แลว้ใชคํ้าสัง่ Data > 

What-if Analysis > Data Table เพือ่หายอดรายการอืน่ๆตอ่ 

 ใชคํ้าสัง่ Insert > Pivot Table เพือ่สรา้งตารางเปรยีบเทยีบตวัเลขคําตอบ 
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ทางออกทีด่กีวา่การใชส้ตูรบวกหรอืสตูร Sum 

กอ่นจะอธบิายสตูร SubTotal หลายคนอาจจะสงสยัวา่ทําไมจงึไมอ่ธบิายวธิใีชส้ตูร Sum ไว ้

กอ่น ทัง้นีไ้มใ่ชเ่พราะสตูร Sum เป็นสตูรงา่ยทีท่กุคนควรรูจั้กกนัดอียูแ่ลว้หรอก แตเ่นือ่งจาก 

Sum เป็นสตูรทีเ่หมาะสําหรับใชห้ายอด

รวมจากตารางซึง่มโีครงสรา้งแน่นอน

ถาวร และในอนาคตตอ้งไมม่กีาร

เปลีย่นแปลงโครงสรา้งอกีตอ่ไป 

ในภาพนี ้เซลล ์B12 หายอดรวมของ
เซลล ์B2:B11 ดว้ยสตูร =SUM(B2:B11) 
ไดคํ้าตอบยอดรวมเทา่กบั 55 

หากตอ่มามกีารปรับโครงสรา้งตาราง โดย
กําหนดใหห้ายอดรวมของเซลล ์B2:B6 เพิม่ และใหแ้ทรก row ใหมร่ะหวา่ง row 6 และ row 7 
แลว้สรา้งสตูร =SUM(B2:B6) ลงไปในเซลล ์B7 ไดย้อดรวมเทา่กบั 15 แตจ่ะสง่ผลใหส้ตูร 
Sum เดมิทีห่ายอดรวมทัง้หมดเทา่กบั 55 กลายเป็นยอดรวมใหมเ่ทา่กบั 77 ซึง่เป็นคําตอบทีผ่ดิ
เนือ่งจากนํายอดรวมของ Sum ในเซลล ์B7 ไปรวมเขา้ไปอกี 

 

แทนทีจ่ะเลอืกใชส้ตูร Sum ตัง้แตแ่รก ถา้เปลีย่น =SUM(B2:B11) ไปสรา้งสตูรบวกแตล่ะเซลล์
เขา้ดว้ยกนัเป็น =B2+B3+B4+B5+B6+B7+B8+B9+B10+B11 แลว้หากภายหลงัมกีารแทรก 
row และใสค่า่ใหมเ่พิม่เขา้ไปในเซลลเ์ชน่ทีย่กตวัอยา่งขา้งตน้ ก็จะไมเ่กดิปัญหาทําใหส้ตูรบวก
คํานวณคา่ผดิพลาด เพราะสตูรบวกยงัคงเลอืกเฉพาะเซลลต์ามเดมิทีกํ่าหนดไวใ้หเ้สมอ แตส่ตูร
บวกกนัทลีะเซลลไ์มใ่ชท่างออกทีด่นัีกหากมเีซลลท์ีต่อ้งการนํามาบวกกนันับพันนับหมืน่เซลล ์
วธิทีีด่กีวา่การใชส้ตูรบวกหรอืสตูร Sum ก็คอื การใชส้ตูร SubTotal 
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การใชส้ตูร SubTotal รว่มกบัคาํส ัง่ Filter และ Custom Views 

หากแปลคําวา่ SubTotal กนัตรงๆอาจเขา้ใจวา่สตูร SubTotal นีทํ้าหนา้ทีห่ายอดรวม Total 
ของรายการแตล่ะกลุม่ที ่Sub เอาไว ้ซึง่ก็แปลงไดไ้มผ่ดินัก แตส่ตูรนีม้ไิดห้าคําตอบใหเ้ฉพาะ
ยอดรวมเทา่นัน้ หากยงัสามารถดดัแปลงใหคํ้านวณหาคา่เฉลีย่หรอืนับไดอ้กีดว้ย โดยเลอืก
กําหนดใหส้ตูร SubTotal คํานวณหายอดตวัเลขไดถ้งึ 11 แบบตามโครงสรา้งสตูรตอ่ไปนี ้

=SubTotal( ตวัเลขประเภทการคาํนวณ, พืน้ทีเ่ซลล ์) 

ตวัเลขประเภทการคํานวณ กําหนดตวัเลขตัง้แตเ่ลข 101 – 111 แตเ่ลขทีใ่ชก้นัทัว่ไปไดแ้ก ่

 101 กําหนดให ้SubTotal ทําหนา้ทีแ่บบสตูร Average 
 102 กําหนดให ้SubTotal ทําหนา้ทีแ่บบสตูร Count 
 103 กําหนดให ้SubTotal ทําหนา้ทีแ่บบสตูร CountA 
 109 กําหนดให ้SubTotal ทําหนา้ทีแ่บบสตูร Sum 

SubTotal มคีวามสามารถพเิศษเหนอืกวา่สตูร Sum กลา่วคอื SubTotal เป็นสตูรทีจ่ะไมนํ่าคา่
จากเซลลท์ีม่สีตูร SubTotal มาคํานวณซํ้าอกี 

 

สงัเกตวา่ในเซลล ์B7 และ B13 ใชส้ตูร SubTotal เพือ่หายอดรวมของตวัเลขจากเซลล ์B2:B6 
และ B2:B12 ตามลําดบั โดยในเซลล ์B13 ใชส้ตูร =SUBTOTAL(109,B2:B12) แมว้า่ได ้
กําหนดขอบเขตของตารางทีต่อ้งการหายอดรวมไวต้ัง้แตเ่ซลล ์B2:B12 ซึง่รวมถงึเซลล ์B7 ทีม่ี
ยอดตวัเลขรวมจากเซลล ์B2:B6 ไวก้็ตาม สตูร SubTotal ในเซลล ์B13 จะละเลยไมนํ่าคา่ใน
เซลล ์B7 มาคํานวณซํ้าอกี ทําใหย้งัคงไดคํ้าตอบเทา่กบั 55 
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ถา้นําสตูร SubTotal ไปใชร้ว่มกบัตารางทีถ่กูซอ่น row/column hide หรอืกรองจากคําสัง่ Data 
> Filter จะพบวา่ สตูร SubTotal แสดงตวัเลขคําตอบเฉพาะทีไ่ดม้าจากเซลลท์ีย่งัมองเห็นตวั
เซลลอ์ยูเ่ทา่นัน้ (Visible Cells Only) โดยตวัสตูรเองไมไ่ดต้อ้งเปลีย่นแปลงใหมแ่ตอ่ยา่งใด 

(Excel รุน่เกา่กวา่ Excel 2003 จะรับตวัเลขประเภทการคํานวณตัง้แตเ่ลข 1 - 11 และใชร้ว่มกบั
การ Filter เทา่นัน้ แตถ่า้ใช ้Excel 2003 เป็นตน้มาแนะนําใหใ้ชต้วัเลข 101 – 111 แทน จะ
สามารถใชร้ว่มกบั Filter หรอืจะซอ่น row/column เองไดอ้กีดว้ย) 

 

หลงัจากทีก่รองหรอืจัดโครงสรา้งตารางเพือ่แสดงผลใหเ้ห็นบนจอตามตอ้งการไดแ้ลว้ ควรใช ้
คําสัง่ View > Custom Views > Add เพือ่ตัง้ชือ่ใหก้บัการแสดงผลตามทีจั่ดไว ้

 

จากนัน้เมือ่ตอ้งการแสดงโครงสรา้งตารางตามแบบใด ใหส้ัง่ View > Custom Views แลว้คลกิ
เลอืกชือ่แบบทีต่ัง้ไวใ้นชอ่ง Views แลว้กดปุ่ ม Show จะไดโ้ครงสรา้งตารางตามแบบทีต่ัง้ชือ่ไว ้
พรอ้มกบัสตูร SubTotal แสดงตวัเลขคําตอบเฉพาะเซลลท์ีย่งัมองเห็นใหพ้รอ้มกนัไป 
(นอกจากนัน้ Custom Views ยงัชว่ยจําการกําหนด Print Setting แตล่ะแบบใหอ้กีดว้ย) 
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การใชค้าํส ัง่ Data > Subtotal 

Data > SubTotal ใชก้บัตารางฐานขอ้มลูซึง่จัดเรยีงขอ้มลูแยกตามกลุม่ทีต่อ้งการไวก้อ่นแลว้

และตอ้งเป็นตารางซึง่ไมม่สีตูรใดๆสรา้งไว ้เมือ่ใชคํ้าสัง่นีจ้ะเกดิสตูร SubTotal หายอดรวมแยก

ตามกลุม่ใหท้นัท ีพรอ้มกบัสรา้ง Outline เพือ่ใชค้ลกิเลอืกแสดงรายละเอยีดทลีะขัน้ตาม

ตอ้งการใหอ้กี และเมือ่นํามาใชง้านรว่มกบั Custom Views จะเป็นเครือ่งมอืใชช้ว่ยงาน

ฐานขอ้มลูไดอ้ยา่งไมน่่าเชือ่ 

เริม่จากจัดเรยีงขอ้มลูเพือ่จัดกลุม่ขอ้มลูทีต่อ้งการหายอดรวม แยกเฉพาะแตล่ะกลุม่กอ่น โดยสัง่ 

Data > Sort จากนัน้คลกิลงในตารางขอ้มลูเซลลใ์ดก็ได ้แลว้สัง่ Data > Subtotal 

 

 ชอ่ง At each change in: ใหเ้ลอืกชือ่ Header ทีต่อ้งการหาผลรวมตามกลุม่ของ 

Header นัน้ๆ 

 ชอ่ง Use function: ใหเ้ลอืก Sum 

 ชอ่ง Add subtotal to: ใหเ้ลอืกชือ่ Header ของ Field ทีต่อ้งการหายอดรวม 

 กดปุ่ ม OK จะพบวา่ ม ีRow ใหมแ่ทรกขึน้เองและมสีตูร Subtotal คํานวณยอดใหท้นัท ี
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หากตอ้งการสรา้ง Subtotal ระดบัรองซอ้น Subtotal ระดบัแรก ใหส้ัง่ Data > Subtotal ซํ้าอกี

ครัง้แลว้เปลีย่น Header ใหมใ่นชอ่ง At each change in: แลว้ใหต้ดักาเครือ่งหมายถกูในชอ่ง 

Replace current subtotals ออก แลว้กด OK 

 

เมือ่กดปุ่ มเครือ่งหมายลบหรอืปุ่ มหมายเลขระดบัชัน้ของ Outline ดา้นบนซา้ย รายการขอ้มลูจะ

หบุ และปุ่ ม Outline จะกลายเป็นเครือ่งหมายบวกแทน หากตอ้งการ Copy เฉพาะ Visible 

Cells ใหเ้ลอืกพืน้ทีต่ารางแลว้กด F5 > Special > เลอืก Visible cells only จากนัน้สัง่ Copy 

ไป Paste จะไดเ้ฉพาะพืน้ทีท่ีเ่หลอืจากการกดปุ่ ม Outline เทา่นัน้ 

ขอ้ดขีองการใชคํ้าสัง่นี ้นอกจาก Excel จะสรา้งสตูร SubTotal ใหเ้องแลว้ หากตอ้งการสัง่

ยอ้นกลบัไปเป็นตารางฐานขอ้มลูตามแบบเดมิ ใหก้ดปุ่ ม Remove All 

หมายเหต ุหากตอ้งการสรา้ง Outline ขึน้มาใชเ้อง ใหเ้ลอืกเซลลท์ีต่อ่เนือ่งกนัแลว้ใชคํ้าสัง่ 

Data > Group  
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การใชค้าํส ัง่ Data > Consolidate 

 

จากภาพนีต้ารางของ Division 1 และ Division 4 มโีครงสรา้งเหมอืนกนั ถา้ตอ้งการหายอดรวม

ตวัเลขเรือ่งเดยีวกนัจากหลายตารางเขา้ดว้ยกนั ใหเ้ริม่จากเปิดชทีใหมข่ึน้มากอ่น แลว้สัง่ Data 

> Consolidate จากนัน้คลกิเลอืกพืน้ทีต่ารางขอ้มลูชดุแรกใหแ้สดงในชอ่ง Reference แลว้กด

ปุ่ ม Add แลว้เลอืกพืน้ทีจ่ากตารางอืน่มา Add ซํ้าจนกวา่จะครบทกุตารางทีต่อ้งการ (โดยจะ

เลอืกจากตารางทีอ่ยูต่า่งชทีหรอืตา่งแฟ้มกนัก็ได)้ แลว้อยา่ลมืกาชอ่ง Use labels in พรอ้มกบั

กาชอ่ง Crate links to source data ใหค้รบเพือ่จะไดส้ตูรลงิคค์า่จากตารางตน้ทางมาใชด้ว้ย 
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สตูร Array IF เพือ่ใชห้ายอดรวมแยกประเภท 

สตูร Array IF เพือ่ใชห้ายอดรวมแยกประเภท ถอืเป็นสตูรทีสํ่าคญัเป็นอยา่งยิง่และเป็นสตูรทีใ่ช ้

บอ่ยทีส่ดุสตูรหนึง่ทเีดยีว จนใน Excel 2007 เป็นตน้มาบรษัิทไมโครซอฟทไ์ดเ้พิม่สตูร 

SumIFs, CountIFs, และ AverageIFs เพือ่ตอบสนองตอ่ความตอ้งการของผูใ้ช ้เพราะใน 

Excel รุน่กอ่นนัน้มเีพยีงสตูร SumIF และ CountIF ซึง่ไมส่ามารถรับเงือ่นไขในการคํานวณเกนิ

กวา่ 1 เงือ่นไข 

แตถ่า้คณุนําแฟ้มทีใ่ชส้ตูร SumIFs, CountIFs, และ AverageIFs ไปเปิดดว้ย Excel 2003 

หรอืรุน่เกา่กวา่ จะพบวา่สตูรใหมเ่หลา่นีไ้มทํ่างานเพราะ Excel รุน่ทีจ่ะใชส้ตูรใหมไ่ดก้็ตอ้งเป็น 

Excel รุน่ใหมเ่ชน่กนั 

บทความนีจ้ะแนะนําแนวทางการสรา้งสตูร Array IF วา่มทีีไ่ปทีม่าอยา่งไร เพือ่ชว่ยใหส้ามารถ

สรา้งสตูรหายอดรวมแยกประเภทไดโ้ดยไมจํ่าเป็นตอ้งอาศยัสตูร SumIFs, CountIFs, และ 

AverageIFs แตอ่ยา่งใด แลว้เมือ่คณุทราบหลกัการทํางานของการใช ้Array IF หรอื Array 

แบบเงือ่นไข ยงัจะชว่ยใหส้ามารถนําไปพัฒนาสรา้งสตูรหาคําตอบประเภทอืน่ๆไดไ้มย่าก 

สตูร Array IF คอือะไร 

สตูร Array IF คอื สตูร IF ทีทํ่าหนา้ทีต่รวจสอบคา่หลายคา่วา่ตรงตามเงือ่นไขทีกํ่าหนดหรอืไม ่

โดยจะไดผ้ลลพัธจ์ากการตรวจสอบเป็น True หรอื False หลายคา่ตามลําดบัตําแหน่งของคา่ที่

ใช ้ซึง่ตา่งจากสตูร IF ธรรมดาทีม่กีารตรวจสอบคา่เพยีงคา่เดยีวและเกดิผลลพัธเ์ป็น True หรอื 

False อยา่งใดอยา่งหนึง่เพยีงคา่เดยีว 

โดยลําพังของสตูร Array IF จะไมส่ามารถหายอดรวมแยกประเภทได ้แตเ่มือ่นําผลลพัธ ์True 

หรอื False ทีไ่ดนั้น้ไปเทยีบกบั Array ของตวัเลขคําตอบทีต่อ้งการ จะทําใหเ้ราสามารถเลอืก

เก็บตวัเลขเฉพาะตําแหน่งคา่ทีต่รงกบัตําแหน่งของ True แลว้จงึนําผลทีไ่ดไ้ปหายอดรว่มกบั

สตูรอืน่ๆก็จะกลายเป็นสตูร Array เพือ่หาคา่ตามสตูรนัน้ๆ เชน่ เมือ่นําผลทีไ่ดห้ลงัจากการเทยีบ

ตําแหน่ง True/False ไปซอ้นในสตูร Sum ก็จะกลายเป็นสตูร Array Sum IF ซึง่หายอดรวม

แยกประเภท หรอืถา้ซอ้นในสตูร Average ก็จะกลายเป็นสตูร Array Average IF ซึง่หาคา่เฉลีย่

แยกประเภท 
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โครงสรา้งของสตูร Array IF ประกอบดว้ย 2 สว่นใหญ่ๆ  ซึง่โดยทัว่ไปทัง้ 2 สว่นตอ้งมขีนาด

ความสงูความกวา้งของ Array เทา่กนั กลา่วคอื 

1. สว่นของ Array ทีทํ่าหนา้ทีค่นืคา่ True หรอื False 

2. สว่นของ Array ทีเ่ป็นตวัเลขหรอืคา่คําตอบเรือ่งทีต่อ้งการ 

(ในเบือ้งตน้ขอใหจํ้าไวว้า่ขนาด Array ทัง้สองสว่นนีต้อ้งมขีนาดเทา่กนั ซึง่ทีจ่รงิแลว้ขอเพยีงวา่

มขีนาดความสงูหรอืขนาดความกวา้งดา้นใดดา้นหนึง่เทา่กนัก็ใชไ้ดแ้ลว้) 

การใชส้ตูร Array IF แบบเงือ่นไขเดยีว 

 

โปรดสงัเกตวา่ใน Range ID มรีหสั a001 และ a002 เป็นรายการทีบ่นัทกึซํ้า ซึง่ถา้มรีหสัไมซ่ํ้า

แลว้ตอ้งการหายอด Amount ของ a001 จะสามารถหาคําตอบโดยใชส้ตูร VLookup ไดท้นัท ี

แตเ่มือ่มรีายการซํ้า ถา้ใชส้ตูร VLookup ก็จะไดย้อดของ a001 รายการแรกเพยีงรายการเดยีว 

หากตอ้งการหายอดรวม Amount ของ a001 หรอืจะแยกหายอดแตล่ะรายการทีซ่ํ้าของ a001 

ก็ตอ้งอาศยัสตูรคํานวณแบบ Array มาชว่ย 

ถา้ไมใ่ชส้ตูร Array IF จะหายอดรวม Amount ของรหสั a001 จากการคํานวณทลีะขัน้ได ้

อยา่งไร 
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1. เพือ่ทําใหต้ารางแสดงเฉพาะพืน้ทีซ่ ึง่เกีย่วขอ้งกบัการคํานวณเทา่นัน้ จงึขอลบพืน้ทีส่ว่น
ของ Num และ Name ทิง้ไป แลว้ Insert เพิม่ column C และ E มาใชคํ้านวณทลีะขัน้ 

2. ตัง้ชือ่ Check ใหก้บัเซลล ์C3:C7 แลว้สรา้งสตูร =Id=$G$3 จะพบวา่ไดคํ้าตอบเป็น 
TRUE; FALSE; TRUE; FALSE; FALSE ตามลําดบั โดยตําแหน่งทีเ่ป็น True คอื
ตําแหน่งของรหสั a001 น่ันเอง 

3. เซลล ์E3:E7 สรา้งสตูร =IF(Check,Amount,0) จะพบวา่ถา้ตําแหน่งใดใน Check มคีา่
เทา่กบั True สตูร IF นีจ้ะเก็บคา่ Amount มาใชต้ามเดมิ แตถ่า้ไมใ่ชจ่ะใสค่า่ 0 แทน 

4. เซลล ์E8 สรา้งสตูร =SUM(E3:E7) ไดคํ้าตอบเทา่กบั 40 ซึง่เป็นยอดรวมแยกประเภท
ของรหสั a001 ตามตอ้งการ 

แทนทีจ่ะตอ้งสรา้งตารางเพิม่เตมิเพือ่คํานวณทลีะขัน้ เราสามารถลดัหาคําตอบยอดรวมแยก

ประเภทของรหสั a001 ทีต่อ้งการโดยพจิารณาแยกพืน้ทีต่ารางเป็น 2 สว่น 
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1. Id เป็นสว่นของ Array ทีทํ่าหนา้ทีค่นืคา่ True หรอื False จากการนําไปเปรยีบเทยีบคา่
กบัรหสัทีต่อ้งการ 

2. Amount เป็นสว่นของ Array ทีเ่ป็นตัวเลขหรอืคา่คําตอบเรือ่งทีต่อ้งการ 

จากนัน้เราสามารถหาคําตอบยอดรวมแยกประเภทของรหสั a001 ซึง่บนัทกึไวใ้นเซลล ์G3 เป็น

เซลลสํ์าหรับใสร่หสัทีต่อ้งการ แลว้ใชส้ตูรตอ่ไปนีห้าผลลพัธท์ีต่อ้งการ 

1. สตูร SUMIF โดยใชส้ตูร =SUMIF(Id,$G$3,Amount) หรอื 

2. สตูร Array SumIF โดยใชส้ตูร { =SUM(IF(Id=$G$3,Amount))} โดยตอ้งกดปุ่ ม 
Ctrl+Shift+Enter ดว้ยจงึจะเกดิวงเล็บปีกกา { } ปิดหวัทา้ยสตูร หรอื 

3. สตูร SumArray โดยใชส้ตูร { =SUM((Id=$G$3)*Amount)} โดยตอ้งกดปุ่ ม 
Ctrl+Shift+Enter ดว้ยจงึจะเกดิวงเล็บปีกกา { } ปิดหวัทา้ยสตูร หรอื 

4. สตูร SumProduct โดยใชส้ตูร =SUMPRODUCT((Id=$G$3)*Amount) โดยไม่
ตอ้งกดปุ่ ม Ctrl+Shift+Enter ดว้ยแตอ่ยา่งใด 

สตูรทัง้สีแ่บบใชห้ลกัการคํานวณแบบเดยีวกนั คอื 

1. Id เป็นสว่นของ Array ทีทํ่าหนา้ทีค่นืคา่ True หรอื False จากการนําไปเปรยีบเทยีบคา่
กบัรหสั a001 ทีต่อ้งการ จะคนืคา่ออกมาเป็น Array  
{TRUE;FALSE;TRUE;FALSE;FALSE} 

2. Amount เป็นสว่นของ Array ทีเ่ป็นตัวเลขหรอืคา่คําตอบเรือ่งทีต่อ้งการ 
{10;20;30;40;50} 

3. เมือ่นํา Array {TRUE;FALSE;TRUE;FALSE;FALSE} มาเทยีบตําแหน่งกบั Array 
{10;20;30;40;50} จะได ้Array ตวัเลขเฉพาะตวัเลขคําตอบทีต่อ้งการออกมาเป็น  
{10;FALSE;30;FALSE;FALSE} 

4. จากนัน้เมือ่นําผล {10;FALSE;30;FALSE;FALSE} ไปหายอดรวมดว้ยสตูร Sum จงึหา
คําตอบเป็น 40 ตามตอ้งการ 
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การเลอืกใชส้ตูร Array SumIF ใหเ้หมาะกบังาน 

แมว้า่สตูรทัง้สีแ่บบนีจ้ะหาผลลพัธท์ีต่อ้งการไดเ้ชน่เดยีวกนัก็ตาม แตข่อใหพ้จิารณาเลอืกใชใ้ห ้

เหมาะสมกบังาน กลา่วคอื 

1. สตูร SUMIF ใหใ้ชก้บัโจทยท์ีง่า่ยไปตลอดเพราะสตูรนีรั้บเงือ่นไขไดเ้พยีงเงือ่นไข
เดยีว และสตูรนีใ้ชเ้วลาคํานวณเร็วทีส่ดุในบรรดาสีส่ตูรทีก่ลา่วถงึอยูน่ี ้

2. สตูร Array SumIF สตูรนีเ้ป็นสตูรพเิศษ เพราะเราสามารถเปลีย่นสตูร Sum ดา้นหนา้
ไปเป็นสตูร Average, Count, Max, Min, หรอื Small เพือ่หายอดอืน่ๆตามสตูรทีใ่ช ้
แทนนัน้ และถา้มหีลายเงือ่นก็สามารถซอ้น IF เขา้ไปไดอ้กี 
 
{ =SUM(IF(Id=$G$3,Amount))} หายอดรวมของ a001 ไดเ้ทา่กบั 40 
{ =AVERAGE(IF(Id=$G$3,Amount))} หาคา่เฉลีย่ของ a001 ไดเ้ทา่กบั 20 
{ =COUNT(IF(Id=$G$3,Amount))} นับยอดของ a001 ไดเ้ทา่กบั 2 
{ =MAX(IF(Id=$G$3,Amount))} หายอดสงูสดุของ a001 ไดเ้ทา่กบั 30 
{ =MIN(IF(Id=$G$3,Amount))} หายอดตํา่สดุของ a001 ไดเ้ทา่กบั 10 

3. สตูร SumArray เป็นสตูรทีผ่มนยิมใชเ้พราะใชม้านานและพบวา่สามารถหาคําตอบที่
ตอ้งการไดเ้สมอแมจ้ะลงิคข์า้มแฟ้มมาจากแฟ้มทีไ่มไ่ดเ้ปิดก็ยังทํางานได ้และถา้มี
หลายเงือ่นไข การใชว้งเล็บหลายๆชดุชว่ยตรวจสอบเงือ่นไขยังงา่ยกวา่ทีจ่ะใชส้ตูร IF 
ซอ้นกนัเขา้ไป 

4. สตูร SumProduct เป็นสตูรยอดนยิมของคนทัว่ไปเพราะไมจํ่าเป็นตอ้งกดปุ่ ม 
Ctrl+Shift+Enter ดว้ยแตอ่ยา่งใด ซึง่แทจ้รงิแลว้โครงสรา้งภายในวงเล็บของสตูรนีก้็
เหมอืนกบัของสตูร SumArray น่ันเอง 
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การใชส้ตูร Array IF แบบหลายเงือ่นไข 

กรณี Range ทีใ่ชต้รวจสอบเงือ่นไขมาจากเรือ่งเดยีวกนั ใหใ้ชบ้วก 

 

ใหห้ายอดรวม Amount ของรหสั Id a001 กบั a002 (ทัง้นีท้ีเ่รยีกวา่ เป็นเรือ่งเดยีวกนัเพราะ

เงือ่นไขเป็นเรือ่งของรหสัเชน่กนัทัง้คู)่ โดยบนัทกึรหสัทีต่อ้งการใหใ้ชเ้ป็นรหสัทีค่น้หาไวท้ี่

เซลล ์G3 และ H3 ตามลําดบั ซึง่สามารถใชส้ตูรหาคําตอบเป็นยอดรวม 110 ไดห้ลายวธิ ีดงันี ้

1. ใชส้ตูร {=SUM(IF(Id=G3, Amount, IF(Id=H3,Amount,0) ))} 
 
โดยตอ้งกดปุ่ ม Ctrl+Shift+Enter เพือ่สรา้งเครือ่งหมายวงเล็บปีกกา { } ปิดหวัทา้ย
สตูร ถา้แกะสตูร IF(Id=G3, Amount, IF(Id=H3,Amount,0) ) โดยการคลกิลากทบั
สว่นของสตูรนีแ้ลว้กดปุ่ ม F9 จะได ้Array {10;20;30;0;50} ซึง่เปลีย่นคา่ Amount 
ของรหสัอืน่ทีไ่มเ่ทา่กบั a001 หรอื a002 ใหเ้ทา่กบั 0 แทน 

2. ใชส้ตูร { =SUM(  ((Id=G3)+(Id=H3))  *Amount) } 
 
โดยตอ้งกดปุ่ ม Ctrl+Shift+Enter เพือ่สรา้งเครือ่งหมายวงเล็บปีกกา { } ปิดหวัทา้ย
สตูร ถา้แกะสตูร ((Id=G3)+(Id=H3)) โดยการคลกิลากทบัสว่นของสตูรนีแ้ลว้กดปุ่ ม 
F9 จะได ้Array {1;1;1;0;1} โดยมเีลข 1 ตรงกบัตําแหน่งของรหสัทีต่อ้งการ  
ถา้แกะทีม่าของเงือ่นไข (Id=G3) จะได ้Array ของ 
{TRUE;FALSE;TRUE;FALSE;FALSE} ทีนํ่ามาบวกกบั (Id=H3) ซึง่เป็น Array ของ 
{FALSE;TRUE;FALSE;FALSE;TRUE} ทําใหไ้ด ้Array  
{1;1;1;0;1}  
และเมือ่นํา {1;1;1;0;1} คณูกบั Array ของ Amount {10;20;30;40;50} 
จะได ้Array {10;20;30;0;50} ซึง่รวมคา่ทัง้หมดไดเ้ทา่กบั 110 ตามตอ้งการ 
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3. ใชส้ตูร =SUMPRODUCT(  ((Id=G3)+(Id=H3))  *Amount) 
 
โดยมหีลกัการคํานวณแบบเดยีวกบัวธิทีีส่อง แตไ่มต่อ้งอาศยั { } 

เพือ่ชว่ยทําใหม้องเห็นลําดบัการคํานวณไดช้ดัเจนขึน้ ขอใหด้ภูาพตอ่ไปนีแ้ลว้ดหูลกัการ

คํานวณทลีะขัน้จาก column ซา้ยไปขวา 

 

 Column ที ่1 เป็นรหสั Id จะพบวา่มรีหสั a001 กบั a002 อยู ่4 รายการ 

 Column ที ่2 ตรวจสอบรหสั Id a001 จะพบวา่มรีหสั a001 อยู ่2 รายการ โดยถา้มอง
ตําแหน่งทีเ่ป็นรหสัทีต่อ้งการเป็นเลข 1 และตําแหน่งทีไ่มใ่ชเ่ป็นเลข 0  
จะไดเ้ลข 1, 0, 1, 0, 0 ตามลําดบัจากบนมาลา่ง 

 Column ที ่3 ตรวจสอบรหสั Id a002 จะพบวา่มรีหสั a002 อยู ่2 รายการ โดยถา้มอง
ตําแหน่งทีเ่ป็นรหสัทีต่อ้งการเป็นเลข 1 และตําแหน่งทีไ่มใ่ชเ่ป็นเลข 0  
จะไดเ้ลข 0, 1, 0, 0, 1 ตามลําดบัจากบนมาลา่ง 

 Column ที ่4 เป็นผลรวมเมือ่นํา Column ที ่2 มารวมกบั Column ที ่3  
จะไดเ้ลข 1, 1, 1, 0, 1 ตามลําดบัจากบนมาลา่ง แสดงตําแหน่งของรหสั a001 กบั 
a002 ณ ตําแหน่งทีต่รงกบัเลข 1 

 Column ที ่5 เป็นตวัเลข Amount ทัง้หมด 

 Column ที ่6 เป็นผลคณูเมือ่นํา Column ที ่4 มารวมกบั Column ที ่5 
จะไดเ้ลข 10, 20, 30, 0, 50 ตามลําดบัจากบนมาลา่ง ซึง่รวมเทา่กบั 110 
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การใชส้ตูร Array IF แบบหลายเงือ่นไข 

กรณี Range ทีใ่ชต้รวจสอบเงือ่นไขมาจากตา่งเร ือ่งกนั ใหใ้ชค้ณู 

 

ใหห้ายอดรวม Amount ของรหสั Id a001 เฉพาะรายการทีม่ ีName เทา่กบั c (ทัง้นีท้ีเ่รยีกวา่ 

เป็นตา่งเรือ่งกนั เพราะเงือ่นไขรหสัตา่งจากเงือ่นไขชือ่) โดยบนัทกึรหสัทีต่อ้งการใหใ้ชเ้ป็นรหสั

และชือ่ทีค่น้หาไวท้ีเ่ซลล ์G3 และ H3 ตามลําดบั ซึง่สามารถใชส้ตูรหาคําตอบเป็นยอดรวม 30 

ไดห้ลายวธิ ีดงันี ้

1. ใชส้ตูร { =SUM(IF(Id=G3, IF(Name=H3,Amount,0), 0 ))} 
 
โดยตอ้งกดปุ่ ม Ctrl+Shift+Enter เพือ่สรา้งเครือ่งหมายวงเล็บปีกกา { } ปิดหวัทา้ย
สตูร ถา้แกะสตูร IF(Id=G3, IF(Name=H3,Amount,0), 0 ) โดยการคลกิลากทบัสว่น
ของสตูรนีแ้ลว้กดปุ่ ม F9 จะได ้Array {0;0;30;0;0} ซึง่เปลีย่นคา่ Amount ของรหสั
อืน่ทีไ่มเ่ทา่กบั a001 และชือ่ไมใ่ช ่c ใหเ้ทา่กบั 0 แทน 

2. ใชส้ตูร { =SUM(  (Id=G3)*(Name=H3)  *Amount) } 
 
โดยตอ้งกดปุ่ ม Ctrl+Shift+Enter เพือ่สรา้งเครือ่งหมายวงเล็บปีกกา { } ปิดหวัทา้ย
สตูร ถา้แกะสตูร (Id=G3)*(Name=H3) โดยการคลกิลากทบัสว่นของสตูรนีแ้ลว้กดปุ่ ม 
F9 จะได ้Array {0;0;1;0;0} โดยมเีลข 1 ตรงกบัตําแหน่งรายการทีต่อ้งการ  
 
ถา้แกะทีม่าของเงือ่นไข (Id=G3) จะได ้Array ของ 
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{TRUE;FALSE;TRUE;FALSE;FALSE} นํามาคณูกบั (Name=H3) ซึง่เป็น Array ของ 
{FALSE;FALSE;TRUE;FALSE;FALSE} ทําใหไ้ด ้Array  
{0;0;1;0;0} 
และเมือ่นํา {0;0;1;0;0} คณูกบั Array ของ Amount {10;20;30;40;50} 
จะได ้Array {0;0;30;0;0} ซึง่รวมคา่ทัง้หมดไดเ้ทา่กบั 30 ตามตอ้งการ 

3. ใชส้ตูร =SUMPRODUCT(  (Id=G3)*(Name=H3)  *Amount) 
 
โดยมหีลกัการคํานวณแบบเดยีวกบัวธิทีีส่อง แตไ่มต่อ้งอาศยั { } 

4. ใชส้ตูร =SUMIFS(Amount,Id,G3,Name,H3) เป็นสตูรทีเ่กดิขึน้ใน Excel 2007 
เป็นตน้มา 

เพือ่ชว่ยทําใหม้องเห็นลําดบัการคํานวณไดช้ดัเจนขึน้ ขอใหด้ภูาพตอ่ไปนีแ้ลว้ดหูลกัการ

คํานวณทลีะขัน้จาก column ซา้ยไปขวา 

 

 Column ที ่1 เป็นรหสั Id จะพบวา่มรีหสั a001 อยู ่2 รายการ 

 Column ที ่2 ตรวจสอบรหสั Id a001 จะพบวา่มรีหสั a001 อยู ่2 รายการ โดยถา้มอง
ตําแหน่งทีเ่ป็นรหสัทีต่อ้งการเป็นเลข 1 และตําแหน่งทีไ่มใ่ชเ่ป็นเลข 0  
จะไดเ้ลข 1, 0, 1, 0, 0 ตามลําดบัจากบนมาลา่ง 

 Column ที ่3 เป็นชือ่ Name จะพบวา่มชีือ่ c อยู ่1 รายการ 

 Column ที ่4 ตรวจสอบชือ่ Name c จะพบวา่มชีือ่ Name c อยู ่1 รายการ โดยถา้มอง
ตําแหน่งทีเ่ป็นรหสัทีต่อ้งการเป็นเลข 1 และตําแหน่งทีไ่มใ่ชเ่ป็นเลข 0  
จะไดเ้ลข 0, 0, 1, 0, 0 ตามลําดบัจากบนมาลา่ง 

 Column ที ่5 เป็นผลคณูเมือ่นํา Column ที ่2 มาคณูกบั Column ที ่4  
จะไดเ้ลข 0, 0, 1, 0, 0 ตามลําดบัจากบนมาลา่ง แสดงตําแหน่งของรหสั a001 มชีือ่ 
Name c ณ ตําแหน่งทีต่รงกบัเลข 1 

 Column ที ่6 เป็นตวัเลข Amount ทัง้หมด 
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 Column ที ่7 เป็นผลคณูเมือ่นํา Column ที ่5 มาคณูกบั Column ที ่6 
จะไดเ้ลข 0, 0, 30, 0, 0 ตามลําดบัจากบนมาลา่ง ซึง่รวมเทา่กบั 30 
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วธิหีายอดรวมแยกประเภทดว้ยสตูร DSum 

สตูร DSum เป็นสตูรหนึง่ในกลุม่ของสตูร Database ซึง่ยงัมสีตูรอืน่ๆอกี เชน่ DCount, 

DAverage, DMax, และ DMin ซึง่สตูรเหลา่นีแ้มใ้ชเ้วลาคํานวณเร็วกวา่สตูร Array แตไ่มค่อ่ย

นยิมใชก้นันักเนือ่งจากเงือ่นไขทีใ่ชใ้นการคํานวณตอ้งกําหนดไวใ้นพืน้ทีโ่ดยเฉพาะ ทําใหไ้ม่

ยดืหยุน่ในการใชง้านเทา่กบัสตูร Array 

 

ตามภาพนีต้ารางฐานขอ้มลูชือ่ InputTable คอืพืน้ทีต่ัง้แตเ่ซลล ์B3:D13 ซึง่ตอ้งกําหนด

ขอบเขตใหร้วมถงึพืน้ทีบ่นหวัตาราง B3:D3 ไวด้ว้ย สว่นตารางทีใ่ชกํ้าหนดเงือ่นไขตัง้ชือ่วา่ 

MyCriteria คอืพืน้ทีเ่ซลล ์F3:H5 โดยตอ้งกําหนดใหข้อ้ความในหวัตารางเงือ่นไขนีส้ะกดตรง

กบัตารางฐานขอ้มลู เมือ่ตอ้งการหายอดรวมของรหสั ID: a001 เฉพาะรายการทีม่ยีอดตวัเลข 

Amount มากกวา่ 50 ใหส้รา้งสตูรในเซลล ์G7 ตามนี ้

=DSUM(InputTable,3,MyCriteria) 

เลข 3 หมายถงึใหห้าคําตอบมาจาก Column ที ่3 ในพืน้ทีต่ารางฐานขอ้มลู  

โปรดสงัเกตตารางเงือ่นไขในเซลล ์F5 มคํีาวา่ xyz (หรอืคําอืน่ใดก็ไดท้ีไ่มใ่ชร่หสั) อยูด่ว้ยเพือ่

ชว่ยใหส้ตูร DSum หายอดรวมเฉพาะรหสัที ่a001 เทา่นัน้ หากตอ้งการหายอดรวมของรหสั 

a002 ดว้ยก็ใหเ้ปลีย่น xyz เป็น a002 แตถ่า้เวน้เซลล ์F5 เป็นเซลลว์า่ง จะพบวา่สตูร DSum 

หายอดรวมผดิกลายเป็นหายอดรวมทัง้หมดทกุรายการ  
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วธิใีชค้าํส ัง่ Data Table 

Data Table เป็นคําสัง่ซึง่ชว่ยทําใหส้ตูรทีส่รา้งขึน้มาเพือ่หาคําตอบทีต่อ้งการเพยีงสตูรเดยีว 

ไมจํ่าเป็นตอ้งถกูสรา้งสตูรซํ้าแลว้ซํ้าอกีหลายๆเซลล ์หรอืตารางคํานวณซึง่ประกอบดว้ยสตูร

คํานวณหลายๆขัน้ตอน ก็ไมจํ่าเป็นตอ้งสรา้งตารางคํานวณขึน้มาใหมซ่ํ้ากบัตารางเดมิอกี 

Data Table อาศยัการออกแบบตารางแบบพเิศษทีจ่ะชว่ยให ้Excel นําคา่ทีว่างไวบ้นหวัตาราง

หรอืขา้งตารางดา้นใดดา้นหนึง่หรอืทัง้สองดา้น สง่ตอ่ไปแทนทีค่า่หรอืสตูรทีบ่นัทกึไวใ้นเซลล ์

เมือ่คา่ในเซลลเ์หลา่นัน้เปลีย่นไปตามคําสัง่ Data Table กจ็ะทําใหเ้ซลลส์ตูรทีเ่กีย่วขอ้ง

คํานวณหาคําตอบใหม ่เพยีงแตก่ารเปลีย่นแปลงคา่ในเซลลแ์ละคําตอบใหมท่ีเ่กดิขึน้นัน้ เราจะ

ไมเ่ห็นมกีารเปลีย่นแปลงใดๆเกดิขึน้ในตาราง แตจ่ะพบวา่ Excel นําคําตอบมาสรปุไวใ้นตาราง 

Data Table ใหเ้อง 

Data Table ม ี3 แบบตามจํานวนตวัแปรทีเ่กีย่วขอ้ง ไดแ้ก ่

 Data Table แบบ 1 ตวัแปร  

 Data Table แบบ 2 ตวัแปร 

 Data Table แบบไมจํ่ากดัตวัแปร โดยใชร้ว่มกบัสตูร Index (กลายเป็นวธิทีีฉ่ลาดกวา่
การใช ้Scenarios) 

โครงสรา้งตาราง Data Table แบง่เป็น 4 สว่น ตามรปู 
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Data Table แบบ 1 ตวัแปร 

 

ในภาพนีเ้ซลล ์I3 และ J3 เป็นเซลลส์ตูร VLookup เพือ่หาวา่รหสั NewID a001-2 ซึง่กรอกลง

ไปในเซลล ์H3 นัน้มชีือ่ Name และจํานวน Amount เทา่กบั c และ 30 ตามลําดบั 

เมือ่ตอ้งการหารายละเอยีดของรหสั NewID ตวัอืน่ แทนทีจ่ะตอ้งเสยีเวลากรอกรหสัอืน่ลงไปใน

เซลล ์H3 เพือ่ดคํูาตอบเป็นครัง้ๆไปหรอืจะตอ้งสรา้งสตูร VLookup ทํานองเดยีวกบัสตูรใน

เซลล ์I3 และ J3 ซํ้าอกีเพือ่ใชค้น้หารายละเอยีดของรหสัอืน่ทัง้หมด ใหส้รา้งตาราง Data 

Table แบบ 1 ตวัแปรตามทีเ่ห็นจากภาพนีค้อืตารางจากเซลล ์H5:J10 

ปัญหานีต้อ้งการเปลีย่นรหสัเพยีงคา่เดยีว ดงันัน้จงึเขา้ขา่ย Data Table แบบ 1 ตวัแปร ซึง่มี

โครงสรา้งแยกแยะออกไปอกี 2 แบบยอ่ยตามแตว่า่คณุตอ้งการดตูวัแปรตามแนวใด ไดแ้ก ่

 Data Table แบบวางตวัแปรไวใ้นหวัตารางดา้นขา้งตามแนวตัง้ สว่นหวัตารางดา้นบน
เป็นสตูรคําตอบที ่link มา และเมือ่สัง่ Data Table ใหเ้ลอืกใชช้อ่ง Column Input Cell 

 Data Table แบบวางตวัแปรไวใ้นหวัตารางดา้นบนตามแนวนอน สว่นหวัตารางดา้นขา้ง
เป็นสตูรคําตอบที ่link มา และเมือ่สัง่ Data Table ใหเ้ลอืกใชช้อ่ง Row Input Cell 
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ตวัอยา่งการใช ้Data Table แบบ 1 ตวัแปร โดยวางตวัแปรไวใ้นหวัตารางดา้นขา้งตามแนวตัง้ 

 

1. นํารหสัทีต่อ้งการหารายละเอยีดพมิพล์งในเซลล ์H6:H10 โดยจะกําหนดใหร้หสัใดขึน้
กอ่นหลงัก็ไดแ้ละไมจํ่าเป็นตอ้งเรยีงลําดบัมากนอ้ย 

2. เซลล ์I5 และ J5 สรา้งสตูร link ผลลัพธข์องสตูรคํานวณมาจากเซลล ์I3 และ J3 
ตามลําดบั 

3. ใหเ้ลอืกพืน้ที ่H5:J10 แลว้สัง่ Data > What-If Analysis > Data Table 

4. คลกิลงในชอ่ง Column input cell แลว้คลกิตอ่ไปทีเ่ซลล ์H3 (เพือ่กําหนดให ้Data 
Table ยงิรหสัทีว่างไวต้ามแนวตัง้ไปทีเ่ซลล ์H3) แลว้กดปุ่ ม OK 

5. จะพบคําตอบปรากฏในตาราง I6:J10 และเมือ่คลกิดจูะพบสตูร {=TABLE(,H3)} ซึง่
สตูรนีไ้มส่ามารถสรา้งโดยการพมิพเ์อง แตต่อ้งใชคํ้าสัง่ Data Table เทา่นัน้จงึจะเกดิ
สตูรนีข้ ึน้ และเมือ่ดใูนวงเล็บของสตูรจะพบ (,H3) แสดงถงึการไมใ่ช ้Row Input แตใ่ช ้
Column Input มเีซลล ์H3 เป็นเซลลรั์บคา่ 
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Data Table แบบ 2 ตวัแปร 

 

ตวัอยา่งนีต้อ้งการหายอด Actual ของ Division และ Department ทีก่รอกลงไปในเซลล ์G3 

และ H3 ตามลําดบั โดยคําตอบทีต่อ้งการสามารถใชส้ตูรใดสตูรหนึง่จากสตูรในเซลล ์I3:I8 ซึง่

สรา้งไวเ้พือ่การศกึษา ดงันี ้

 =DSUM(B2:E6,4,G2:H3) 

 =VLOOKUP(G3&H3,D3:E6,2,0) 

 =INDEX(Actual,MATCH(G3&H3,D3:D6,0)) 

 =SUMIF(D3:D6,G3&H3,Actual) 

 =SUMPRODUCT((Division=G3)*(Department=H3)*Actual) 

 =SUMPRODUCT((Division&Department=G3&H3)*Actual) 

เมือ่ตอ้งการหายอด Actual ของแตล่ะ Division และ Department  จงึเขา้ขา่ย Data Table 

แบบ 2 ตวัแปร 

1. พมิพช์ือ่ Department แตล่ะตวัไวใ้นเซลล ์H10:K10 ซึง่ถอืเป็น Row Input 

2. พมิพช์ือ่ Division แตล่ะตวัไวใ้นเซลล ์G11:G14 ซึง่ถอืเป็น Column Input 

3. ในเซลลห์วัมมุตาราง G10 สรา้งสตูร =I3 เพือ่ link สตูรคํานวณหา Actual หรอืจะเลอืก
ลงิคส์ตูรหา Actual จากเซลลใ์ดก็ไดจ้ากสตูรในเซลล ์I3:I8 

4. จากนัน้ใหเ้ลอืกพืน้ทีต่ัง้แต ่G10:K14 แลว้สัง่ Data > What-If Analysis > Data 
Table  

5. คลกิลงไปในชอ่ง Row Input Cell แลว้คลกิตอ่ไปยงัเซลล ์H3 ซึง่รับชือ่ Department 
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6. คลกิลงไปในชอ่ง Column Input Cell แลว้คลกิตอ่ไปยงัเซลล ์G3 ซึง่เป็นเซลลรั์บชือ่ 
Division แลว้กดปุ่ ม OK จะพบคําตอบของยอด Actual แสดงในตาราง H11:K14 
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วธิใีชค้าํส ัง่ Pivot Table 

ในบรรดาคําสัง่ทัง้หมดของ Excel นัน้ Pivot Table จัดวา่เป็นคําสัง่ทีทํ่าใหผู้พ้บเห็นโดยเฉพาะ
ผูบ้รหิารพากนัตืน่เตน้ อยากกระตุน้ใหพ้นักงานของตนใช ้Pivot Table ใหเ้ป็นกนัทกุคน เพราะ
ในชัว่เวลาเพยีงไมก่ีอ่ดึใจก็สามารถสรา้งตารางเปรยีบเทยีบขอ้มลูเพือ่แสดงคําตอบทีต่อ้งการ
โดยไมจํ่าเป็นตอ้งสรา้งสตูรยากๆยาวๆแมแ้ตน่อ้ย ดว้ยเหตนุีเ้อง Pivot Table จงึถกูพัฒนาใหด้ี
ขึน้เรือ่ยๆ กลายเป็นจดุขายทีทํ่าใหผู้ใ้ชโ้ปรแกรม Microsoft Excel ตอ้งหาซือ้โปรแกรม Excel 
รุน่ใหมท่ีม่ ีPivot Table รุน่ลา่สดุมาใชก้นั 

ดว้ยความงา่ยแสนงา่ยในการใช ้Pivot Table หาคําตอบมาใหน้ีเ่อง ทําใหผู้ใ้ช ้Excel ละเลยที่
จะใชส้ตูร กลายเป็นขอ้อา้งวา่ไมต่อ้งเรยีนรูส้ตูรทีต่อ้งสรา้งขึน้มาเองหรอืหาทางใชเ้ครือ่งมอือืน่
ทีอ่าจจะใหคํ้าตอบทีถ่กูตอ้งแมน่ยํากวา่ บางคนใช ้Pivot Table สรา้งตารางขนาดมหมึาเพยีง
เพือ่หาคําตอบเพยีงคา่เดยีว Pivot Table จงึกลบักลายเป็นเครือ่งมอืทีเ่สมอืนกบัการขีช่า้งจับ
ตั๊กแตน ดงันัน้กอ่นทีจ่ะรูจั้กวธิใีช ้Pivot Table มปีระเด็นทีค่วรคํานงึ ดงันี ้

1. Pivot Table ไมใ่ชเ่ครือ่งมอืทีม่ไีวใ้ชห้าคําตอบจากการคํานวณ แต ่Pivot Table เป็น
เครือ่งมอืชว่ยสรา้งตารางเพือ่นําขอ้มลูมาสรปุเป็นตวัเลขเปรยีบเทยีบเพือ่ทราบถงึแนวโนม้ 
ความมากนอ้ย หรอืจัดลําดบัตามความสําคญัใหเ้ห็นเพือ่ใชป้ระกอบการตดัสนิใจ 

2. Pivot Table ไมส่ามารถสรปุขอ้มลูทีเ่ป็นตวัอกัษร เชน่ แสดงรายชือ่ลกูคา้ หรอืรายชือ่สนิคา้ 
โดยขอ้มลูทีเ่ป็นตวัอกัษรจะถกูเลอืกใชเ้ป็นหวัตาราง (Row Label หรอื Column Label) 
ของ Pivot Table ไดเ้ทา่นัน้ 

3. ในการสรา้ง Pivot Table ไมค่วรนําขอ้มลูทีเ่กดิจากสตูรการคํานวณมาใชส้รา้ง เพราะสตูรจะ
ทําใหเ้สยีเวลาในการดงึขอ้มลูมาแสดง แตค่วรใชข้อ้มลูดบิซึง่ปราศจากสตูรคํานวณมาสรปุ
ดว้ย Pivot Table (หากเป็นขอ้มลูทีไ่ดจ้ากการคํานวณควรนําไปใชก้บัคําสัง่ Data Table จะ
เหมาะสมกวา่) 

4. โจทยย์ากๆ เชน่ ใหคํ้านวณหายอดรวมสงูสดุของสนิคา้ 3 รายการแรกทีม่ลีกูคา้เป็นผูช้าย 
ซึง่คําตอบของโจทยป์ระเภทนีแ้มจ้ะใชส้ตูรหาคําตอบไดก้็ตามแตไ่มใ่ชเ่รือ่งทีจ่ะคดิสตูรกนั
ไดง้า่ยๆ จงึจําเป็นตอ้งใช ้Pivot Table 

5. ผลของ Pivot Table เป็นตารางทีไ่มไ่ดอ้ยูใ่นแบบโครงสรา้งฐานขอ้มลูทีด่ ีจงึไมเ่หมาะทีจ่ะ
นําคา่จากตาราง Pivot Table ไปใชต้อ่ในการอา้งองิ หากตอ้งการนําขอ้มลูจากตาราง Pivot 
Table ไปใชใ้นการอา้งองิตอ่ สามารถทําไดห้ลายวธิดีงันี ้
5.1. Copy ตารางไป Paste แบบ Value เพือ่นําขอ้มลูทัง้ตารางทีเ่ป็นผลลพัธไ์ปใช ้แตว่ธินีี้

ตอ้งทําใหมท่กุครัง้ทีม่กีารเปลีย่นแปลงขอ้มลู 
5.2. พมิพเ์ครือ่งหมายเทา่กบั = แลว้คลกิลงไปในเซลลต์วัเลขคําตอบในตาราง Pivot 

Table จะไดส้ตูร =GetPivotData สรา้งขึน้ใหเ้องทนัท ีซึง่สตูรนีจ้ะทําหนา้ทีค่งตวัเลข
คําตอบไวต้ามเดมิเสมอไมว่า่จะมกีารปรับเปลีย่นโครงสรา้งตาราง Pivot Table ใหต้า่ง
ไปจากเดมิก็ตาม 

5.3. ใหด้บัเบลิคลกิลงไปในเซลลผ์ลลพัธต์วัเลขใดๆในตาราง จะพบวา่ Excel สรา้งชทีใหม่
ทีเ่ป็นตารางฐานขอ้มลูซึง่เกีย่วขอ้งและเป็นทีม่าของตวัเลขนัน้ๆ จากนัน้จงึนําตาราง
ใหมน่ีไ้ปใชง้านกบัสตูรดา้นฐานขอ้มลูตอ่ไป 
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6. กอ่นจะนําขอ้มลูไปใชส้รา้ง Pivot Table ตอ้งตรวจสอบและแกไ้ขปรับปรงุขอ้มลูดงันี ้
6.1. หากไมจํ่าเป็นแลว้ ไมค่วรนําขอ้มลูทีเ่ป็นสตูรคํานวณไปใชใ้นการสรา้ง Pivot Table 

เพราะจะทําให ้Excel ทํางานชา้ลง ใหต้รวจสอบวา่เซลลใ์ดมสีตูรโดยกดปุ่ ม F5 > 
Special > กาชอ่ง Formulas 

6.2. ตอ้งแน่ใจวา่ขอ้มลูทีเ่ห็นวา่เป็นตวัเลขมสีถานะทีเ่ป็นตวัเลขจรงิ และขอ้มลูทีเ่ห็นวา่เป็น
ตวัอกัษรมสีถานะเป็นตวัอกัษรจรงิ โดยการทดลองยกเลกิการกําหนด Format ทัง้หมด
เพือ่ทําใหเ้ห็นคา่ทีแ่ทจ้รงิ 

6.3. ขอ้มลูทีเ่ป็นวนัที ่ตอ้งบนัทกึไวใ้นรปูแบบของวนัเดอืนปีและเวลาที ่Excel รูจั้ก เชน่ 
บนัทกึขอ้มลูไวเ้ป็นวนัเดอืนปี 14/2/2012 หรอืเวลา 12:30:45 เพือ่ชว่ยใหส้ามารถใช ้
คําสัง่ใน Pivot Table จัด Group เพือ่สรปุเป็นรายเดอืน รายไตรมาส หรอืตามชว่งระยะ
ทีต่อ้งการไดท้นัท ี

6.4. ตารางขอ้มลูทีจ่ะนํามาใชส้รา้ง Pivot Table ตอ้งอยูใ่นแบบโครงสรา้งฐานขอ้มลูทีด่ ี 
6.5. ขอ้มลูทีเ่ป็นตวัเลข หา้มเวน้เซลลใ์ดเวน้วา่งไว ้โดยตอ้งบนัทกึเลข 0 ไวแ้ทน เพือ่ชว่ย

ให ้Pivot Table นําตวัเลขไปหายอดรวมตามสตูร Sum (ถา้มเีซลลต์วัเลขเวน้วา่งไว ้
Pivot Table จะหาคําตอบแบบนับใหเ้สมอ) โดยกดปุ่ ม F5 > Special > กาชอ่ง 
Blanks เพือ่สัง่ให ้Excel เลอืกเซลลท์ีเ่ป็นชอ่งวา่ง จากนัน้พมิพเ์ลข 0 แลว้กดปุ่ ม 
Ctrl+Enter พรอ้มกนัเพือ่บนัทกึเลข 0 ลงไปในเซลลว์า่งทีเ่ลอืกไว ้

6.6. ควรตัง้ชือ่ Range Name ใหก้บัตารางฐานขอ้มลูเพือ่ความสะดวกในการอา้งองิกบั 
Pivot Table เมือ่มกีารปรับขนาดตารางตา่งไปจากเดมิ โดยชือ่ทีต่ัง้นีต้อ้งกําหนดให ้
ครอบคลมุถงึพืน้ทีเ่ซลลส์ว่นทีเ่ป็นหัวตารางรว่มกบัรายการขอ้มลูทัง้หมด 

6.7. ควรกําหนดรายการทีต่อ้งการใหเ้รยีงลําดบัแบบพเิศษไวใ้น Custom List เพือ่ชว่ยให ้
Pivot Table สรา้งตารางทีม่หีวัตารางเรยีงลําดบัแบบพเิศษนีใ้หด้ว้ย 

7. ตาราง Pivot Table ทีส่รา้งขึน้ควรนํามาใชง้านเพยีงครัง้เดยีว และสรา้งขึน้ในชทีอืน่หรอื
แฟ้มทีแ่ยกตา่งหากจากเรือ่งอืน่ และไมค่วรนําตาราง Pivot Table มาใชซ้ํ้าแลว้ซํ้าอกี 
เพราะอาจหลงลมืวา่ตวัเองไดเ้คยปรับเปลีย่นแกไ้ขอะไรไปแลว้บา้ง 

8. หากจําเป็นตอ้งสรา้ง Pivot Table ขึน้อกีโดยใชฐ้านขอ้มลูเดมิซํ้ากบั Pivot Table ทีม่อียู่
แลว้ ตอ้งสัง่ Refresh กอ่นเสมอ เพราะในความเป็นจรงิแลว้ Pivot Table จะสรา้ง pivot 
cache ขึน้มากอ่นจากนัน้จงึนําขอ้มลูจาก cache ไปสรา้งเป็น Pivot Table อกีทหีนึง่ โดย
ไมไ่ดใ้ชข้อ้มลูจากฐานขอ้มลูตน้ตออกีแตอ่ยา่งใด (ตา่งจาก Excel 2003 ซึง่ผูใ้ชง้าน
สามารถกําหนดไดเ้องวา่จะสรา้ง cache ตวัใหมห่รอืใชต้วัเดมิ) 

9. แทนทีจ่ะสัง่ Refresh ตาราง Pivot Table เพยีงตารางหนึง่ตารางเดยีว ควรใชคํ้าสัง่ 
Refresh All เพือ่ปรับคา่ในทกุตาราง จะไดห้มดปัญหาวา่เป็นตารางทีใ่ช ้cache แยกกนั
หรอืไม ่

10. ผูใ้ช ้Pivot Table ควรเป็นผูส้รา้ง Pivot Table นัน้ขึน้มาเองเพือ่เขา้ใจทีไ่ปทีม่าตัง้แตแ่รกวา่
สรา้งขึน้มาจากฐานขอ้มลูใดและมเีงือ่นไขทีกํ่าหนดไวเ้ป็นพเิศษอยา่งไรบา้ง โดยฝึกหัด
สรา้งตาราง Pivot Table จากฐานขอ้มลูขนาดเล็กๆทีต่นทราบผลลพัธท์ีถ่กูตอ้ง จะไดเ้กดิ
ความมัน่ใจในผลลพัธเ์หลา่นัน้ 
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ข ัน้ตอนการสรา้ง Pivot Table 

ในตวัอยา่งนีเ้ป็นการสรา้ง Pivot Table จากขอ้มลูในแฟ้มชือ่ PivotTableSample.xlsx เพือ่ทํา
ใหเ้กดิแฟ้มใหมสํ่าหรับใชแ้สดง Pivot Table แยกตา่งหากจากแฟ้มฐานขอ้มลู เมือ่ใดทีผู่ใ้ชง้าน
ตอ้งการใช ้Pivot Table แบบใดก็เพยีงเปิดแฟ้มทีส่รา้ง Pivot Table แบบทีต่อ้งการขึน้มา และ
ยงัทําใหแ้ตล่ะแฟ้มม ีcache แยกตา่งหาก ชว่ยหลกีเลีย่งขอ้ผดิพลาดทีอ่าจเกดิขึน้จากการ
เรยีกใช ้cache อกีดว้ย 

 

1. เริม่ตน้จากตัง้ชือ่ Range Name วา่ MyData  ใหก้บัพืน้ทีต่าราง B2:I27 โดยชือ่นี้
ครอบคลมุพืน้ทีส่ว่นทีเ่ป็นหวัตาราง B2:I2 ไวด้ว้ยเพือ่ให ้Pivot Table ใชข้อ้ความบน
หวัตารางในการแยกประเภทของขอ้มลู 

2. เปิดแฟ้มใหมข่ึน้มาแลว้สัง่ Save สมมตวิา่ชือ่ PivotShow1.xlsx 
3. สัง่ Insert > Pivot Table > Pivot Table จะพบหนา้จอ Create PivotTable 

 

 



หนา้ 85 / 97 
 

 

 

© www.ExcelExpertTraining.com 

4. ใหค้ลกิลงในชอ่ง Table/Range: แลว้สัง่ View > Switch Windows เพือ่ไปยงัแฟ้ม
ฐานขอ้มลูชือ่ PivotTableSample.xlsx 

5. ในแฟ้ม PivotTableSample.xlsx ใหค้ลกิลงไปในเซลล ์B2 ซึง่เป็นเซลลห์วัมมุเซลล์
แรกของพืน้ทีต่ารางชือ่ MyData จะไดช้ือ่แฟ้มและตําแหน่งเซลลเ์ริม่ตน้ 
[PivotTableSample.xlsx]Pivot2!$B$2 กรอกใหเ้องในชอ่ง Table/Range: 

 
6. ใหพ้มิพแ์กเ้ฉพาะสว่นของตําแหน่งเซลล ์$B$2 เป็น mydata จะไดข้อ้ความในชอ่ง 

Table/Range: [PivotTableSample.xlsx]Pivot2!mydata แลว้กดปุ่ ม OK (หากไมไ่ด ้
ตัง้ชือ่ Range Name ไวก้อ่น ก็ยงัสามารถใชเ้มาสเ์ลอืกตําแหน่งอา้งองิโดยตรง โดยกด
ปุ่ ม Ctrl+Shift+ลกูศรขวา 1 ครัง้และตามดว้ย Ctrl+Shift+ลกูศรลง 1 ครัง้ เพือ่เลอืก
พืน้ทีฐ่านขอ้มลูทัง้หมด จะได ้[PivotTableSample.xlsx]Pivot2!$B$2:$I$27 แลว้กด
ปุ่ ม OK) 

7. Excel จะเปิดจอ PivotTable Field List ขึน้มาทางดา้นขวาของจอ ใหค้ลกิเลอืกชือ่ 
Field ทีต่อ้งการลงมาใสใ่นชอ่ง Report Filter, Column Labels, Row Labels, และ 
Values จะเกดิตาราง Pivot Table ตามภาพ 
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วธิปีรบัแตง่ Pivot Table 

1. ตัง้แต ่Excel 2007 เป็นตน้มา Pivot Table ทีเ่กดิขึน้จะถกูควบคมุโครงสรา้งผา่นจอ 
PivotTable Field List เป็นหลกั หากผูใ้ชง้านตอ้งการลาก Field บนตวัพืน้ทีข่องตาราง
เองตามวธิทีีเ่คยใชใ้น Excel รุน่เกา่ จะตอ้งปรับระบบโดยสัง่ PivotTable Options > 
Display > กาชอ่ง Classic Pivot Table layout 

 
2. การกําหนด Format ตวัเลขใหเ้หมอืนกนัทัง้ตาราง ใหค้ลกิขวาลงไปเซลลห์วัมมุซา้ย

บนสดุ เชน่ ตามตวัอยา่งนีค้อืเซลลท์ีม่คํีาวา่ Sum of ACTUAL แลว้สัง่ Number 
Format 

3. เมือ่ตอ้งการกรองหารายการสงูสดุกีร่ายการแรกหรอืตํา่สดุกีร่ายการสดุทา้ย ใหค้ลกิทีปุ่่ ม 
Filter ของ Column Labels หรอื Row Labels เลอืก Value Filters > Top 10 แลว้
เลอืก Top หรอื Bottom และกําหนดจํานวนรายการทีต่อ้งการ (ไมจํ่าเป็นตอ้งใช ้10) 

 
4. ถา้สงสยัทีม่าของยอดตวัเลขใด ใหด้ับเบลิคลกิลงไปในเซลลต์วัเลขนัน้ จะเกดิชทีใหม่

แสดงตารางรายการขอ้มลูทีม่าของตวัเลข ซึง่ตารางใหมท่ีไ่ดม้าในชทีใหมน่ีจ้ะมี
โครงสรา้งตามหลกัฐานขอ้มลูทีด่ ีเหมาะสําหรับนําไปใชง้านตอ่ 
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5. ในกรณีทีม่ขีอ้มลูเป็นวนัเดอืนปี เมือ่ตอ้งการจัดกลุม่รายการตามรายเดอืน รายไตรมาส 
หรอืตามชว่งระยะเวลาทีต่อ้งการ ใหเ้ลอืกแสดงขอ้มลูตามรายวนักอ่น แลว้คลกิขวาลง
ไปในเซลลว์ันทีใ่ดก็ได ้สัง่ Group แลว้เลอืก Grouping ตามแบบชว่งระเวลาทีต่อ้งการ 

 
6. Excel สามารถสรา้งชทีใหมแ่ยกตามประเภทรายการทีเ่ลอืก Filter ไวใ้หท้นัทชีทีละ

ประเภท โดยใชเ้มนู PivotTable Tools > Options > Options > Show Report Filter 
Pages 

7. หากตอ้งการใหเ้กดิการ Refresh ขอ้มลูในทนัททีีเ่ปิดแฟ้มขึน้มา ใหส้ัง่ PivotTable 
Options > Data > Refresh data when opening the file โดยคําสัง่นีจ้ะมผีลกบั
ตารางทีกํ่าลังเลอืกอยูเ่ทา่นัน้ ไมไ่ดม้ผีลกบัทกุตาราง 

เร ือ่งแปลกของ Pivot Table 

ใน Excel 2003 และรุน่กอ่นนัน้ เมือ่มกีารสรา้ง Pivot Table ตารางทีส่องขึน้ไปในแฟ้มเดมิ 
ผูใ้ชง้านมสีทิธิเ์ลอืกให ้Excel ใช ้cache ตวัใหมแ่ยกเป็นของตารางใหมห่รอืจะใช ้cache เดมิ
รว่มกบัตารางเดมิก็ได ้หากเลอืกใช ้cache  ตวัใหมก่็จะสง่ผลใหก้าร refresh ไมก่ระทบกบั
ตารางอืน่แตจ่ะทําใหแ้ฟ้มมขีนาดใหญข่ึน้ แตถ่า้ใช ้cache เดมิรว่มกนัแมแ้ฟ้มจะมขีนาดเล็กกวา่
แตเ่มือ่สัง่ refresh ก็จะสง่ผลใหท้กุตารางทีใ่ช ้cache รว่มกนันัน้ปรับคา่ตาม 

จากการทดลองใช ้Excel 2007 และ Excel 2010 พบวา่ เมือ่สรา้งตาราง Pivot Table ตารางที่
สองขึน้ไปในแฟ้มเดมิ จะไมม่กีารถามใหเ้ลอืกใช ้cache เชน่แตก่อ่น พบวา่เมือ่เปลีย่นแปลงคา่
ตวัเลขในฐานขอ้มลูแลว้สัง่ Refresh (ไมไ่ดเ้ลอืก Refresh All) ทกุตาราง Pivot Table จะปรับ
คา่ตวัเลขตามขอ้มลูทีเ่ปลีย่นใหม ่แสดงวา่ทกุตารางใช ้cache ตวัเดยีวกนั (ซึง่หลกัการนีช้ว่ย
ลดความผดิพลาดอนัอาจจะเกดิขึน้หากบางตารางไมย่อมปรับคา่ใหมต่ามเมือ่ Refresh) 

แตจ่ากหนังสอื Pivot Table Data Crunching โดย Bill Jelen หนา้ 41 ยอ่หนา้ที ่3 เขยีน
อธบิายไวว้า่ Excel 2010 จะสรา้ง cache ขึน้มาใหมเ่สมอ 
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การใช ้Excel รบัขอ้มลูจากโปรแกรมอืน่ 

ใครทีค่ดิวา่บรษัิทขนาดใหญไ่มจํ่าเป็นตอ้งใชโ้ปรแกรม Excel ก็ไดเ้พราะมโีปรแกรมสําเร็จรปู 
เชน่ โปรแกรมบญัช ีโปรแกรมขาย โปรแกรมควบคมุสนิคา้ หรอืโปรแกรม SAP ซึง่มรีาคาแพง
แสนแพงใชง้านอยูแ่ลว้ ถอืวา่เป็นความเขา้ใจผดิอยา่งยิง่ บรษัิทยิง่มขีนาดใหญ ่มปีรมิาณขอ้มลู
มหาศาล ยิง่ตอ้งใช ้Excel มากขึน้ เนือ่งจาก Excel มคีวามยดืหยุน่และสะดวกรวดเร็วกวา่การจัด
หนา้ตารายงานใหมด่ว้ยโปรแกรมสําเร็จรปู โดยเฉพาะการจัดทํารายงานเพือ่การบรหิาร 
วเิคราะห ์และตดัสนิใจอยา่งเรง่ดว่น 

แมข้อ้มลูซึง่เก็บไวด้ว้ยโปรแกรมสําเร็จรปูจะมปีรมิาณมหาศาล มจํีานวนรายการเกนิกวา่จํานวน 
row ที ่Excel เตรยีมไวแ้ละไมไ่ดเ้ก็บไวเ้ป็นแฟ้มนามสกลุ xls ก็ตาม Excel มคีวามสามารถ
พเิศษในการเลอืก (Extract) เฉพาะรายการทีต่รงตามเงือ่นไขเขา้มาใชใ้นชทีผา่นคําสัง่ Query 

วธิใีชค้าํส ัง่ Query เพือ่ Connect 

1. เปิด File ใหมว่า่งๆขึน้มาแลว้สัง่ Data > From other Sources > From Microsoft 

Query 

2. ใน Choose Data Source เลอืก <New Data Source> แลว้กด OK 
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3. ใน Create New Data Source ชอ่งที ่1 ใหพ้มิพช์ือ่เรยีกฐานขอ้มลูทีค่ณุตัง้ขึน้เอง ใน

ชอ่งที ่2 ใหค้ลกิเลอืกประเภทของ File ฐานขอ้มลูวา่ใช ้Driver ตวัใด (เลอืกใหต้รงกบั

นามสกลุของแฟ้ม) และในชอ่งที ่3 ใหก้ด Connect (ไมต่อ้งใชช้อ่งที ่4) 

 

4. ใน ODBC dBase Setup ใหต้ดักาในชอ่ง Use Current Directory แลว้กดปุ่ ม Select 

Directory เพือ่หาชือ่ Directory ทีเ่ก็บ File ฐานขอ้มลูนัน้ไว ้ 
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5. กด OK 2 ครัง้เพือ่กลบัไปสู ่Dialog Choose Data Source ตามขัน้ตอนที ่2 สงัเกตวา่จะ

ปรากฏชือ่เรยีกฐานขอ้มลูถกูเลอืกไว ้ใหก้ด OK 

 

 

  

6. Query Wizard จะปรากฏขึน้ 

การใช ้Query Wizard 

1. ใน Choose Columns ใหเ้ลอืกชือ่ Column เฉพาะบางชือ่ทีต่อ้งการในชอ่งดา้นซา้ย 

แลว้กดปุ่ มเครือ่งหมายลกูศร > เพือ่เลอืกมาแสดงในชอ่งดา้นขวา แลว้กดปุ่ ม Next
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2. ใน Filter Data ใหเ้ลอืกนําขอ้มลูเฉพาะทีต่รงตามเงือ่นไขใน Only include rows 

where ทัง้นีจ้ะเลอืกทําขัน้ตอนนีก้บัทกุ Column to filter หรอืไมก่็ไดแ้ลว้กด Next 

 

 

  

3. ใน Sort Order ใหเ้ลอืกลําดบัการจัดเรยีงขอ้มลู วา่ตอ้งการใหจั้ดเรยีงขอ้มลูใดกอ่นหลัง 

แลว้กด Next 
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4. ใน Finish ใหก้ด Finish แลว้ Excel จะใหกํ้าหนดสถานทีค่นืขอ้มลูทีต่อ้งการ เมือ่เลอืก

ตําแหน่งเซลลท์ีต่อ้งการแลว้ใหก้ด OK 

 

 

 

หากตอ้งการ Update Query ขอ้มลูใหม ่ใหก้ดปุ่ ม Refresh บนเมนู Table Tools โดย

ไมจํ่าเป็นตอ้งทําทลีะขึน้ใหมอ่กี 
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การแยกคาํทีต่ดิกนัเป็นพดืออกเป็นเซลลล์ะคาํ 

ในกรณีทีข่อ้มลูซึง่นําเขา้มาจากโปรแกรมสําเร็จรปูหรอืขอ้มลูทีบ่นัทกึไวใ้น Excel มลีกัษณะที่

ตดิตอ่กนัเป็นพดื (ไมไ่ดอ้ยูใ่นโครงสรา้งทีแ่ยกแตล่ะเรือ่งไวเ้ป็นแตล่ะเซลล)์ ใหเ้ริม่จากเลอืก

พืน้ทีข่อ้มลูใน column ทีต่อ้งการแลว้สัง่ Data > Text to Column  

Step 1 of 3 : ใหเ้ลอืก Delimited กรณีแตล่ะคํามจํีานวนตวัอกัษรไมเ่ทา่กนั มฉิะนัน้ใหเ้ลอืก 

Fixed Width 

 

Step 2 of 3 : ใหก้าเครือ่งหมาย Delimiters ทีใ่ชแ้บง่คํา 
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Step 3 of 3 : เลอืก Format ของแตล่ะ Field โดยคลกิหวัของ Field ทีช่อ่ง Data preview 

แลว้กาเลอืกประเภทในชอ่ง Column data format แลว้ใหเ้ลอืกเซลลใ์นชอ่ง Destination: 

ระวงัอยา่ใหซ้ํ้ากบัพืน้ทีซ่ ึง่ใชง้านอยูแ่ลว้ จากนัน้กดปุ่ ม Finish 

 

ผลทีไ่ดจ้ะแยกขอ้มลูทีต่ดิกนัเป็นพดืออกเป็น column แยกออกจากกนั 
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วธิไีปยงัเซลลข์องคา่ทีต่อ้งการคน้หา 

ตามปกตเิราสามารถยา้ยตําแหน่งเซลลไ์ปยงัเซลลท์ีต่อ้งการไดโ้ดยการใชเ้มาสค์ลกิเลอืกเซลล ์

หรอืกดปุ่ มลกูศรบนแป้นพมิพไ์ปเรือ่ยๆ ถา้ตอ้งการไปทีเ่ซลลใ์นชทีอืน่ก็สามารถกดปุ่ ม F5 แลว้

พมิพตํ์าแหน่งหรอืชือ่เซลลท์ีต่อ้งการ หรอืคลกิเลอืกชือ่ Range Name จากชอ่ง Name Box 

ซึง่วธิเีหลา่นีผู้ใ้ชง้านตอ้งทราบตําแหน่งหรอืชือ่เซลลท์ีต่อ้งการ แตถ่า้ทราบแตเ่พยีงตอ้งการไป

ทีค่า่ใดคา่หนึง่ทีต่อ้งการโดยไมท่ราบตําแหน่งทีแ่น่นอนจะทําไดเ้ชน่ไร 

วธิแีรก 

เมือ่สรา้งสตูร Index หรอื Offset หรอืสตูรใดๆทีใ่ชห้าคา่ทีต่อ้งการไดโ้ดยตรงไดแ้ลว้ (เวน้สตูร 

VLookup) ใหใ้ชเ้มาสค์ลกิทีเ่ซลลส์ตูรแลว้คลกิลากเลอืกสตูรทัง้หมดทีเ่ห็นในชอ่ง Formula 

Bar จากนัน้ใหก้ดปุ่ ม F5 แลว้กดปุ่ ม Enter เพยีง 1 ครัง้ จะเห็นตําแหน่งเซลลอ์า้งองิของคา่นัน้

แสดงขึน้มาในชอ่ง Formula Bar แทน พรอ้มกนันัน้ตําแหน่ง Cursor จะยา้ยไปแสดงตําแหน่ง

เซลลนั์น้ตามไปดว้ย เมือ่พบตําแหน่งเซลลข์องคา่ทีต่อ้งการแลว้ใหก้ดปุ่ ม Esc เพือ่แปลง

กลบัมาเป็นสตูรตามเดมิ (ถา้เผลอกดปุ่ ม Enter ตอ่ไปอกีจะทําใหส้ตูรเดมิถกูทําลายกลายเป็น

ตําแหน่งอา้งองิตามปกตแิทน) 

วธิที ี ่2 

คลา้ยกบัวธิแีรกแตจ่ะทําให ้Cursor กระโดดไปยงัเซลลข์องคา่นัน้ไดเ้ลย โดยเริม่จากเมือ่สรา้ง

สตูร Index หรอื Offset หรอืสตูรใดๆทีใ่ชห้าคา่ทีต่อ้งการไดโ้ดยตรงไดแ้ลว้ (เวน้สตูร 

VLookup) ใหจั้ดการ Copy ตวัสตูร (ตา่งจากการ Copy Cell) โดยใชเ้มาสค์ลกิทีเ่ซลลส์ตูรแลว้

คลกิลากเลอืกสตูรทัง้หมดทีเ่ห็นในชอ่ง Formula Bar แลว้คลกิขวาเพือ่สัง่ Copy แลว้ใหก้ดปุ่ ม 

Esc 1 ครัง้ จากนัน้ใหก้ดปุ่ ม F5 แลว้กดปุ่ ม Ctrl+v เพือ่สัง่ Paste ตวัสตูรลงไปในชอ่ง 

Reference แลว้กดปุ่ ม Enter จะพบวา่ Cursor จะยา้ยไปยงัตําแหน่งเซลลข์องคา่นัน้ 

วธิที ี ่3 

ใหต้ัง้ชือ่ Formula Name ใหก้บัสตูร Index หรอื Offset หรอืสตูรใดๆทีใ่ชห้าคา่ทีต่อ้งการได ้

โดยตรง (เวน้สตูร VLookup) โดยในการตัง้ชือ่นีต้อ้งกําหนดตําแหน่งอา้งองิแบบ Absolute 

Reference จากนัน้ใหก้ดปุ่ ม F5 แลว้พมิพช์ือ่ Formula Name ลงไปในชอ่ง Reference แลว้

กดปุ่ ม Enter จะพบวา่ Cursor จะยา้ยไปยงัตําแหน่งเซลลข์องคา่นัน้ ซึง่แนะนําใหใ้ช ้Macro 
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Recorder บนัทกึขัน้ตอนตัง้แตก่ารกดปุ่ ม F5 นีไ้วแ้ลว้สรา้งปุ่ มกดเพือ่ไปยงัเซลลข์องคา่ที่

ตอ้งการไดท้ันททีีค่ลกิลงไปในปุ่ ม (เนือ้หาการใช ้Macro Recorder แสดงไวใ้นหลกัสตูรเคล็ด

การเพิม่ผลงาน ลดความซบัซอ้นของงานดว้ย Excel VBA) 

วธิที ี ่4 

ใหต้ัง้ชือ่ Range Name ใหก้บัเซลลข์องคา่ทีต่อ้งการแลว้นําชือ่ทีต่ัง้นีไ้ปสรา้งเป็น Hyperlink 

เชน่เดยีวกบัการใชง้านบนอนิเตอรเ์น็ต โดยเริม่จากพมิพข์อ้ความใดๆลงไปในเซลลแ์ลว้คลกิขวา

สัง่ HyperLink ใหเ้ลอืก Place in This Document ในชอ่ง Link to: ดา้นซา้ย แลว้คลกิเลอืก

ชือ่ Range Name ทีต่อ้งการในชอ่งดา้นขวา แลว้กดปุ่ ม OK จะพบวา่ขอ้ความทีพ่มิพไ์ว ้

เปลีย่นเป็นสน้ํีาเงนิและถกูขดีเสน้ใตเ้อาไวเ้พือ่แสดงวา่เป็นลงิคท์ีใ่ชเ้มาสค์ลกิได ้

เมือ่คลกิทีล่งิคจ์ะทําให ้Cursor ยา้ยไปยงัเซลลท์ีม่ชี ือ่ Range name นัน้ หากตอ้งการยอ้นกลบั

มาทีตํ่าแหน่งเซลลเ์ดมิ ใหก้ดปุ่ ม F5 แลว้ตามดว้ย Enter 

 

หากตอ้งการสรา้ง HyperLink ทีค่ลกิเพือ่ไปยงัแฟ้มอืน่หรอืเปิดหนา้เว็บ ใหเ้ลอืก Existing File 

or Web Page ในชอ่ง Link to: ดา้นซา้ยแทน แลว้เลอืกชือ่แฟ้มหรอืพมิพตํ์าแหน่งทีอ่ยู ่URL 

http:// ของเว็บ 
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วธิที ี ่5 

ใหต้ัง้ชือ่ Range Name ใหก้บัเซลลข์องคา่ทีต่อ้งการแลว้นําชือ่ทีต่ัง้นีไ้ปสรา้งเป็น Hyperlink 

โดยใชส้ตูร =HyperLink(“ชือ่แฟ้มและตําแหน่งเซลล”์, “ขอ้ความทีแ่สดง”) เชน่ 

=HYPERLINK("[DatabaseDesign.xlsm]"&"Id","Click Here") 

 

[DatabaseDesign.xlsm] เป็นชือ่แฟ้ม 

Id เป็นชือ่ Range Name 

Click Here เป็นขอ้ความทีจ่ะแสดงเป็นลงิคใ์หค้ลกิ 

แทนทีจ่ะตอ้งพมิพช์ือ่แฟ้มลงไปในสตูรนีโ้ดยตรง ซึง่จะใชง้านไมไ่ดห้ากมกีารเปลีย่นชือ่แฟ้ม

ตา่งไปจากเดมิ ใหใ้ชส้ตูรตอ่ไปนีแ้สดงชือ่แฟ้มออกมาใหเ้ห็นในเซลลห์นึง่แลว้จงึลงิคช์ือ่แฟ้มที่

หาไดไ้ปใชใ้นสตูร HyperLink จะยดืหยุน่กวา่ 

=MID(CELL("filename"),FIND("[",CELL("filename")),FIND("]",CELL("filename")

)-FIND("[",CELL("filename"))+1) 

แทนทีจ่ะกําหนดชือ่ Id เป็นชือ่ทีค่งทีไ่ปตลอด สตูร HyperLink จะชว่ยทําใหค้ลกิไปยงัเซลลท์ี่

ตา่งไปจากเดมิไดโ้ดยใชช้ือ่ Range Name เป็นตัวแปรทีกํ่าหนดไวใ้นเซลลอ์กีเซลลห์นึง่ ดงันัน้

สตูรแบบสมบรูณ์ของสตูรนีจ้งึกลายเป็น 

=HYPERLINK(A1&A2,A3) 

 

A1 เป็นเซลลท์ีแ่สดงชือ่แฟ้มทีห่าไดจ้ากสตูร Mid ขา้งตน้ 

A2 เป็นเซลลท์ีแ่สดงชือ่ Range Name 

A3 เป็นเซลลท์ีแ่สดงขอ้ความทีจ่ะแสดงเป็นลงิคใ์หค้ลกิ 

หมายเหต ุ 

เนือ่งจากการคลกิลงไปในเซลลท์ีม่สีตูร HyperLink จะเป็นการสัง่ให ้Cursor ยา้ยไปยงั

ตําแหน่งเซลลอ์ืน่ทีกํ่าหนดไว ้หากตอ้งการแกะดสูตูรในเซลล ์ใหก้ดปุ่ มซา้ยบนเมาสค์ลกิแชล่ง

ไปในเซลลส์ตูร HyperLink สกั 2-3 วนิาทแีลว้จงึปลอ่ยมอืจากเมาส ์


